Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: [SOLVED] non public dns

  1. #1
    Join Date
    Oct 2007
    Location
    Carcavelos, Lisbon
    Posts
    61
    Rep Power
    8

    Default [SOLVED] non public dns

    I'm using zimbra in a local server, non public : local.dyndns.org
    It's configured to get mail from the public server and deliver internally.
    I configured Externel Accounts and Canonical address.
    Everything is wotking perfect, except AS/AV are not filtering the emails.
    I try to use fecthmail, the probem is that fecthmail cannot deliver email to a non public server, allways have this message:
    Host or domain name not found. Name service error
    for name=local.dyndns.pt type=A: Host not found
    My fetchmail configuration file is:
    poll mail.domain.com
    protp pop3
    user "user1"
    pass "pass1"
    is userx@local.dyndns.org
    nokeep
    fetchall

    The goal is to filter emails with AV/AS.
    Can you tell me if there is a solution for that?

  2. #2
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Bug 14047 – AntiSpam doesn't work with external POP3 Account

    Though there is no reason why you cannot do what you want using fetchmail; you just need to ensure you have a valid MX and A record for your domain by using a Wiki :: Split DNS architecture.

  3. #3
    Join Date
    Oct 2007
    Location
    Carcavelos, Lisbon
    Posts
    61
    Rep Power
    8

    Default

    I am using a split DNS and everything works fine except for fetchmail. I can use outlook and thunderbird internally and access webmail from outside. I don't know why but seems that fecthmail does not look for the local DNS.
    Maybe it go trough default gateway, and since local.dyndns.org is not an MX public name it does not find it.

  4. #4
    Join Date
    Oct 2007
    Location
    Carcavelos, Lisbon
    Posts
    61
    Rep Power
    8

    Default

    One more thing. If I send an email from the command line in the Zimbra zerver, like this
    #mail userx@local.dyndns.org

    I can receive the email.
    It seems that fecthmail works in a different way.

  5. #5
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    fetchmail just pushes the email into your local SMTP server. You say local.dyndns.org yet in the error message it says
    local.dyndns.pt type=A: Host not found
    so is that another domain you handle ? If so then that should have a MX and associated A record aswell.

  6. #6
    Join Date
    Oct 2007
    Location
    Carcavelos, Lisbon
    Posts
    61
    Rep Power
    8

    Default

    Sorry, I type it incorrectly. The correct is local.dyndns.org type=A: Host not found

    From a PC I can browse http://local.dyndns.org

  7. #7
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Code:
    cat /etc/hosts
    cat /etc/resolv.conf
    dig yourdomain mx
    dig yourdomain any
    host `hostname` <- note backticks and not single quotes

  8. #8
    Join Date
    Oct 2007
    Location
    Carcavelos, Lisbon
    Posts
    61
    Rep Power
    8

    Default

    cat /etc/hosts
    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    192.168.5.200 local.dyndns.org local zonalogic2
    ::1 localhost6.localdomain6 localhost6
    127.0.0.1 localhost.localdomain localhost zonalogic2


    cat /etc/resolv.conf
    nameserver 192.168.5.200

    dig local.dyndns.org mx

    ; <<>> DiG 9.4.2 <<>> local.dyndns.org mx
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 10929
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 1

    ;; QUESTION SECTION:
    ;local.dyndns.org. IN MX

    ;; ANSWER SECTION:
    local.dyndns.org. 86400 IN MX 10 local.dyndns.org.

    ;; AUTHORITY SECTION:
    local.dyndns.org. 86400 IN NS 192.168.5.200.local.dyndns.org.

    ;; ADDITIONAL SECTION:
    local.dyndns.org. 86400 IN A 192.168.5.200

    ;; Query time: 12 msec
    ;; SERVER: 192.168.5.200#53(192.168.5.200)
    ;; WHEN: Wed Apr 29 15:45:27 2009
    ;; MSG SIZE rcvd: 97



    dig local.dyndns.org any

    ; <<>> DiG 9.4.2 <<>> local.dyndns.org any
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 36962
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 4, AUTHORITY: 0, ADDITIONAL: 1

    ;; QUESTION SECTION:
    ;local.dyndns.org. IN ANY

    ;; ANSWER SECTION:
    local.dyndns.org. 86400 IN SOA local.dyndns.org. ferra.local.dyndns.org. 1 7200 3600 604800 86400
    local.dyndns.org. 86400 IN NS 192.168.5.200.local.dyndns.org.
    local.dyndns.org. 86400 IN MX 10 local.dyndns.org.
    local.dyndns.org. 86400 IN A 192.168.5.200

    ;; ADDITIONAL SECTION:
    local.dyndns.org. 86400 IN A 192.168.5.200

    ;; Query time: 0 msec
    ;; SERVER: 192.168.5.200#53(192.168.5.200)
    ;; WHEN: Wed Apr 29 15:47:54 2009
    ;; MSG SIZE rcvd: 155


    host `hostname`
    local.dyndns.org has address 192.168.5.200
    local.dyndns.org mail is handled by 10 local.dyndns.org.

  9. #9
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Why is the FQDN of your server eg. local.dyndns.org the domain aswell ? Your hosts file is incorrect aswell as it should be
    Code:
    192.168.5.200 local.dyndns.org
    ::1 localhost6.localdomain6 localhost6
    127.0.0.1 localhost.localdomain localhost
    as you have put in a short name of local which according to your dig forms part of the domain name local.dyndns.org

  10. #10
    Join Date
    Oct 2007
    Location
    Carcavelos, Lisbon
    Posts
    61
    Rep Power
    8

    Default

    I have changed hosts:

    cat /etc/hosts
    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    192.168.5.200 local.dyndns.org
    ::1 localhost6.localdomain6 localhost6
    127.0.0.1 localhost.localdomain localhost

    but still the same problem.

    Should I need to configure FQDN of server different from the domain?

Similar Threads

  1. Zimbra and Exchange coexistence.
    By kajetan in forum Migration
    Replies: 10
    Last Post: 10-13-2010, 04:01 AM
  2. GAL not working with Active Directory
    By ardiederich in forum Installation
    Replies: 13
    Last Post: 02-12-2008, 07:01 PM
  3. :( DNS Lookup issues
    By jhgutierrezg in forum Administrators
    Replies: 3
    Last Post: 05-30-2007, 08:00 AM
  4. DNS in a nutshell part two (For dummies)
    By daimer77 in forum Installation
    Replies: 4
    Last Post: 12-18-2006, 05:28 PM
  5. DNS Strategies and Best Practices, and a SLES10 Request
    By LMStone in forum Administrators
    Replies: 4
    Last Post: 10-14-2006, 07:51 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •