Page 2 of 2 FirstFirst 12
Results 11 to 12 of 12

Thread: ZCS on CentOS w/ more than 4GB of RAM ??

  1. #11
    Join Date
    Jan 2008
    Posts
    20
    Rep Power
    7

    Default

    I tried doing the 32 to 64 bit migration but never could get it to work. I ended up going from centos4_32 with 4gb of ram to centos5_32 with 12gb ram on a different server using rsync and ip blocking scripts. on old one was 5.21NE, rsynced /opt/zimbra to /opt/zimbra_ori on new one. Changed IP, blocked ports, ran installer. Stopped service ,removed the zimbra folder, moved /opt/zimbra_ori to /opt/zimbra, installed 5.21 again(upgrade), grinded through it and it looked like it worked.

    Mailboxd would never start. after much googling found I had to change the the memory size in /opt/zimbra/bin/zmmailboxdctl

    changed
    jm=`expr $memkb ‘*’ ${mailboxd_java_heap_memory_percent} / 100 / 1024`
    to
    jm=2048

    worked like a champ! I thought, hey! I've got this far, lets upgrade to 6.04NE!!

    Followed regular instructions and did same thing as before, mailboxd wouldn't start. Went back to the /opt/zimbra/bin/zmmailboxdctl and it was different than before, so after playing with percentages did the following...

    changed
    mailboxd_java_heap_memory_percent=${mailboxd_java_ heap_memory_percent:=30}
    mailboxd_java_heap_new_size_percent=${mailboxd_jav a_heap_new_size_percent:=25}

    to
    mailboxd_java_heap_memory_percent=${mailboxd_java_ heap_memory_percent:=15}
    mailboxd_java_heap_new_size_percent=${mailboxd_jav a_heap_new_size_percent:=18}

    hope this help someone as I burned a lot of midnight oil on this. Looking back I am wondering if was same problem with my attempt at 64bit migration. It has 48gb of ram, maybe a limitation to the memory size even in 64bit version of the java heap size??

    thanks,
    Robert

  2. #12
    Join Date
    Dec 2009
    Location
    Singapore and India
    Posts
    42
    Rep Power
    5

    Default

    Hmmm... quite wierd... i have set the java heap percent to 40 and some ldap optimization for number of threads etc. on a Dual Xeon 24GB ram machine with Centos 64. No problems at all. Runs smooth
    VBNCloud & VBNMail - Administrator
    Zimbra OSS with Full Cloud Files/Gallery Services [Under Dev]

Similar Threads

  1. Trouble Sending mail - All Messages deferred!
    By SiteDiscovery in forum Administrators
    Replies: 7
    Last Post: 09-03-2009, 04:52 AM
  2. Mail is being queued, not delivered!
    By icepick94 in forum Administrators
    Replies: 12
    Last Post: 01-22-2009, 06:03 AM
  3. Replies: 41
    Last Post: 10-29-2007, 02:36 PM
  4. ZCS 3.2 Beta Available
    By KevinH in forum Announcements
    Replies: 31
    Last Post: 07-07-2006, 03:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •