I am trying (literally for days) to install the open version of ZCS on a new install of CentOS5. I have Googled, Wikied and Forumed over and over. So now, I'm trying here, hoping someone will take pity on me...

Computer is totally naked on the Internet and has a static IP.
CentOS install seems to go fine.
I disable SELinux and Firewall.
I put my naked IP, FQDN including hostname, and nickname into /etc/hosts.
I do yum update.
Remove sendmail.
Install openssl097a, compat-libstdc++-296, compat-libstdc++-33, compat-db & libtool-ltdl.
I comment out "defaults requiretty" in /etc/sudoers.
I delete the line LANG="en_us.utf-8" in /etc/sysconfig/i18n.
I install fetchmail.
I'm using the open RHEL5 version of ZCS.
Download and unpack ZCS into /var/tmp OK.
./install.sh --platform-override

I have to change the domain from hostname. domainname.com to domainname.com or the DNS tests fail.

I have to use the menus to put in a password so it goes from UNSET to SET.

Things seemingly go OK until ldap tries to initialize. It times out. In the log files I get an error about sudoers is 0640 should be 0440.

I have searched /opt/zimbra/libexec/zmsetup.pl for sudoers, 0640 & 0440. None are present in the file. I have seen suggestions to edit the file regarding this.

I'm so close to getting this to work that I can taste it. I suspect something simple, but can't identify it. Any and all assistance will be greatly appreciated!

Log file follows:

Sun May 10 13:50:28 2009 Saving config in /opt/zimbra/config.23005...
Sun May 10 13:50:28 2009 done.
Sun May 10 13:50:30 2009 Operations logged to /tmp/zmsetup.05102009-135000.log
Sun May 10 13:50:30 2009 checking isEnabled zimbra-ldap
Sun May 10 13:50:30 2009 zimbra-ldap is enabled
Sun May 10 13:50:30 2009 Initializing ldap...
Sun May 10 13:50:30 2009 *** Running as zimbra user: /opt/zimbra/libexec/zmldapinit
sudo: /etc/sudoers is mode 0640, should be 0440
sudo: /etc/sudoers is mode 0640, should be 0440
sudo: /etc/sudoers is mode 0640, should be 0440
sudo: /etc/sudoers is mode 0640, should be 0440
sudo: /etc/sudoers is mode 0640, should be 0440
sudo: /etc/sudoers is mode 0640, should be 0440
sudo: /etc/sudoers is mode 0640, should be 0440
IO::Socket::INET: connect: No route to host at /opt/zimbra/libexec/zmldapinit line 160.
Sun May 10 13:51:13 2009 failed. (28928)
Sun May 10 13:51:13 2009

ERROR

Sun May 10 13:51:14 2009

Configuration failed

Sun May 10 13:51:14 2009 Please address the error and re-run /opt/zimbra/libexec/zmsetup.pl to
Sun May 10 13:51:14 2009 complete the configuration.
Sun May 10 13:51:14 2009
Errors have been logged to /tmp/zmsetup.05102009-135000.log