Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: Zimbra won't work after a reboot

  1. #1
    Join Date
    May 2009
    Posts
    15
    Rep Power
    6

    Default Zimbra won't work after a reboot

    Hi every one,
    i''m new and i'm trying to use zimbra in a testing environement, but it won't work, yestarday every thing worked fine, till this morning zimbra mailbox won't start.

    # nslookup mail.mydomain.ma
    Server: 172.16.1.125
    Address: 172.16.1.125#53

    Name: mail.mydomain.ma
    Address: 172.16.1.125

    Code:
    # su zimbra
    $ zmcontrol status
    Unable to determine enabled services from ldap.
    Enabled services read from cache. Service list may be inaccurate.
    Host machinevirt0.mydomain.ma
    	antispam                Stopped
    		zmmtaconfigctl is not running
    		zmamavisdctl is not running
    	antivirus               Stopped
    		zmmtaconfigctl is not running
    		zmamavisdctl is not running
    		zmclamdctl is not running
    	ldap                    Stopped
    	logger                  Stopped
    		logmysql.server is not running
    		zmlogswatchctl is not running
    	mailbox                 Stopped
    		zmmtaconfigctl is not running.
    		mysql.server is not running.
    		zmmailboxdctl is not running.
    	mta                     Stopped
    		zmmtaconfigctl is not running
    		postfix is not running
    		zmsaslauthdctl is not running
    	snmp                    Stopped
    		zmswatch is not running.
    	spell                   Stopped
    		zmapachectl is not running
    	stats                   Stopped
    and when i try to start it :
    Code:
    $ zmcontrol start
    Host machinevirt0.mydomain.ma
    	Starting ldap...Done.
    	Starting logger...Done.
    	Starting mailbox...Done.
    	Starting antispam...Done.
    	Starting antivirus...Done.
    	Starting snmp...Done.
    	Starting spell...Done.
    	Starting mta...Done.
    	Starting stats...Done.
    but when i start firefox with : https://172.16.1.127:7071/, i got nothing.

    i apologize for my bad english.

  2. #2
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Welcome to the forums

    Please post the following information so we can help
    Code:
    cat /etc/hosts
    cat /etc/resolv.conf
    dig yourdomain mx
    dig yourdomain any
    host `hostname` <- note backticks and not single quotes
    Are you behind a firewall on a private IP ? If so you will need to setup a Wiki :: Split DNS architecture.

  3. #3
    Join Date
    May 2009
    Posts
    15
    Rep Power
    6

    Default

    /etc/hosts :
    Code:
    # cat /etc/hosts
    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    127.0.0.1		localhost.localdomain localhost
    #::1			localhost6.localdomain6 localhost6
    /etc/resolv.conf
    Code:
    # cat /etc/resolv.conf 
    ; generated by /sbin/dhclient-script
    search mydomain.ma
    nameserver 172.16.1.125
    Code:
    # dig mydomain.ma mx
    
    ; <<>> DiG 9.3.4-P1 <<>> mydomain.ma mx
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 44423
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;mydomain.ma.			IN	MX
    
    ;; AUTHORITY SECTION:
    mydomain.ma.		3600	IN	SOA	localhost. root.localhost. 2 10800 3600 604800 3600
    
    ;; Query time: 1 msec
    ;; SERVER: 172.16.1.125#53(172.16.1.125)
    ;; WHEN: Tue May 12 10:53:38 2009
    ;; MSG SIZE  rcvd: 77
    Code:
    # dig mydomain.ma any
    
    ; <<>> DiG 9.3.4-P1 <<>> mydomain.ma any
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 18811
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 2
    
    ;; QUESTION SECTION:
    ;mydomain.ma.			IN	ANY
    
    ;; ANSWER SECTION:
    mydomain.ma.		43200	IN	SOA	localhost. root.localhost. 2 10800 3600 604800 3600
    mydomain.ma.		3600	IN	NS	localhost.
    
    ;; ADDITIONAL SECTION:
    localhost.		86400	IN	A	127.0.0.1
    localhost.		86400	IN	AAAA	::1
    
    ;; Query time: 0 msec
    ;; SERVER: 172.16.1.125#53(172.16.1.125)
    ;; WHEN: Tue May 12 10:53:54 2009
    ;; MSG SIZE  rcvd: 135
    Code:
    # host `hostname` 
    machinevirt0.mydomain.ma has address 172.16.1.127
    No im not using any thing it's only on the same LAN.

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Please read the Quick Start Installation Guide for details of the required hosts file format. You'll also need a Split DNS set-up on your LAN, yes you really do need it for a LAN. These subjects have been covered (and answered) many times in the forums if you'd care to search.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    Join Date
    May 2009
    Posts
    15
    Rep Power
    6

    Default

    i fixed my dns this is what i got on /var/log/zimbra.log

    Code:
    May 12 14:08:08 machinevirt0 zmmailboxdmgr[6512]: stale pid 27195 found in /opt/zimbra/log/zmmailboxd_manager.pid: No such process
    May 12 14:08:08 machinevirt0 zmmailboxdmgr[6512]: assuming no other instance is running
    May 12 14:08:08 machinevirt0 zmmailboxdmgr[6512]: file /opt/zimbra/log/zmmailboxd.pid does not exist
    May 12 14:08:08 machinevirt0 zmmailboxdmgr[6512]: assuming no other instance is running
    May 12 14:08:08 machinevirt0 zmmailboxdmgr[6512]: no manager process is running
    May 12 14:09:16 machinevirt0 zmmailboxdmgr[6827]: status requested
    and i got this message repeated several times.

    Any one can help ??

  6. #6
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Please post again what I asked for earlier so we can confirm that your DNS is all okay now.

  7. #7
    Join Date
    May 2009
    Posts
    15
    Rep Power
    6

    Default

    thanks uxbod

    here is the new config :
    Code:
    #dig mydomain.ma  mx
    
    ; <<>> DiG 9.3.4-P1 <<>> mydomain.ma mx
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 24215
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;mydomain.ma.			IN	MX
    
    ;; AUTHORITY SECTION:
    mydomain.ma .		3600	IN	SOA	localhost. root.localhost. 2 10800 3600 604800 3600
    
    ;; Query time: 10 msec
    ;; SERVER: 172.16.1.125#53(172.16.1.125)
    ;; WHEN: Tue May 12 14:20:08 2009
    ;; MSG SIZE  rcvd: 77
    Code:
    dig mydomain.ma any
    
    ; <<>> DiG 9.3.4-P1 <<>> mydomain.ma any
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 45567
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 2
    
    ;; QUESTION SECTION:
    ;mydomain.ma.			IN	ANY
    
    ;; ANSWER SECTION:
    mydomain.ma.		43200	IN	SOA	localhost. root.localhost. 2 10800 3600 604800 3600
    mydomain.ma.		3600	IN	NS	localhost.
    
    ;; ADDITIONAL SECTION:
    localhost.		86400	IN	A	127.0.0.1
    localhost.		86400	IN	AAAA	::1
    
    ;; Query time: 0 msec
    ;; SERVER: 172.16.1.125#53(172.16.1.125)
    ;; WHEN: Tue May 12 14:24:22 2009
    ;; MSG SIZE  rcvd: 135
    etc/resolv.conf ,host `hostname` and /etc/hosts stays the same.
    can u please explain where can you see where something is going wrong ?

  8. #8
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    As Phoenix said please read through Zimbra Collaboration Suite Single Server Installation - Open Source especially the section about /etc/hosts

  9. #9
    Join Date
    May 2009
    Posts
    15
    Rep Power
    6

    Default

    do the file /etc/hosts have to look like this :

    127.0.0.1 localhost.localdomain localhost
    172.16.1.127 machinevirt0.mydomain.ma

  10. #10
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Indeed Then the server can resolve its FQDN.

Similar Threads

  1. Replies: 8
    Last Post: 01-20-2009, 01:06 PM
  2. Upgrade to ZCS 5.10
    By blozancic in forum Installation
    Replies: 0
    Last Post: 10-21-2008, 09:03 AM
  3. Replies: 12
    Last Post: 02-25-2008, 07:28 PM
  4. zmtlsctl give LDAP error
    By sourcehound in forum Administrators
    Replies: 5
    Last Post: 03-11-2007, 04:48 PM
  5. Zimbra server crashed
    By goetzi in forum Administrators
    Replies: 6
    Last Post: 03-25-2006, 01:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •