Results 1 to 5 of 5

Thread: bdb_db_open: alock package is unstable

  1. #1
    Join Date
    May 2006
    Posts
    19
    Rep Power
    9

    Default bdb_db_open: alock package is unstable

    So folks... wow. ive got to say i want to get this to work... Bad...
    sladp will not start. So after alot of looking I cam across a command to help me figure out whats going on...
    Code:
    /opt/zimbra/openldap/libexec/slapd -d1 -l LOCAL0 -4 -u zimbra -h 'ldaps:// ldap://:389/' -f /opt/zimbra/conf/slapd.conf -o slp=off
    It outputs this 9just the ending area...
    Code:
    config_build_entry: "cn={1}cosine"
    config_build_entry: "cn={2}inetorgperson"
    config_build_entry: "cn={3}amavisd"
    config_build_entry: "cn={4}zimbra"
    config_build_entry: "olcDatabase={-1}frontend"
    config_build_entry: "olcDatabase={0}config"
    config_build_entry: "olcDatabase={1}bdb"
    backend_startup_one: starting ""
    bdb_db_open: alock package is unstable
    backend_startup_one: bi_db_open failed! (-1)
    runwired.sytes.net shutdown: initiated
    ====> bdb_cache_release_all
    runwired.sytes.net destroy: freeing system resources.
    slapd stopped.
    connections_destroy: nothing to destroy.
    help please... I have another solution ready to install however before I open that can of worms I'd like to verify this solution... And use it hopefully...

  2. #2
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    So how exactly did this happen? Did you try to upgrade to the 3.1.1 version?

    If so, which version were you running before.

    Also, every time you do anything with Zimbra, it's best to restore to a backup. Do you have one?

    If so, It may be helpful to restore to it.

    ed: I also noticed you posted in the fedora core 4 how to after you posted here. You indicated you had solved the problem. Is this related?

  3. #3
    Join Date
    May 2006
    Posts
    19
    Rep Power
    9

    Default yes solved and reolved... On FC4

    hwever on FC5 i get an error number 256 when attempting to start sLDAP on FC5 any idead to that?

  4. #4
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    FC5 isn't quite supported yet.

  5. #5
    Join Date
    May 2006
    Posts
    19
    Rep Power
    9

    Default Yeah...

    LOL I figured that... I was hoping there was a way to get it to work... And If not a better estimate on release dates other than within the next month... Please...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •