Results 1 to 6 of 6

Thread: migrated zimbra vmware image, zimbra acting strange??

  1. #1
    Join Date
    Mar 2007
    Posts
    21
    Rep Power
    8

    Default migrated zimbra vmware image, zimbra acting strange??

    Hi there,

    Zimbra runs/is stored on a vmware image on a mirror RAID array on one of my machines, the boot drive died, so i bought a new one, reinstalled the OS, and fired up the vmware image. It booted fine as usual however zimbra doesnt respond on the web interface.

    I checked zmcontrol status before and mysql didn't load properly or something, which i thought was odd, upon zmcontrol restart this magically fixed itself. note: i have not touched this image for like 6 months. it has run 24x7 perfectly prior to that.

    after an image reboot and restarting zimbra everything came up fine, however i can't seem to access the zimbra login.

    here's my zimbra login from startup:

    Code:
    May 17 00:16:52 lina zimbramon[14147]: 14147:info: Starting services initiated by zmcontrol 
    May 17 00:16:53 lina slapd[14214]: @(#) $OpenLDAP: slapd 2.3.43 (Aug 20 2008 12:21:57) $ ^Iroot@build25.lab.zimbra.com:/home/build/p4/FRANKLIN/ThirdParty/openldap/openldap-2.3.43.5z/servers/slapd 
    May 17 00:16:53 lina slapd[14215]: slapd starting 
    May 17 00:17:00 lina zimbramon[14147]: 14147:info: Rewriting configs  antispam amavis antivirus amavis   webxml mailbox amavis antispam antivirus mta sasl    
    May 17 00:17:10 lina zimbramon[14147]: 14147:info: Starting logger via zmcontrol 
    May 17 00:17:10 lina zimbramon[14147]: 14147:info: Starting mailbox via zmcontrol 
    May 17 00:17:11 lina zimbramon[14760]: 14760:info: zmmtaconfig: zmmtaconfig started on lina.seravitae.com with loglevel=3 pid=14760 
    May 17 00:17:42 lina zmmailboxdmgr[15586]: status requested
    May 17 00:17:42 lina zmmailboxdmgr[15586]: file /opt/zimbra/log/zmmailboxd_manager.pid does not exist
    May 17 00:17:42 lina zmmailboxdmgr[15586]: assuming no other instance is running
    May 17 00:17:42 lina zmmailboxdmgr[15586]: file /opt/zimbra/log/zmmailboxd.pid does not exist
    May 17 00:17:42 lina zmmailboxdmgr[15586]: assuming no other instance is running
    May 17 00:17:42 lina zmmailboxdmgr[15586]: no manager process is running
    May 17 00:17:42 lina zmmailboxdmgr[15593]: start requested
    May 17 00:17:42 lina zmmailboxdmgr[15593]: checking if another instance of manager is already running
    May 17 00:17:42 lina zmmailboxdmgr[15593]: file /opt/zimbra/log/zmmailboxd_manager.pid does not exist
    May 17 00:17:42 lina zmmailboxdmgr[15593]: assuming no other instance is running
    May 17 00:17:42 lina zmmailboxdmgr[15593]: file /opt/zimbra/log/zmmailboxd.pid does not exist
    May 17 00:17:42 lina zmmailboxdmgr[15593]: assuming no other instance is running
    May 17 00:17:42 lina zmmailboxdmgr[15594]: wrote manager pid 15594 to /opt/zimbra/log/zmmailboxd_manager.pid
    May 17 00:17:42 lina zmmailboxdmgr[15595]: wrote java pid 15595 to /opt/zimbra/log/zmmailboxd_java.pid
    May 17 00:17:42 lina zmmailboxdmgr[15594]: manager started mailboxd/JVM with pid 15595
    May 17 00:17:42 lina zimbramon[14147]: 14147:info: Starting antispam via zmcontrol 
    May 17 00:17:44 lina amavis[15621]: starting.  /opt/zimbra/amavisd/sbin/amavisd at lina.seravitae.com amavisd-new-2.5.4 (20080312), Unicode aware, LANG="en_AU.UTF-8"
    May 17 00:17:44 lina amavis[15621]: user=1001, EUID: 1001 (1001);  group=, EGID: 1001 1002 1001 5 4 (1001 1002 1001 5 4)
    May 17 00:17:44 lina amavis[15621]: Perl version               5.008008
    May 17 00:17:45 lina amavis[15621]: SpamControl: init_pre_chroot done
    May 17 00:17:45 lina amavis[15634]: Net::Server: Process Backgrounded
    May 17 00:17:45 lina amavis[15634]: Net::Server: 2009/05/17-00:17:45 Amavis (type Net::Server::PreForkSimple) starting! pid(15634)
    May 17 00:17:45 lina amavis[15634]: Net::Server: Binding to UNIX socket file /opt/zimbra/data/amavisd/amavisd.sock using SOCK_STREAM
    May 17 00:17:45 lina amavis[15634]: Net::Server: Binding to TCP port 10024 on host 127.0.0.1
    May 17 00:17:45 lina amavis[15634]: Net::Server: Group Not Defined.  Defaulting to EGID '1001 1002 1001 5 4'
    May 17 00:17:45 lina amavis[15634]: Net::Server: User Not Defined.  Defaulting to EUID '1001'
    May 17 00:17:45 lina zimbramon[14147]: 14147:info: Starting antivirus via zmcontrol 
    May 17 00:17:45 lina amavis[15634]: Module Amavis::Conf        2.094
    May 17 00:17:45 lina amavis[15634]: Module Archive::Zip        1.23
    May 17 00:17:45 lina amavis[15634]: Module Compress::Zlib      1.42
    May 17 00:17:45 lina amavis[15634]: Module Convert::TNEF       0.17
    May 17 00:17:45 lina amavis[15634]: Module Convert::UUlib      1.11
    May 17 00:17:45 lina amavis[15634]: Module DBD::mysql          4.007
    May 17 00:17:45 lina amavis[15634]: Module DBI                 1.605
    May 17 00:17:45 lina amavis[15634]: Module DB_File             1.817
    May 17 00:17:45 lina amavis[15634]: Module Digest::MD5         2.36
    May 17 00:17:45 lina amavis[15634]: Module Digest::SHA1        2.11
    May 17 00:17:45 lina amavis[15634]: Module MIME::Entity        5.426
    May 17 00:17:45 lina amavis[15634]: Module MIME::Parser        5.426
    May 17 00:17:45 lina amavis[15634]: Module MIME::Tools         5.426
    May 17 00:17:45 lina amavis[15634]: Module Mail::Header        2.03
    May 17 00:17:45 lina amavis[15634]: Module Mail::Internet      2.03
    May 17 00:17:45 lina amavis[15634]: Module Mail::SpamAssassin  3.002005
    May 17 00:17:45 lina amavis[15634]: Module Net::DNS            0.63
    May 17 00:17:45 lina amavis[15634]: Module Net::LDAP           0.36
    May 17 00:17:45 lina amavis[15634]: Module Net::Server         0.97
    May 17 00:17:45 lina amavis[15634]: Module Time::HiRes         1.9715
    May 17 00:17:45 lina amavis[15634]: Module URI                 1.37
    May 17 00:17:45 lina amavis[15634]: Module Unix::Syslog        1.1
    May 17 00:17:45 lina amavis[15634]: Amavis::DB code      NOT loaded
    May 17 00:17:45 lina amavis[15634]: Amavis::Cache code   NOT loaded
    May 17 00:17:45 lina amavis[15634]: SQL base code        NOT loaded
    May 17 00:17:45 lina amavis[15634]: SQL::Log code        NOT loaded
    May 17 00:17:45 lina amavis[15634]: SQL::Quarantine      NOT loaded
    May 17 00:17:45 lina amavis[15634]: Lookup::SQL code     NOT loaded
    May 17 00:17:45 lina amavis[15634]: Lookup::LDAP code    loaded
    May 17 00:17:45 lina amavis[15634]: AM.PDP-in proto code loaded
    May 17 00:17:45 lina amavis[15634]: SMTP-in proto code   loaded
    May 17 00:17:45 lina amavis[15634]: Courier proto code   NOT loaded
    May 17 00:17:45 lina amavis[15634]: SMTP-out proto code  loaded
    May 17 00:17:45 lina amavis[15634]: Pipe-out proto code  NOT loaded
    May 17 00:17:45 lina amavis[15634]: BSMTP-out proto code NOT loaded
    May 17 00:17:45 lina amavis[15634]: Local-out proto code loaded
    May 17 00:17:45 lina amavis[15634]: OS_Fingerprint code  NOT loaded
    May 17 00:17:45 lina amavis[15634]: ANTI-VIRUS code      loaded
    May 17 00:17:45 lina amavis[15634]: ANTI-SPAM code       loaded
    May 17 00:17:45 lina amavis[15634]: ANTI-SPAM-SA code    loaded
    May 17 00:17:45 lina amavis[15634]: Unpackers code       loaded
    May 17 00:17:45 lina amavis[15634]: Found $file            at /usr/bin/file
    May 17 00:17:45 lina amavis[15634]: No $dspam,             not using it
    May 17 00:17:45 lina amavis[15634]: No $altermime,         not using it
    May 17 00:17:45 lina amavis[15634]: Internal decoder for .mail
    May 17 00:17:45 lina amavis[15634]: Internal decoder for .asc 
    May 17 00:17:45 lina amavis[15634]: Internal decoder for .uue 
    May 17 00:17:45 lina amavis[15634]: Internal decoder for .hqx 
    May 17 00:17:45 lina amavis[15634]: Internal decoder for .ync 
    May 17 00:17:45 lina amavis[15634]: No decoder for       .F    tried: unfreeze, freeze -d, melt, fcat
    May 17 00:17:45 lina amavis[15634]: Found decoder for    .Z    at /bin/uncompress
    May 17 00:17:45 lina amavis[15634]: Found decoder for    .gz   at /bin/gzip -d
    May 17 00:17:45 lina amavis[15634]: Found decoder for    .bz2  at /bin/bzip2 -d
    May 17 00:17:45 lina amavis[15634]: No decoder for       .lzo  tried: lzop -d
    May 17 00:17:45 lina amavis[15634]: No decoder for       .rpm  tried: rpm2cpio.pl, rpm2cpio
    May 17 00:17:45 lina amavis[15634]: Found decoder for    .cpio at /bin/cpio
    May 17 00:17:45 lina amavis[15634]: Found decoder for    .tar  at /bin/cpio
    May 17 00:17:45 lina amavis[15634]: Found decoder for    .deb  at /usr/bin/ar
    May 17 00:17:45 lina amavis[15634]: Internal decoder for .zip 
    May 17 00:17:45 lina amavis[15634]: No decoder for       .7z   tried: 7zr, 7za, 7z
    May 17 00:17:45 lina amavis[15634]: No decoder for       .rar  tried: rar, unrar
    May 17 00:17:45 lina amavis[15634]: No decoder for       .arj  tried: arj, unarj
    May 17 00:17:45 lina amavis[15634]: No decoder for       .arc  tried: nomarch, arc
    May 17 00:17:45 lina amavis[15634]: No decoder for       .zoo  tried: zoo, unzoo
    May 17 00:17:45 lina amavis[15634]: No decoder for       .lha  tried: lha
    May 17 00:17:45 lina amavis[15634]: No decoder for       .cab  tried: cabextract
    May 17 00:17:45 lina amavis[15634]: No decoder for       .tnef tried: tnef
    May 17 00:17:45 lina amavis[15634]: Internal decoder for .tnef
    May 17 00:17:45 lina amavis[15634]: No decoder for       .exe  tried: rar, unrar; lha; arj, unarj
    May 17 00:17:45 lina amavis[15634]: Using primary internal av scanner code for ClamAV-clamd
    May 17 00:17:45 lina amavis[15634]: SpamControl: initializing Mail::SpamAssassin
    May 17 00:17:45 lina clamd[15666]: clamd daemon 0.93.3 (OS: linux-gnu, ARCH: i386, CPU: i686) 
    May 17 00:17:45 lina clamd[15666]: Log file size limited to 20971520 bytes. 
    May 17 00:17:45 lina clamd[15666]: Reading databases from /opt/zimbra/data/clamav/db 
    May 17 00:17:45 lina clamd[15666]: Not loading PUA signatures. 
    May 17 00:17:46 lina amavis[15634]: SpamControl: init_pre_fork done
    May 17 00:17:49 lina clamd[15666]: Loaded 593363 signatures. 
    May 17 00:17:49 lina clamd[15666]: TCP: Bound to port 3310 
    May 17 00:17:49 lina clamd[15666]: TCP: Setting connection queue length to 15 
    May 17 00:17:49 lina clamd[15679]: Limits: Global size limit set to 10240000 bytes. 
    May 17 00:17:49 lina clamd[15679]: Limits: File size limit set to 10240000 bytes. 
    May 17 00:17:49 lina clamd[15679]: Limits: Recursion level limit set to 16. 
    May 17 00:17:49 lina clamd[15679]: Limits: Files limit set to 10000. 
    May 17 00:17:49 lina clamd[15679]: Archive support enabled. 
    May 17 00:17:49 lina clamd[15679]: Archive: Blocking encrypted archives. 
    May 17 00:17:49 lina clamd[15679]: Algorithmic detection enabled. 
    May 17 00:17:49 lina clamd[15679]: Portable Executable support enabled. 
    May 17 00:17:49 lina clamd[15679]: ELF support enabled. 
    May 17 00:17:49 lina clamd[15679]: Mail files support enabled. 
    May 17 00:17:49 lina clamd[15679]: OLE2 support enabled. 
    May 17 00:17:49 lina clamd[15679]: PDF support disabled. 
    May 17 00:17:49 lina clamd[15679]: HTML support enabled. 
    May 17 00:17:49 lina clamd[15679]: Self checking every 1800 seconds. 
    May 17 00:17:50 lina zimbramon[14147]: 14147:info: Starting snmp via zmcontrol 
    May 17 00:17:51 lina zimbramon[14147]: 14147:info: Starting spell via zmcontrol 
    May 17 00:17:51 lina zimbramon[14147]: 14147:info: Starting mta via zmcontrol 
    May 17 00:18:02 lina postfix/postfix-script[16125]: warning: not owned by root: /opt/zimbra/postfix-2.4.7.5z/conf/main.cf
    May 17 00:18:02 lina postfix/postfix-script[16138]: starting the Postfix mail system
    May 17 00:18:03 lina postfix/master[16139]: daemon started -- version 2.4.7, configuration /opt/zimbra/postfix-2.4.7.5z/conf
    May 17 00:18:03 lina saslauthd[16147]: detach_tty      : master pid is: 16147
    May 17 00:18:03 lina saslauthd[16147]: ipc_init        : listening on socket: /opt/zimbra/cyrus-sasl-2.1.22.3z/state/mux
    May 17 00:18:03 lina zimbramon[14147]: 14147:info: Starting stats via zmcontrol 
    May 17 00:18:37 lina zmmailboxdmgr[16833]: status requested
    May 17 00:18:37 lina zmmailboxdmgr[16833]: status OK
    May 17 00:18:38 lina zmmailboxdmgr[16889]: status requested
    May 17 00:18:38 lina zmmailboxdmgr[16889]: status OK
    May 17 00:19:46 lina zmmailboxdmgr[17210]: status requested
    May 17 00:19:46 lina zmmailboxdmgr[17210]: status OK
    May 17 00:19:47 lina zmmailboxdmgr[17266]: status requested
    May 17 00:19:47 lina zmmailboxdmgr[17266]: status OK
    May 17 00:20:47 lina zmmailboxdmgr[17461]: status requested
    May 17 00:20:47 lina zmmailboxdmgr[17461]: status OK
    May 17 00:20:56 lina zmmailboxdmgr[17805]: status requested
    May 17 00:20:56 lina zmmailboxdmgr[17805]: status OK
    May 17 00:20:56 lina zmmailboxdmgr[17861]: status requested
    May 17 00:20:56 lina zmmailboxdmgr[17861]: status OK
    so the server comes up fine. the server admin on port 7071 (default) comes up fine. i can't find in the server admin panel where the web interface port is...

    port 80 and 8080 don't respond, netstat -nlp shows a httpd on 7780 but this just says "It works!" and appears to be the internal spell check system according to wiki.

    Any ideas how i can find the port this bugger is running on and/or why im getting no errors but the server's not coming up? was sure it was running on port 80.

    cheers

  2. #2
    Join Date
    Oct 2005
    Location
    USA, Canada and India
    Posts
    777
    Rep Power
    11

    Default

    when you installed new os you also installed some WEBSERVER with it on the host machine.
    "It works!" ..is a default page of some webserver..stop/uninstall that on HOST machine and then restart zimbra in your VM..
    everything should work.

    Raj
    i2k2 Networks
    Dedicated & Shared Zimbra Hosting Provider

  3. #3
    Join Date
    Mar 2007
    Posts
    21
    Rep Power
    8

    Default

    hi raj,

    that would make sense, except i am typing the direct IP address of the zimbra box as the URL. The source of the webserver is on the zimbra box, not my host machine.. Just out of paranoia though I have checked my host machine and there is no webserver on it (pretty sure vista doesn't install apache by default )

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by seravitae View Post
    That would make sense, except i am typing the direct IP address of the zimbra box as the URL.
    Does that indicate that you can't resolve the url of your server via DNS? You should check that your hosts file and DNS A & MX records are correct, post verification that they are OK.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    Join Date
    Mar 2007
    Posts
    21
    Rep Power
    8

    Default

    phenoix, usually it would, however my server is local only, so i'm using split-DNS. the hostname is resolvable on the vmware image to itself, but all other machines access it via direct IP. when i want to access zimbra remotely, I have port fowarded my IP to port 80.

    So in this case, DNS isn't causing the issue - as using the localhost IP:80 in web browser shows nothing. Even locally in the image, nothing is serving on port 80 - netstat shows nothing on tcp/80... It's like the server is silently dying on startup - everything says it's working fine, but port 80 is closed and nothing is serving... I thought the random mysql startup failure and this weird behavior might be because of low ram, so I increased the image's ram by 1GB, and it made no difference.

    thanks for the suggestions/comments so far!

  6. #6
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Does dmesg report anything at all ? what about /var/log/messages ?

Similar Threads

  1. slapd message error
    By smoke in forum Administrators
    Replies: 7
    Last Post: 04-27-2008, 04:23 PM
  2. Replies: 12
    Last Post: 02-25-2008, 07:28 PM
  3. Replies: 31
    Last Post: 12-15-2007, 09:05 PM
  4. Zimbra shutdowns every n hours.
    By Andrewb in forum Administrators
    Replies: 13
    Last Post: 08-14-2007, 09:55 AM
  5. zmtlsctl give LDAP error
    By sourcehound in forum Administrators
    Replies: 5
    Last Post: 03-11-2007, 04:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •