Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: [SOLVED] Zimbra send but not receive CentOS 5 VM

  1. #1
    Join Date
    May 2009
    Posts
    21
    Rep Power
    6

    Default [SOLVED] Zimbra send but not receive CentOS 5 VM

    OK, I have scoured the depths of the forums and net for help but I am just at a loss to get things working. First the setup:

    Dynamic DNS (no-ip.org) MX is set
    Westell DSL/Router open
    Windows Xp Pro "server" running VMware server 2
    CentOS 5 VM using NAT (and on the host port forwarding all set for each port)

    I can send email fine from Zimbra.
    When I run an online test of SMTP from the web this is the result:

    RESULT: .no-ip.org
    Banner: 220 .no-ip.org ESMTP Postfix
    Connect Time: 0 seconds - Good
    Transaction Time: 0.375 seconds - Good
    Relay Check: OK - This server is not an open relay.
    Rev DNS Check: OK - resolves to .pitt.east.verizon.net
    GeoCode Info: Geocoding server is unavailable
    Session Transcript:
    HELO please-read-policy.mxtoolbox.com
    250 .no-ip.o [78 ms]
    MAIL FROM:
    250 2.1.0 [109 ms]
    RCPT TO:
    554 5.7.1 : Relay access deni [78 ms]
    QUIT
    221 2.0.0 B [109 ms]

    I can telnet to port 25 from the Internet and get a response fine as well.

    On the Zimbra Admin panel I can see the emails attempted to be delivered but with "connection refused" as the reason under Mail Queues.

    My guess is that I have something local screwed up. Possibly bad info in Zimbra or in CentOS 5 /etc/hosts. I think I have a .no-ip.org somewhere a localhost.localdomain should be or vise-versa or else some local DNS issue.

    I'll be happy to supply the configs or any info needed to help me properly.

    Thanks!

    UPDATE:

    I'm not sure why my last reply didn't appear, but here goes again:

    When my /etc/hosts file is set to this:

    127.0.0.1 server.no-ip.org localhost
    #.#.#.# server.no-ip.org mail
    ::1 localhost6.localdomain6 localhost6

    Zimbra starts and I can send and can connect via SMTP but get relay access denied.

    when I change it to:

    127.0.0.1 localhost.localdomain localhost
    #.#.#.# server.no-ip.org mail
    ::1 localhost6.localdomain6 localhost6

    Zimbra does not start:

    [zimbra@server ~]$ zmcontrol start
    Host server.no-ip.org
    Starting ldap...Done.
    FAILED
    Failed to start slapd. Attempting debug start to determine error.
    daemon: bind(7) failed errno=99 (Cannot assign requested address)
    slap_open_listener: failed on ldap://server.no-ip.org:389


    I believe the problem has to do with the fact that it is a dynamic IP and/or DNS, but I cannot figure out a solution. Any help is greatly appreciated.

    Thanks!
    Last edited by killc; 05-21-2009 at 01:24 PM.

  2. #2
    Join Date
    May 2009
    Posts
    21
    Rep Power
    6

    Default

    Can anyone help? To update:

    I think I may have an idea of the issue. Since it is a dynamic IP using Dynamic DNS when I do >host #thecurrentIPaddress# I get back the ##.pitt.east.verizon.net instead of #myserver#.no-ip.org. Could this be the possible issue?

    When I go into /etc/hosts:

    127.0.0.1 localhost.localdomain localhost
    #.#.#.# #myserver#.no-ip.org mail
    ::1 localhost6.localdomain6 localhost6

    and then run, I get:

    [zimbra@XXXXX ~]$ zmcontrol start
    Host #myserver#.no-ip.org
    Starting ldap...Done.
    FAILED
    Failed to start slapd. Attempting debug start to determine error.
    daemon: bind(7) failed errno=99 (Cannot assign requested address)
    slap_open_listener: failed on ldap://#myserver#.no-ip.org:389

    BUT

    if I change /etc/hosts to:

    127.0.0.1 #myserver#.no-ip.org localhost
    #.#.#.# #myserver#.no-ip.org mail
    ::1 localhost6.localdomain6 localhost6

    Then Zimbra starts fine and again I can send but not receive from the Internet.

    It appears this is purely a DNS/Resolution issue and I can understand why the second /etc/hosts works to get zimbra to start and also why that will not work... but I do not have a solution. Any help is appreciated.

    Thanks!

  3. #3
    Join Date
    May 2009
    Posts
    21
    Rep Power
    6

    Default update

    I'm not sure why my last reply didn't appear, but here goes again:

    When my /etc/hosts file is set to this:

    127.0.0.1 server.no-ip.org localhost
    #.#.#.# server.no-ip.org mail
    ::1 localhost6.localdomain6 localhost6

    Zimbra starts and I can send and can connect via SMTP but get relay access denied.

    when I change it to:

    127.0.0.1 localhost.localdomain localhost
    #.#.#.# server.no-ip.org mail
    ::1 localhost6.localdomain6 localhost6

    Zimbra does not start:

    [zimbra@server ~]$ zmcontrol start
    Host server.no-ip.org
    Starting ldap...Done.
    FAILED
    Failed to start slapd. Attempting debug start to determine error.
    daemon: bind(7) failed errno=99 (Cannot assign requested address)
    slap_open_listener: failed on ldap://server.no-ip.org:389


    I believe the problem has to do with the fact that it is a dynamic IP and/or DNS, but I cannot figure out a solution. Any help is greatly appreciated.

    Thanks!

  4. #4
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Is your server on a private IP behind a firewall/router ? If so you will need to setup a Wiki :: Split DNS. Please post the following
    Code:
    cat /etc/hosts
    cat /etc/resolv.conf
    dig yourdomain mx
    dig yourdomain any
    host `hostname` <- note backticks and not single quotes (copy and paste)

  5. #5
    Join Date
    May 2009
    Posts
    21
    Rep Power
    6

    Default

    No, that is why most of what I am finding in searches does not apply... or doesn't directly apply.

    It is a public IP, standard 3Mb DSL service from Verizon. I use no-ip.org for dynamic dns handling and MX record.

    Code:
    [root@server ~]# cat /etc/hosts
    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    127.0.0.1               server.no-ip.org localhost
    #correctexternalIP#          server.no-ip.org mail
    ::1             localhost6.localdomain6 localhost6
    
    
    [root@server ~]# cat /etc/resolv.conf
    ; generated by /sbin/dhclient-script
    search localdomain
    nameserver 192.168.164.2
    [root@server ~]# dig server.no-ip.org
    
    
    
    [root@server ~]# dig server.no-ip.org mx
    
    ; <<>> DiG 9.3.4-P1 <<>> server.no-ip.org mx
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 19359
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;server.no-ip.org.              IN      MX
    
    ;; ANSWER SECTION:
    server.no-ip.org.       5       IN      MX      5 server.no-ip.org.
    
    ;; Query time: 2113 msec
    ;; SERVER: 192.168.164.2#53(192.168.164.2)
    ;; WHEN: Fri May 22 08:11:53 2009
    ;; MSG SIZE  rcvd: 50
    
    
    [root@server ~]# dig server.no-ip.org any
    
    ; <<>> DiG 9.3.4-P1 <<>> server.no-ip.org any
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 53467
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;server.no-ip.org.              IN      ANY
    
    ;; ANSWER SECTION:
    server.no-ip.org.       5       IN      A       #correctexternalIP#
    server.no-ip.org.       5       IN      MX      5 server.no-ip.org.
    
    ;; Query time: 2035 msec
    ;; SERVER: 192.168.164.2#53(192.168.164.2)
    ;; WHEN: Fri May 22 08:12:02 2009
    ;; MSG SIZE  rcvd: 66
    
    
    [root@server ~]# host `hostname`
    server.no-ip.org has address #correctexternalIP#
    server.no-ip.org mail is handled by 5 server.no-ip.org.
    [root@server ~]#
    The other thing is that when I send mail to the server from the internet it does reach it, and does reach Zimbra because I can see it in the mail queue it is just that it shows as connection refused. So it seems like something with the internal routing/DNS that Zimbra uses is either not finding the actual delivery mailbox or something similar.

    Thanks!

  6. #6
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Anything else listening on port 389 ? iptables and selinux disabled ?

  7. #7
    Join Date
    May 2009
    Posts
    21
    Rep Power
    6

    Default

    I don't believe so. iptables and selinux disabled. I followed the CentOS5 guide from these forums which has them disabled from the install.

  8. #8
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    No close enough then Your /etc/hosts is wrong
    Code:
    127.0.0.1               server.no-ip.org localhost
    it should look like
    Code:
    127.0.0.1	localhost.localdomain	localhost
    ::1	localhost6.localdomain6	localhost6
    xxx.xxx.xxx.xxx	server.fq.dn	server

  9. #9
    Join Date
    May 2009
    Posts
    21
    Rep Power
    6

    Default

    I truly appreciate your assistance! But unfortunately this takes us full circle back to my initial post.

    When I change /etc/hosts to:

    Code:
    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    127.0.0.1               localhost.localdomain localhost
    ::1             localhost6.localdomain6 localhost6
    #correctexternalIP#          server.no-ip.org server.no-ip.org
    I get:

    Code:
    [zimbra@server ~]$ zmcontrol start
    Host server.no-ip.org
            Starting ldap...Done.
    FAILED
    /opt/zimbra/bin/ldap: line 59: kill: (9369) - No such process
    /opt/zimbra/bin/ldap: line 59: kill: (9369) - No such process
    /opt/zimbra/bin/ldap: line 59: kill: (9369) - No such process
    /opt/zimbra/bin/ldap: line 59: kill: (9369) - No such process
    /opt/zimbra/bin/ldap: line 59: kill: (9369) - No such process
    /opt/zimbra/bin/ldap: line 59: kill: (9369) - No such process
    /opt/zimbra/bin/ldap: line 59: kill: (9369) - No such process
    Failed to start slapd.  Attempting debug start to determine error.
    daemon: bind(7) failed errno=99 (Cannot assign requested address)
    slap_open_listener: failed on ldap://server.no-ip.org:389
    It seems to me that this is logical because it is trying to resolve its own FQDN to the external IP address internally which will not work. I need Zimbra to internally resolve to localhost, not the FQDN.

    Any help is truly appreciated.
    Thanks!

  10. #10
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Is your server sat in a DMZ behind a firewall ? I see from your resolv.conf you are using a private IP for your nameserver. You should really setup a Wiki :: Split DNS architecture and either NAT or port forward on your FW.

Similar Threads

  1. [SOLVED] Zimbra logwatch.
    By nishith in forum Administrators
    Replies: 5
    Last Post: 06-10-2009, 04:42 PM
  2. [SOLVED] Error Installing Zimbra on RHEL 5
    By harris7139 in forum Installation
    Replies: 10
    Last Post: 09-25-2007, 11:39 AM
  3. Post instsallation problems
    By Assaf in forum Installation
    Replies: 14
    Last Post: 01-29-2007, 10:38 AM
  4. Replies: 16
    Last Post: 09-07-2006, 06:39 AM
  5. Unable to start tomcat
    By chanck in forum Administrators
    Replies: 11
    Last Post: 06-11-2006, 12:58 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •