Results 1 to 4 of 4

Thread: [SOLVED] Could not find an LDAP entry for server

  1. #1
    Join Date
    Oct 2008
    Rep Power

    Default [SOLVED] Could not find an LDAP entry for server

    ZCS-5.0.10 GA - running on Ubuntu Linux

    I was attempting to set up a temporary server to migrate to. I installed Zimbra on the new hardware and in the process I attempted to change the hostname by using the zmsetservername command on the new machine. Well, I'm not sure how but this has messed up the production server. I cannot get the mailbox service started. I'm seeing the following error in mailbox.log.

    Could not find an LDAP entry for server ''

    I did not do a new backup as I had no clue that Zimbra on a completely different machine could modify something on my production server. I do have a backup from a couple of weeks ago. Nothing as far as user accounts has changed since that backup.

    Also, I should not that I'm seeing the "NO SUCH SERVER" error in zimbra.log

    May 28 11:33:20 mail4 zimbramon[10849]: 10849:info: zmmtaconfig: ERROR: account.NO_SUCH_SERVER (no such server:

    Thanks for any help.

  2. #2
    Join Date
    Nov 2006
    Rep Power


    cat /etc/hosts
    cat /etc/resolv.conf
    dig yourdomain mx
    dig yourdomain any
    host `hostname` <- note backticks and not single quotes
    su - zimbra

  3. #3
    Join Date
    Oct 2008
    Rep Power


    Thanks for replying. I found that I hadn't read the instructions for zmsetservername well enough. I missed the fact that if you run the command on a server with the same name as a production server that it would apply the changes to the production server as well. I ended up installing ZCS over the broken production install and got things up and running again. I did make a backup copy of the broken install before re-installing, just to make sure I didn't make things worse. I've learned my lesson and did learn a couple of things about Zimbra, which is good.

  4. #4
    Join Date
    Nov 2008
    Rep Power


    I know this thread has been closed for quite a while. But I did this exact same thing and your thread saved my bacon. Thanks for posting your solution.

Similar Threads

  1. Documents fail to initialize
    By dgcarter in forum Installation
    Replies: 9
    Last Post: 12-17-2007, 11:44 PM
  2. Replies: 13
    Last Post: 07-20-2007, 03:21 AM
  3. Initializing ldap...FAILED (256)
    By CVD in forum Installation
    Replies: 17
    Last Post: 03-10-2006, 08:47 AM
  4. Yet another get.DirectContext issue
    By dccpark in forum Installation
    Replies: 5
    Last Post: 03-08-2006, 12:25 PM
  5. Certify Error on (re)install
    By rodrigoccurvo in forum Installation
    Replies: 4
    Last Post: 09-23-2005, 09:04 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts