Results 1 to 6 of 6

Thread: Redirect http or http to preauth

Hybrid View

  1. #1
    Join Date
    Jun 2009
    Location
    Poughkeepsie, NY
    Posts
    18
    Rep Power
    6

    Default Redirect http or http to preauth

    Hello everyone,

    First I'm really excited to get to learn and setup a Zimbra server. Here is what I have set for redirects and preauth.

    I have set http to redirect to https always. We have successfully setup preauth.jsp to authenticate with our CAS server. However it only works when the link is zimbra.server.com/preauth.jsp. When I use zimbra.server.com it allows me to authenticate with CAS but then redirects me to the Zimbra login which shouldn't happen. The /preauth.jsp link automatically signs me into Zimbra.

    I feel like this is such as easy fix that I'm not thinking of right now. Any ideas would be greatly appreciated. We will soon be making a push to get Zimbra implemented at my school and like I said, I'm really excited for it.

    -Tim

  2. #2
    Join Date
    Jun 2009
    Location
    Poughkeepsie, NY
    Posts
    18
    Rep Power
    6

    Default

    Simply put, when a user navigates to any variation of zimbra.server.com how do I get it to redirect to zimbra.server.com/preauth.jsp

    TIA

  3. #3
    Join Date
    Jun 2009
    Location
    Poughkeepsie, NY
    Posts
    18
    Rep Power
    6

    Default

    I figured it out thanks to @xxTigerxx and his post about the stuff.

    In Zimbra.web.xml.in the orignal code looks like this

    public/Login.jsp



    I changed it to

    /preauth.jsp


    This now redirects CAS directly to the mailbox after authnetication.

  4. #4
    Join Date
    Jun 2009
    Location
    Poughkeepsie, NY
    Posts
    18
    Rep Power
    6

    Default

    Ok so the above fix did work for Login, but that broke Logout through CAS. Actually logout doesn't work at all. Clicking on the Logout link basically logs you into the web client again. Oh joy haha

  5. #5
    Join Date
    Jun 2009
    Location
    Poughkeepsie, NY
    Posts
    18
    Rep Power
    6

    Default

    SOLVED!!!

    I headed over the JA-SIG forums and "Ryan" was able to help me out. I needed to change the main domain settings. These are the two commands you need to run as user "zimbra".

    //one line
    zmprov md example.com zimbraWebClientLoginURL
    https://zimbra.example.com/zimbra/preauth.jsp

    //one line
    zmprov md example.com zimbraWebClientLogoutURL
    https://cas.example.com/cas/logout

  6. #6
    Join Date
    Jun 2009
    Location
    fresno, ca
    Posts
    10
    Rep Power
    6

    Default

    Thanks for following up with you solutions to the problems you had. I will definitely need your post when I get better associated to the zimbra mail server. Right now I am using a functional server and trying to add more domains. I have the domains added as that is the easy part.

    Thanks again.

Similar Threads

  1. How do I redirect http to a https general URL?
    By henryw in forum Administrators
    Replies: 0
    Last Post: 12-29-2008, 04:31 PM
  2. HTTP redirect (no https)
    By stich86 in forum Installation
    Replies: 3
    Last Post: 03-11-2008, 03:16 PM
  3. [SOLVED] Redirect HTTP to HTTPS
    By atx4runner in forum Installation
    Replies: 2
    Last Post: 02-13-2008, 10:14 AM
  4. HTTP to redirect to HTTPS
    By djve in forum Installation
    Replies: 3
    Last Post: 05-30-2007, 07:28 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •