Results 1 to 4 of 4

Thread: [SOLVED] HTTP Proxy Troubles

  1. #1
    Join Date
    Jun 2009
    Location
    Vancouver
    Posts
    7
    Rep Power
    6

    Default [SOLVED] HTTP Proxy Troubles

    After setting up my fresh clustered install, the web interface is only available by specifying the proxy port numbers, (8080 or 8443, eg:http://my.domain.com:8080). I also can't access the admin web interface through the proxy. The IMAP/POP part of the proxy seems to work good as far as I've tested it.

    I have a mailbox/ldap machine and an mta/proxy machine. I thought I did everything right, but I will admit the proxy configuration on both machines didn't make perfect sense to me. Wondering if anyone had some suggestions as I'm not necessarily sure where to start.

    I don't have the hostnames setup yet, so just running off of IP's. I also chose 'mixed' HTTP mode on both servers so maybe that throws things off.

  2. #2
    Join Date
    Jun 2009
    Location
    Vancouver
    Posts
    7
    Rep Power
    6

    Default

    I was reading through Working with Zimbra Proxy and noticed 2 things:

    For the mailbox server(s):
    zimbraMailMode to http. This is the only supported mode.
    Therefore, I switched my mailbox server to http mode using 'zmtlsctl http'

    For the proxy servers:
    zimbraMailReferMode to reverse-proxied
    Therefore, I switched my proxy server to reverse-proxied using 'zmprov ms proxy.domain.com zimbraMailReferMode reverse-proxied'

    However, I'm still in the same situation, after restarting all services I don't notice any change in operation.

  3. #3
    Join Date
    Jun 2008
    Posts
    594
    Rep Power
    8

    Default

    > After setting up my fresh clustered install, the web interface is only available by specifying the proxy port numbers, (8080 or 8443, eg:http://my.domain.com:8080). I also can't access the admin web interface through the proxy.

    Seems you have web proxy also enabled which would mean that http on mailstore will be accessed using 8080 port and on proxy using 80. Admin port 7071 however is never proxied.

  4. #4
    Join Date
    Jun 2009
    Location
    Vancouver
    Posts
    7
    Rep Power
    6

    Default

    Quote Originally Posted by veronica View Post
    Seems you have web proxy also enabled which would mean that http on mailstore will be accessed using 8080 port and on proxy using 80. Admin port 7071 however is never proxied.
    I was able to access 8080 through the proxy and 80 through the mailstore. Opposite.

    I guess something went wrong somewhere in the install process and seems like the ports aren't correct at all. I got some advice to try "Setting up HTTP Proxy after IMAP/POP Proxy is set up" in the admin guide. I did, and now it works.

Similar Threads

  1. ldap & http proxy
    By jojo in forum Installation
    Replies: 0
    Last Post: 05-15-2009, 12:30 AM
  2. Proxy Upgrade - http no longer works only https
    By bonoboslr in forum Administrators
    Replies: 1
    Last Post: 11-24-2008, 12:38 AM
  3. ZCS 5.0.6 with HTTP Proxy
    By piloteornis in forum Installation
    Replies: 2
    Last Post: 06-30-2008, 07:33 AM
  4. Replies: 1
    Last Post: 01-02-2008, 09:31 PM
  5. How to make Zimbra use HTTP Proxy on outgoing requests?
    By martinm_76 in forum Installation
    Replies: 2
    Last Post: 09-03-2006, 10:13 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •