Results 1 to 10 of 20

Thread: system email being sent to wrong domain

Hybrid View

  1. #1
    Join Date
    May 2006
    Location
    England.
    Posts
    927
    Rep Power
    10

    Default system email being sent to wrong domain

    An odd one this, and I've tried and tried to work it out but I'm failing miserably.

    Short version: daily system report emails are being sent to the address root@hostname.domain.co.uk rather than to root@domain.co.uk

    More info. When I installed, I remember the install complaining that it didnt have an MX record configured, but the default address it was looking at was hostname.domain.co.uk (I accepted this the first time and it all went wrong, so I started again from scratch) so I change that entry to just domain.co.uk and it all works fine, but it seems that the server is confused about what it's own email address is.

    This means that the daily reports were ending up stuck in the queue, as a work around - I've configured an additional domain in the admin console and added an alias to my account so the mail can be routed correctly, but of course I'm more interested in a real fix.

    I recon theres a config file somewhere that needs editing, but I've looked at quite a few and so far Ive not found anything that looks right.

    I hope I've managed to explain this well enough that someone can help.

  2. #2
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    Try zmlocalconfig | grep hostname see if it pops up there.
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  3. #3
    Join Date
    May 2006
    Location
    England.
    Posts
    927
    Rep Power
    10

    Default

    Hi, yes the results of that are:

    mail:~ # su - zimbra
    zimbra@mail:~> zmlocalconfig | grep hostname
    zimbra_server_hostname = mail.domain.co.uk


    But I read that as being correct, I mean, is that not the fully qualified host name?

  4. #4
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    This is in the crontab

    # Daily reports
    #
    10 1 * * * /opt/zimbra/libexec/zmdailyreport | /opt/zimbra/postfix/sbin/sendmail root


    We send to root by default so you can hack it to just edit this address. In general we need to make this configurable. If you domain name matches the system name then it would just work since the root account will alias to your admin account. So for now you can work around it but feel free to file a bug to correct this going forward.
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  5. #5
    Join Date
    May 2006
    Location
    England.
    Posts
    927
    Rep Power
    10

    Default

    Thank you, I'll file a bug report once I get it solved and workng, so I uderstand the problem enough to describe it succinctly.

    I do indeed find the line you mention when I type crontab -l the problem is I'm not sure what I should be changing. I dont mind the message being sent to root, it's just that it's being sent to root@mail.domain.co.uk rather than root@domain.co.uk, and I see only the username in the line you quote.

    Sorry if I'm being a little thick here, but could you tell me the path and filename of the file which needs editing?

  6. #6
    Join Date
    Feb 2006
    Location
    Germany, Saarland, Saarbruecken
    Posts
    53
    Rep Power
    9

    Default

    Quote Originally Posted by Dirk
    Thank you, I'll file a bug report once I get it solved and workng, so I uderstand the problem enough to describe it succinctly.

    I do indeed find the line you mention when I type crontab -l the problem is I'm not sure what I should be changing. I dont mind the message being sent to root, it's just that it's being sent to root@mail.domain.co.uk rather than root@domain.co.uk, and I see only the username in the line you quote.

    Sorry if I'm being a little thick here, but could you tell me the path and filename of the file which needs editing?
    Hint, use webmin to change the crontabs. Or in your case change the file: /opt/zimbra/zimbramon/crontabs/crontab.logger

    Cu

  7. #7
    Join Date
    Feb 2007
    Posts
    11
    Rep Power
    8

    Default How does the root account alias to the zimbra admin?

    Quote Originally Posted by KevinH View Post
    This is in the crontab

    # Daily reports
    #
    10 1 * * * /opt/zimbra/libexec/zmdailyreport | /opt/zimbra/postfix/sbin/sendmail root


    We send to root by default so you can hack it to just edit this address. In general we need to make this configurable. If you domain name matches the system name then it would just work since the root account will alias to your admin account. So for now you can work around it but feel free to file a bug to correct this going forward.
    How exactly does the root account alias to the admin account? The reason I'm asking is that I'm not getting any of the daily reports. They are all still in root's mailbox (i.e. I can log in as root and use the mail command to see them). I know I can edit zimbra's crontab to fix this but I'd like to avoid manually changing configuration files if at all possible.

  8. #8
    Join Date
    Jul 2006
    Posts
    623
    Rep Power
    10

    Default

    4.5.2 has a fix for this that delivers the dailyreport to the admin account via the configured smtphost. no more dependancies on the local system mailer or root account.
    Bugzilla - Wiki - Downloads - Before posting... Search!

  9. #9
    Join Date
    Jul 2006
    Location
    Evanston, IL
    Posts
    2
    Rep Power
    9

    Default

    Im running "4.5.3_GA_733.RHEL4_20070228100631 RHEL4 NETWORK edition" and had the same problem. The smtp_source and smtp_destination options were set to "admin@host.domain" instead of just "admin@domain". So my daily reports were bouncing as there's no local user called "admin" on the server. My crontab has the newer line I believe:

    # Daily reports
    #
    10 1 * * * /opt/zimbra/libexec/zmdailyreport -m

    I fixed it by changing the smtp_* options to "admin@domain" per other threads, but Im wondering if its a bug that the options got set to the full host.domain instead of using the mail domain only? Or is this just a transient bug from 4.5.2 that has been fixed?

Similar Threads

  1. Disable a domain without deleting email?
    By shankwc in forum Administrators
    Replies: 3
    Last Post: 09-21-2010, 12:16 AM
  2. need advice on configuring zimbra to work with fax server
    By pheonix1t in forum Administrators
    Replies: 0
    Last Post: 07-11-2007, 07:46 PM
  3. upgrade to 4.0.3 antispam does'nt work
    By lucanannipieri in forum Administrators
    Replies: 14
    Last Post: 11-07-2006, 02:56 AM
  4. domain coexistence
    By marcmac in forum Administrators
    Replies: 14
    Last Post: 06-30-2006, 01:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •