Results 1 to 5 of 5

Thread: [SOLVED] Close to despair: LDAP installation problem!?

  1. #1
    Join Date
    Jul 2009
    Posts
    2
    Rep Power
    6

    Default [SOLVED] Close to despair: LDAP installation problem!?

    Hello everybody,

    I've now tried to install Zimbra Opensource a couple of times but I've still not succeeded

    Everything goes fine until the final moment:

    "Address unconfigured (**) items or correct ldap configuration (? - help) "

    There are no items with ** anymore so it has to be the LDAP configuration.

    But I don't know what's wrong!?

    The DNS seems to work correctly, I've got an MX record, the passwords should be ok too.

    So what else could it be??

    Main menu

    1) Common Configuration:
    +Hostname: ZimbraLinux.mydomain.local
    +Ldap master host: zimbralinux.mydomain.local
    +Ldap port: 389
    +Ldap Admin password: set
    +Require secure interprocess communications: yes
    +TimeZone: (GMT+01.00) Brussels / Copenhagen / Madrid / Paris

    2) zimbra-ldap: Enabled
    +Create Domain: yes
    +Domain to create: mydomain.local
    +Ldap Root password: set
    +Ldap Replication password: set
    +Ldap Postfix password: set
    +Ldap Amavis password: set
    +Ldap Nginx password: set

    3) zimbra-store: Enabled
    +Create Admin User: yes
    +Admin user to create: admin@mydomain.local
    +Admin Password set
    +Enable automated spam training: yes
    +Spam training user: spam.gmp3cv0lz@mydomain.local
    +Non-spam(Ham) training user: ham.tsaqrb6ha@mydomain.local
    +Global Documents Account: wiki@mydomain.local
    +SMTP host: ZimbraLinux.mydomain.local
    +Web server HTTP port: 80
    +Web server HTTPS port: 443
    +Web server mode: http
    +IMAP server port: 143
    +IMAP server SSL port: 993
    +POP server port: 110
    +POP server SSL port: 995
    +Use spell check server: yes
    +Spell server URL: http://ZimbraLinux.mydomain.local:7780/aspell.php
    +Configure store for use with reverse mail proxy: FALSE
    +Configure store for use with reverse web proxy: FALSE

    4) zimbra-mta: Enabled
    +MTA Auth host: ZimbraLinux.mydomain.local
    +Enable Spamassassin: yes
    +Enable Clam AV: yes
    +Notification address for AV alerts: admin@mydomain.local
    +Bind password for postfix ldap user: set
    +Bind password for amavis ldap user: set

    5) zimbra-snmp: Enabled
    +Enable SNMP notifications: yes
    +SNMP Trap hostname: ZimbraLinux.mydomain.local
    +Enable SMTP notifications: yes
    +SMTP Source email address: admin@mydomain.local
    +SMTP Destination email address: admin@mydomain.local

    6) zimbra-logger: Enabled
    7) zimbra-spell: Enabled
    8) Default Class of Service Configuration:
    +Enable Instant Messaging Feature: Disabled
    +Enable Briefcases Feature: Enabled
    +Enable Tasks Feature: Enabled
    +Enable Notebook Feature: Enabled

    c) Collapse menu
    r) Start servers after configuration yes
    s) Save config to file
    q) Quit
    Any help would be greatly appreciated!

  2. #2
    Join Date
    Jul 2007
    Location
    San Jose, CA
    Posts
    1,027
    Rep Power
    10

    Default

    Quote Originally Posted by Xeronimo1974 View Post
    1) Common Configuration:
    +Hostname: ZimbraLinux.mydomain.local
    +Ldap master host: zimbralinux.mydomain.local
    I am no LDAP expert, but I notice here that you have your hostname as ZimbraLinux everywhere but on this LDAP line, where it's all lower-case. Everything, and I do mean everything, is case-sensitive in Linux. You might try correcting that.
    Cheers,

    Dan

  3. #3
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Welcome to the forums

    90% of LDAP installation issues are due to a misconfigured /etc/hosts; so would you please post the following
    Code:
    cat /etc/hosts
    cat /etc/resolv.conf
    dig yourdomain mx
    dig yourdomain any
    host `hostname` <- note backticks and not single quotes (type exactly as specified)

  4. #4
    Join Date
    Jul 2009
    Posts
    2
    Rep Power
    6

    Default

    Quote Originally Posted by dwmtractor View Post
    I am no LDAP expert, but I notice here that you have your hostname as ZimbraLinux everywhere but on this LDAP line, where it's all lower-case. Everything, and I do mean everything, is case-sensitive in Linux. You might try correcting that.
    D'oh! That seems to have been the problem ... I was finally able to install it and it works nicely now

  5. #5
    Join Date
    Jul 2007
    Location
    San Jose, CA
    Posts
    1,027
    Rep Power
    10

    Default

    Quote Originally Posted by Xeronimo1974 View Post
    D'oh! That seems to have been the problem ... I was finally able to install it and it works nicely now
    Glad to be of service. . .it's them little things that get you every time. . .

    Marking solved. . .
    Cheers,

    Dan

Similar Threads

  1. LDAP problem with the installation of Zimbra
    By makeitwork in forum Installation
    Replies: 3
    Last Post: 05-10-2007, 04:59 PM
  2. Zimbra Installation Problem
    By AnilKumarYalla in forum Developers
    Replies: 0
    Last Post: 09-10-2006, 10:33 PM
  3. ldap pasword problem
    By jasonwillis in forum Installation
    Replies: 15
    Last Post: 03-15-2006, 08:56 AM
  4. Installation problem
    By sywong70 in forum Installation
    Replies: 5
    Last Post: 11-07-2005, 09:01 PM
  5. Installation problem
    By charlie in forum Administrators
    Replies: 1
    Last Post: 10-14-2005, 09:55 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •