Results 1 to 7 of 7

Thread: [SOLVED] Ubuntu 8.04 64 + Zimbra 5.018

  1. #1
    Join Date
    Jul 2009
    Posts
    6
    Rep Power
    6

    Unhappy [SOLVED] Ubuntu 8.04 64 + Zimbra 5.018

    Hello,

    I tried to install zimbra the 20th time now. I edited my hosts file and tried it with installing bind9 but It doesn't run.

    I (try to) run zimbra on a Ubuntu 8.04 64bit minimal installation root server

    Here the error message in the log file:

    Code:
    ERROR: zclient.IO_ERROR (invoke Connection refused, server: localhost) (cause: java.net.ConnectException Connection refused)
    Fri Jul 17 18:30:29 2009 *** Running as zimbra user: /opt/zimbra/bin/zmprov mcf zimbraNotebookAccount wiki@rapidserv.de
    ERROR: zclient.IO_ERROR (invoke Connection refused, server: localhost) (cause: java.net.ConnectException Connection refused)
    Fri Jul 17 18:30:32 2009 *** Running as zimbra user: /opt/zimbra/bin/zmprov in wiki@rapidserv.de
    ERROR: zclient.IO_ERROR (invoke Connection refused, server: localhost) (cause: java.net.ConnectException Connection refused)
    Fri Jul 17 18:30:33 2009 *** Running as zimbra user: /opt/zimbra/bin/zmprov mc default zimbraFeatureNotebookEnabled FALSE
    ERROR: zclient.IO_ERROR (invoke Connection refused, server: localhost) (cause: java.net.ConnectException Connection refused)
    Fri Jul 17 18:30:35 2009 failed to initialize documents...see logfile for details.
    Fri Jul 17 18:30:35 2009 Restarting mailboxd...
    my hosts file:
    127.0.0.1 localhost.localdomain localhost
    188.40.234.114 rapidserv.de rapidserv

    host `hostname`
    rapidserv.de has address 188.40.234.114
    rapidserv.de mail is handled by 10 rapidserv.de.
    seems to right..

    zmsetup.07172009-182438.log

    Sorry just found http://wiki.zimbra.com/index.php?tit..._Install_Guide
    I hope this will help me..

    Greetings HansBlix
    Last edited by HansBlix; 07-17-2009 at 02:37 PM.

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Your host file is incorrect, it should contain the FQDN (Fully Qualified Domain Name) of your server. This file:

    Code:
    127.0.0.1 localhost.localdomain localhost
    188.40.234.114 rapidserv.de rapidserv
    should look like this:
    Code:
    127.0.0.1 localhost.localdomain localhost
    188.40.234.114 mail.rapidserv.de mail
    You will also need a Split DNS if your server is behind a NAT router or firewall, it's detailed in the wiki article you linked to. Your external DNS records will also need correcting to reflect the FQDN of the Zimbra server.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Jul 2009
    Posts
    6
    Rep Power
    6

    Unhappy

    Hello, thanks for the answer.

    I installed it again like described in the wiki article, the webinterface on mail.rapidserv.de shows up now, but when I try to login it says:

    ???remote.CONNECT_FAILURE???

    During the installation I also got these errors (again):

    Code:
    (..)
    ERROR: account.DOMAIN_EXISTS (domain already exists: rapidserv.de)(..)
    Code:
    ERROR: zclient.IO_ERROR (invoke Connection refused, server: localhost) (cause: java.net.ConnectException Connection refused)
    Mon Jul 20 18:27:33 2009 *** Running as zimbra user: /opt/zimbra/bin/zmprov mcf zimbraNotebookAccount wiki@rapidserv.de
    ERROR: zclient.IO_ERROR (invoke Connection refused, server: localhost) (cause: java.net.ConnectException Connection refused)
    Mon Jul 20 18:27:33 2009 *** Running as zimbra user: /opt/zimbra/bin/zmprov in wiki@rapidserv.de
    ERROR: zclient.IO_ERROR (invoke Connection refused, server: localhost) (cause: java.net.ConnectException Connection refused)
    Mon Jul 20 18:27:34 2009 *** Running as zimbra user: /opt/zimbra/bin/zmprov mc default zimbraFeatureNotebookEnabled FALSE
    ERROR: zclient.IO_ERROR (invoke Connection refused, server: localhost) (cause: java.net.ConnectException Connection refused)
    Mon Jul 20 18:27:39 2009 failed to initialize documents...see logfile for details.
    Here are some configuration files which may be important to solve the problem:
    I hope somebody can help me

    hosts:
    Code:
    127.0.0.1 localhost.localdomain localhost
    188.40.234.114 mail.rapidserv.de mail
    named.conf.options:
    Code:
    options {
            directory "/var/cache/bind";
    
            //query-source address * port 53;
    
            forwarders {
                    213.133.98.98; 213.133.100.100;
            };
    
            auth-nxdomain no;    # conform to RFC1035
    
    };
    named.conf.local:
    Code:
            zone "rapidserv.de"  {
                    type master;
                    file "/etc/bind/db.rapidserv.de";
            };
    resolv.conf:
    Code:
    nameserver 188.40.234.114
    (the ip of my server)

    db.rapidserv.de:
    Code:
    ;
    ; BIND data file for mydomain.com
    ;
    $TTL    604800
    @       IN      SOA     mail.rapidserv.de. admin.rapidserv.de. (
                             090720         ; Serial
                             604800         ; Refresh
                              86400         ; Retry
                            2419200         ; Expire
                             604800 )       ; Negative Cache TTL
    ;
    @       IN      NS      mail
            IN      MX      10 mail
            IN      A       188.40.234.114
    mail    IN      A       188.40.234.114
    setup log file:
    zmsetup.07202009-181958.log

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Let's check the DNS first, post the output of the following command (run on the zimbra server):

    Code:
    cat /etc/hosts
    cat /etc/resolv.conf
    dig rapidserv.de mx
    dig rapidserv.de any
    host `hostname`  <-- type that exact command with backticks not single quotes
    Last edited by uxbod; 07-22-2009 at 11:58 AM.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    Join Date
    Jul 2009
    Posts
    6
    Rep Power
    6

    Default

    Here are the outputs:

    Code:
    root@rapidserv:~# cat /etc/hosts
    127.0.0.1 localhost.localdomain localhost
    188.40.234.114 mail.rapidserv.de mail
    Code:
    root@rapidserv:~# cat /etc/resolv.conf
    nameserver 188.40.234.114
    Code:
    root@rapidserv:~# dig rapidserv.de mx
    
    ; <<>> DiG 9.4.2 <<>> rapidserv.de mx
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 25861
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 13, ADDITIONAL: 1
    
    ;; QUESTION SECTION:
    ;rapidserv.de.                  IN      MX
    
    ;; ANSWER SECTION:
    rapidserv.de.           86400   IN      MX      10 rapidserv.de.
    
    ;; AUTHORITY SECTION:
    .                       302970  IN      NS      C.ROOT-SERVERS.NET.
    .                       302970  IN      NS      H.ROOT-SERVERS.NET.
    .                       302970  IN      NS      G.ROOT-SERVERS.NET.
    .                       302970  IN      NS      A.ROOT-SERVERS.NET.
    .                       302970  IN      NS      M.ROOT-SERVERS.NET.
    .                       302970  IN      NS      E.ROOT-SERVERS.NET.
    .                       302970  IN      NS      D.ROOT-SERVERS.NET.
    .                       302970  IN      NS      K.ROOT-SERVERS.NET.
    .                       302970  IN      NS      B.ROOT-SERVERS.NET.
    .                       302970  IN      NS      L.ROOT-SERVERS.NET.
    .                       302970  IN      NS      J.ROOT-SERVERS.NET.
    .                       302970  IN      NS      I.ROOT-SERVERS.NET.
    .                       302970  IN      NS      F.ROOT-SERVERS.NET.
    
    ;; ADDITIONAL SECTION:
    rapidserv.de.           37797   IN      A       188.40.234.114
    
    ;; Query time: 26 msec
    ;; SERVER: 188.40.234.114#53(188.40.234.114)
    ;; WHEN: Wed Jul 22 20:05:45 2009
    ;; MSG SIZE  rcvd: 273
    Code:
    root@rapidserv:~# dig rapidserv.de any
    
    ; <<>> DiG 9.4.2 <<>> rapidserv.de any
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 6433
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 13, ADDITIONAL: 1
    
    ;; QUESTION SECTION:
    ;rapidserv.de.                  IN      ANY
    
    ;; ANSWER SECTION:
    rapidserv.de.           86380   IN      MX      10 rapidserv.de.
    rapidserv.de.           37777   IN      A       188.40.234.114
    
    ;; AUTHORITY SECTION:
    .                       302951  IN      NS      L.ROOT-SERVERS.NET.
    .                       302951  IN      NS      J.ROOT-SERVERS.NET.
    .                       302951  IN      NS      B.ROOT-SERVERS.NET.
    .                       302951  IN      NS      G.ROOT-SERVERS.NET.
    .                       302951  IN      NS      H.ROOT-SERVERS.NET.
    .                       302951  IN      NS      D.ROOT-SERVERS.NET.
    .                       302951  IN      NS      F.ROOT-SERVERS.NET.
    .                       302951  IN      NS      C.ROOT-SERVERS.NET.
    .                       302951  IN      NS      E.ROOT-SERVERS.NET.
    .                       302951  IN      NS      A.ROOT-SERVERS.NET.
    .                       302951  IN      NS      I.ROOT-SERVERS.NET.
    .                       302951  IN      NS      M.ROOT-SERVERS.NET.
    .                       302951  IN      NS      K.ROOT-SERVERS.NET.
    
    ;; ADDITIONAL SECTION:
    rapidserv.de.           37778   IN      A       188.40.234.114
    
    ;; Query time: 45 msec
    ;; SERVER: 188.40.234.114#53(188.40.234.114)
    ;; WHEN: Wed Jul 22 20:06:05 2009
    ;; MSG SIZE  rcvd: 289
    Code:
    root@rapidserv:~# host `hostname`
    rapidserv.de has address 188.40.234.114
    rapidserv.de mail is handled by 10 rapidserv.de.
    Thanks for your help

    Regards HansBlix

  6. #6
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Your A & MX records are incorrect, they should look like this:

    Code:
    rapidserv.de.           86380   IN      MX      10 mail.rapidserv.de.
    
    mail.rapidserv.de.           37797   IN      A       188.40.234.114
    Make those changes and see if that fixes your problem.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #7
    Join Date
    Jul 2009
    Posts
    6
    Rep Power
    6

    Default

    It seem to work now!
    Thanks a lot.

    But what is about the failed to initialize documents error during the installation, I think antispam and antivirus doesn't work because of that..

    Code:
    zmcontrol status
    Host rapidserv.de
            antispam                Stopped
                    zmamavisdctl is not running
            antivirus               Stopped
                    zmamavisdctl is not running
            ldap                    Running
            logger                  Running
            mailbox                 Running
            mta                     Running
            snmp                    Running
            spell                   Running
            stats                   Running
    any suggestions?

    ===============

    The server has just not enough RAM, so I deactived the logger, antivirus and antispam the rest works properly now

    Thanks again and a nice weekend

    Regars HansBlix
    Last edited by HansBlix; 07-24-2009 at 04:36 AM.

Similar Threads

  1. Replies: 8
    Last Post: 01-12-2012, 01:20 AM
  2. Get emails out of zimbra or get it working again?
    By kingfeanor in forum Migration
    Replies: 9
    Last Post: 11-25-2008, 12:02 AM
  3. [SOLVED] Clamav problem ? What's happening ?
    By aNt1X in forum Installation
    Replies: 23
    Last Post: 02-14-2008, 04:43 AM
  4. dspam logrotate errors
    By michaeln in forum Users
    Replies: 7
    Last Post: 02-19-2007, 11:45 AM
  5. 3.1 on FC4 problems
    By cohnhead in forum Installation
    Replies: 8
    Last Post: 05-26-2006, 11:16 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •