Results 1 to 3 of 3

Thread: [SOLVED] Database error upgrading from ZCS 5.0.16 to 5.0.18

Hybrid View

  1. #1
    Join Date
    Feb 2007
    Posts
    9
    Rep Power
    8

    Default [SOLVED] Database error upgrading from ZCS 5.0.16 to 5.0.18

    I am currently running ZCS 5.0.16 on CentOS 5.3 (i386). When I tried to upgrade to 5.0.18, I got a database error and a bunch of "REPAIR TABLE" suggestions. Research in the forums didn't give me a clear answer on what to do here; one answer says its ok to ignore the errors, but this was on a different upgrade and I'm not sure if this applies here. Any help is appreciated.

    Below is a partial log from the upgrade:


    Checking for prerequisites...
    FOUND: NPTL
    FOUND: sudo-1.6.9p17-3
    FOUND: libidn-0.6.5-1.1
    FOUND: fetchmail-6.3.6-1.1
    FOUND: gmp-4.1.4-10
    FOUND: compat-libstdc++-296-2.96-138
    FOUND: compat-libstdc++-33-3.2.3-61
    FOUND: libtool-ltdl-1.5.22-6.1
    FOUND: /usr/lib/libstdc++.so.6
    Checking for suggested prerequisites...
    FOUND: perl-5.8.8
    Prerequisite check complete.
    Checking current number of databases...

    Do you want to verify message store database integrity? [Y] y
    Verifying integrity of message store databases. This may take a while.
    mysqld is alive
    Database errors found.
    /opt/zimbra/mysql/bin/mysqlcheck --defaults-file=/opt/zimbra/conf/my.cnf -S /opt/zimbra/db/mysql.sock -A -C -s -u root --password= --auto-repair
    mysql.columns_priv
    error : Table upgrade required. Please do "REPAIR TABLE `columns_priv`" to fix it!
    mysql.db
    error : Table upgrade required. Please do "REPAIR TABLE `db`" to fix it!
    mysql.func
    error : Table upgrade required. Please do "REPAIR TABLE `func`" to fix it!
    mysql.help_relation
    error : Table upgrade required. Please do "REPAIR TABLE `help_relation`" to fix it!
    mysql.host
    error : Table upgrade required. Please do "REPAIR TABLE `host`" to fix it!
    mysql.tables_priv
    error : Table upgrade required. Please do "REPAIR TABLE `tables_priv`" to fix it!
    mysql.time_zone
    error : Table upgrade required. Please do "REPAIR TABLE `time_zone`" to fix it!
    mysql.time_zone_leap_second
    error : Table upgrade required. Please do "REPAIR TABLE `time_zone_leap_second`" to fix it!
    mysql.time_zone_name
    error : Table upgrade required. Please do "REPAIR TABLE `time_zone_name`" to fix it!
    mysql.time_zone_transition
    error : Table upgrade required. Please do "REPAIR TABLE `time_zone_transition`" to fix it!
    mysql.time_zone_transition_type
    error : Table upgrade required. Please do "REPAIR TABLE `time_zone_transition_type`" to fix it!
    zimbra.current_volumes
    error : Table upgrade required. Please do "REPAIR TABLE `current_volumes`" to fix it!
    [root@mail1 zcs-5.0.18_GA_3011.RHEL5.20090707164432]#

  2. #2
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Code:
    su - zimbra
    zmlocalconfig -s | grep zimbra_mysql_password | awk '{ print $3 }'
    _then using that password you can run_
    mysqlcheck --defaults-file=/opt/zimbra/conf/my.cnf --socket=/opt/zimbra/db/mysql.sock -u zimbra -p zimbra

  3. #3
    Join Date
    Feb 2007
    Posts
    9
    Rep Power
    8

    Default

    uxbod,

    I did what you said, and it seems to have fixed it. Thanks!

    For anyone who is reading, the messages you get are:

    [zimbra@mail1 ~]$ /opt/zimbra/mysql/bin/mysqlcheck --defaults-file=/opt/zimbra/conf/my.cnf --socket=/opt/zimbra/db/mysql.sock -u zimbra -p zimbra
    Enter password:
    zimbra.config OK
    zimbra.current_volumes OK
    zimbra.deleted_account OK
    zimbra.jiveExtComponentConf OK
    zimbra.jiveGroupProp OK
    zimbra.jiveGroupUser OK
    zimbra.jiveID OK
    zimbra.jiveOffline OK
    zimbra.jivePrivacyList OK
    zimbra.jivePrivate OK
    zimbra.jiveProperty OK
    zimbra.jiveRemoteServerConf OK
    zimbra.jiveRoster OK
    zimbra.jiveRosterGroups OK
    zimbra.jiveSASLAuthorized OK
    zimbra.jiveUserProp OK
    zimbra.jiveVCard OK
    zimbra.jiveVersion OK
    zimbra.mailbox OK
    zimbra.mailbox_metadata OK
    zimbra.mucAffiliation OK
    zimbra.mucConversationLog OK
    zimbra.mucMember OK
    zimbra.mucRoom OK
    zimbra.mucRoomProp OK
    zimbra.out_of_office OK
    zimbra.scheduled_task OK
    zimbra.service_status OK
    zimbra.table_maintenance OK
    zimbra.volume OK
    [zimbra@mail1 ~]$
    Then re-run the install, and this time it gets through the database integrity checks just fine.

    Thanks again
    Last edited by jimramsey; 07-19-2009 at 03:16 AM. Reason: fix spelling error

Similar Threads

  1. Trouble Sending mail - All Messages deferred!
    By SiteDiscovery in forum Administrators
    Replies: 7
    Last Post: 09-03-2009, 05:52 AM
  2. ZCS 5.0.16 to 5.0.18 -- Preauth jsp Removed
    By Rebel6381 in forum Administrators
    Replies: 1
    Last Post: 07-14-2009, 01:23 PM
  3. Mail is being queued, not delivered!
    By icepick94 in forum Administrators
    Replies: 12
    Last Post: 01-22-2009, 07:03 AM
  4. Replies: 41
    Last Post: 10-29-2007, 03:36 PM
  5. ZCS 3.2 Beta Available
    By KevinH in forum Announcements
    Replies: 31
    Last Post: 07-07-2006, 04:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •