Results 1 to 4 of 4

Thread: [SOLVED] Moving zimbra to a new server (32 to 64) problems

  1. #1
    Join Date
    Aug 2009
    Rep Power

    Default [SOLVED] Moving zimbra to a new server (32 to 64) problems


    I'm planning to move our zimbra installation to a new server (from 32 to 64 bit). Here's the details:

    old (production) server: 5.0.12_GA_2790 running on RHEL 4.7
    new server: RHEL 5.3

    I've found some wiki articles -

    Ajcody-Notes-Server-Move - Zimbra :: Wiki
    Moving ZCS to Another Server » Zimbra :: Blog
    Network Edition: Moving from 32-bit to 64-bit Server - Zimbra :: Wiki

    These articles link to each other, and contradict each other at certain places. So, I emailed zimbra support. I was told to use the first article, that zimbra has tested the procedure, and that it works even on a move from 32 to 64 bit.

    So, following that procedure, I'm trying to do a "dry-run" of the migration. Here are my steps:

    1. Took an rsynch of the /opt/zimbra directory from the old, prod server to an external drive
    2. Installed bind on the new server, to answer queries for my domain and set it up to use this local bind for resolving
    3. Took the new server offline (ie unplugged it from the network)
    4. Gave the new server the same network/hostname info as the old production server
    5. Did a software only install on the new server of the same version of zimbra (ie ./ -s)
    6. Removed the zimbra directory and re-added it (rm -rf /opt/zimbra, mkdir /opt/zimbra)
    7. rsynch'ed my backup from the external drive into the /opt/zimbra directory
    8. Ran the zmfixperms script on the new server
    9. Ran another, full install on the new server (same version as step 5) - ie ./ with NO -s

    The install in step 9 goes through till the end, then throws an error -

    "zimbra system failure: unable to lookup server by name: [ldap: errror code 49 - invalid credentials]"

    So, the install is a bust as ZCS can't get to it's config in ldap. I quit the install. I run "zmlocalconfig -s | grep pass", and see the ldap passwords. I try to run an ldapsearch locally on the machine, and I get another "invalid credentials" error. It seems that the initial, software only install (in step 5) is setting the ldap password, then when I rsynch my backup into /opt/zimbra, it's putting another ldap password in there.

    However, after the install in step 9 fails, zimbra's slapd is running, and I try running an ldapsearch against it using both the ldap password from the software only install (step 5) and the ldap password from the rsynch'ed backup in step 7. With both passwords I get the "invalid credentials" error".

    While waiting for a reply email from zimbra, I've had a couple days to dig through the wiki/forums. I found a forum post -

    which discusses a quite different procedure (appears to be related to a previous release of ZCS). However, the procedure is similar to the one above except it involves dumping/restoring the ldap seperately (via an ldif file).

    So, I'm basically stuck. Any thoughts or help would be greatly appreciated.

  2. #2
    Join Date
    Jun 2009
    Rep Power


    You are moving Zimbra from 32 bits to 64 bits OS. please use this article,
    Network Edition: Moving from 32-bit to 64-bit Server - Zimbra :: Wiki or read on this post
    I am use article about and successfully move ZCS. 5.0.16 from Fedora Core7 32bits. ==> Ubuntu 8.04 64 bits, Problem is you are moving ZCS. to different OS. can not using "rsynch" all of /opt/zimbra from old server to new server because of some lib file is not same in 32bits and 64 bits.
    Last edited by Kernel; 08-05-2009 at 04:43 PM.
    Zimbra 7.2.0 on Dell R710| Ubuntu 8.04 x86_64, 8 GB. RAM, Dual Quad Xeon, 4X146 GB. SAS.
    Zimbra install as Multi Server MTA. & LDAP.+Mailbox server
    Zimbra install as VM on ESXi 5

  3. #3
    Join Date
    Aug 2009
    Rep Power


    Thanks for the reply. I started with that article, but was told by zimbra support that it wasnt' necessary, and that I could follow the rsynch procdure.

    Further, your statement about the rsynch method not working because of the different libraries between 32 and 64 bit isnt necessarily true. By reinstalling - ie upgrading, (step 9 in my post), the zimbra rpms should be updated to use the correct libraries. This was confirmed to me by zimbra support.

    However, I might try the method you suggested as I don't seem to be making any progress with my current one.

  4. #4
    Join Date
    Aug 2009
    Rep Power


    I've figured this out. Began using the following steps (found in this thread -

    1) Backup working zimbra
    2) Dump ldap to disk using wiki page (create ldif file)
    3) stop running zimbra, shut down machine
    4) bring up new machine with same hostname, same IP doesn't matter as long is DNS is redirecting
    5) install current version of zimbra with new flavor for OS. Go through entire setup (ie don't use ./ -s, just./
    6) wipe /opt/zimbra/openldap-data
    7) Import ldif file using wiki page
    8) Move /opt/zimbra/openldap-data dir to safe local
    9) replace /opt/zimbra with backup
    10) Move openldap-data dir into place (/opt/zimbra/openldap-data)
    11) run ./ -s

    but still had the ldap "invalid credentials" error using ldapsearch, and zimbra couldn't talk to ldap.

    The third page or so had more detailed steps, and that's what worked. Seems I wasnt handling the openldap-data directory correctly.

    Marked as solved.

Similar Threads

  1. Replies: 8
    Last Post: 01-20-2009, 12:06 PM
  2. 4.5 Upgrade failure
    By brained in forum Installation
    Replies: 9
    Last Post: 03-03-2007, 02:30 PM
  3. huge log size
    By rmvg in forum Administrators
    Replies: 5
    Last Post: 01-02-2007, 09:39 AM
  4. 3.1 on FC4 problems
    By cohnhead in forum Installation
    Replies: 8
    Last Post: 05-26-2006, 11:16 AM
  5. Zimbra server crashed
    By goetzi in forum Administrators
    Replies: 6
    Last Post: 03-25-2006, 12:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts