Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: mysql startup failure on new server

  1. #1
    Join Date
    Jul 2009
    Posts
    34
    Rep Power
    6

    Default mysql startup failure on new server

    what does this suggest?

    090807 21:30:08 mysqld started
    090807 21:30:08 [Warning] option 'max_join_size': unsigned value 18446744073709551615 adjusted to 4294967295
    090807 21:30:08 [Warning] option 'max_join_size': unsigned value 18446744073709551615 adjusted to 4294967295
    090807 21:30:08 [ERROR] Can't start server: cannot resolve hostname!: Success
    090807 21:30:08 mysqld ended

    fwiw


    [root@goose zimbra]# grep -i domain /opt/zimbra/config.*
    AVDOMAIN=goose.intranet.seamanpaper.com
    CREATEDOMAIN=goose.intranet.seamanpaper.com
    DOCREATEDOMAIN=yes

    [zimbra@goose ~]$ hostname
    goose.intranet.seamanpaper.com
    [zimbra@goose ~]$ dig +short `hostname` a
    192.168.10.112
    [zimbra@goose ~]$ dig +short `hostname` mx
    10 goose.intranet.seamanpaper.com.
    [zimbra@goose ~]$ dig +short intranet.seamanpaper.com mx
    10 buster.intranet.seamanpaper.com.

    Last edited by dreamgear; 08-07-2009 at 09:02 PM.

  2. #2
    Join Date
    Jul 2009
    Posts
    34
    Rep Power
    6

    Default

    fwiw

    [zimbra@goose ~]$ hostname
    goose.intranet.seamanpaper.com
    [zimbra@goose ~]$ dig +short `hostname` a
    192.168.10.112
    [zimbra@goose ~]$ dig +short `hostname` mx
    10 goose.intranet.seamanpaper.com.
    [zimbra@goose ~]$ dig +short intranet.seamanpaper.com mx
    10 buster.intranet.seamanpaper.com.
    [zimbra@goose ~]$

    [root@goose zimbra]# grep -i domain /opt/zimbra/config.*
    AVDOMAIN=goose.intranet.seamanpaper.com
    CREATEDOMAIN=goose.intranet.seamanpaper.com
    DOCREATEDOMAIN=yes

  3. #3
    Join Date
    Jul 2009
    Posts
    34
    Rep Power
    6

    Default

    This forum is confusing me. I added a reply but it does't appear.. and then when I try to post it again it tells me it's a duplicate. But the original is still not there several minutes later.

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by dreamgear View Post
    This forum is confusing me. I added a reply but it does't appear.. and then when I try to post it again it tells me it's a duplicate. But the original is still not there several minutes later.
    It's an anti-spam measure, as you're a new member your post was moderated and needed approving.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Code:
    cat /etc/hosts

  6. #6
    Join Date
    Jul 2009
    Posts
    34
    Rep Power
    6

    Default

    ::1 localhost.localdomain localhost

  7. #7
    Join Date
    Jul 2009
    Posts
    34
    Rep Power
    6

    Default

    BTW zmmtaconfig was looping solidly compute-bound even after I ran the shutdown script, after the installation script fell all over it self and looped for six hours berore I killed it. And what? This was because the *mysql* startup failed because the hostname was wrong ? Huh?

  8. #8
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by dreamgear View Post
    ::1 localhost.localdomain localhost
    You need a valid, and correct, hosts file. I'd suggest you check the Quick Start Installation Guide for the correct format, you'll also need valid DNS A & MX records and you can find details in the Split DNS article or the forums if you search.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  9. #9
    Join Date
    Jul 2009
    Posts
    34
    Rep Power
    6

    Default

    So in other words it doesn't use the standard APIs to determine hostname. FWIW hostname is set in /etc/sysconfig/network on red hat.

    And this has what to do with MySQL?

    Assuming this was in fact a stupid error on my part, you should still take note of the fact that the installation script just collapsed and did many wrong things after failing to check that the required configuration was in place.

    Thanks for the docs pointer, I hadn't found that before.
    Last edited by dreamgear; 08-10-2009 at 07:39 AM.

  10. #10
    Join Date
    Jul 2009
    Posts
    34
    Rep Power
    6

    Default

    Ok, I followed all the directions in the installation document, and it's doing exactly the same thing:

    Note the date/time:
    090810 14:17:43 mysqld started
    090810 14:17:43 [Warning] option 'max_join_size': unsigned value 18446744073709551615 adjusted to 4294967295
    090810 14:17:43 [Warning] option 'max_join_size': unsigned value 18446744073709551615 adjusted to 4294967295
    090810 14:17:43 [ERROR] Can't start server: cannot resolve hostname!: Success
    090810 14:17:43 mysqld ended

    Here's some more info:
    [root@goose log]# hostname
    goose.intranet.seamanpaper.com
    [root@goose log]# ifconfig | grep inet
    inet addr:192.168.10.112 Bcast:192.168.10.255 Mask:255.255.255.0
    inet6 addr: fe80::20c:29ff:fe66:3f93/64 Scope:Link
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    [root@goose log]# dig +short `hostname` a
    192.168.10.112
    [root@goose log]# dig +short `hostname` mx
    10 goose.intranet.seamanpaper.com.
    [root@goose log]# cat /etc/hosts
    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    ::1 localhost.localdomain localhost
    192.168.10.112 goose.intranet.seamanpaper.com goose
    [root@goose log]#

    What did I miss?

Similar Threads

  1. Zimbra secondary server installation failure
    By cdmdotnet in forum Installation
    Replies: 2
    Last Post: 04-27-2009, 05:20 PM
  2. Replies: 9
    Last Post: 02-25-2009, 04:39 AM
  3. Yet another get.DirectContext issue
    By dccpark in forum Installation
    Replies: 5
    Last Post: 03-08-2006, 01:25 PM
  4. Insallation failed (Debian server)
    By popui007 in forum Installation
    Replies: 5
    Last Post: 09-29-2005, 03:27 PM
  5. more fedora install problems
    By jlynch3 in forum Installation
    Replies: 13
    Last Post: 09-14-2005, 10:37 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •