Results 1 to 4 of 4

Thread: Upgrading from open source?

  1. #1
    Join Date
    Dec 2008
    Location
    Anchorage Alaska
    Posts
    17
    Rep Power
    6

    Default Upgrading from open source?

    We have installed Zimbra open source (Release 5.0.14_GA_2850.UBUNTU8_64 UBUNTU8_64 FOSS edition) but the customer just hates the web interface and wants to go back to Outlook. So we want to upgrade them to the Prof. version.
    I see in the wiki it says:
    On recent versions it may be possible to take a backup, then just run the NE .install.sh over your FOSS instance, with a purchased license handy. You should choose the same version of NE as you are currently running on FOSS for this transition to minimize other variables."
    From the way I read that I should be able to just upgrade the installed and running server. Someone how ever told me this can not be done and I would need to install on a different server.
    Can someone tell me can I just .install.sh over the running server to do this upgrade on the same hardware and not loose anything?

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    You should shutdown your current Zimbra and take a backup of the /opt/zimbra directory structure then run the './install.sh' to upgrade your OSS version to NE. When you've done the upgrade take a full backup of Zimbra with the NE backup tool.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Dec 2008
    Location
    Anchorage Alaska
    Posts
    17
    Rep Power
    6

    Default

    This is great. My thought was to first install the 5.0.14 version as that is what they are running.. test and make sure everything is running fine then upgrade to the 5.0.18 version. Or is it safe to go right to 5.0.18?

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by penbrock View Post
    This is great. My thought was to first install the 5.0.14 version as that is what they are running.. test and make sure everything is running fine then upgrade to the 5.0.18 version. Or is it safe to go right to 5.0.18?
    Yes, you must install the same version of NE over the OSS version. You can either get the NE 5.0.14 installed then upgrade (that would be my recommendation) or upgrade OSS to 5.0.18 the install NE. If you go for my suggestion then make sure you take a backup before doing the upgrade (you should, obviously, do that as good practice).
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Similar Threads

  1. ISP mail connection errors out
    By egottwald in forum Error Reports
    Replies: 1
    Last Post: 10-13-2008, 10:59 PM
  2. [Installation] Zimbra Desktop - Ubuntu 8.04 Hardy
    By kaltera in forum Installation Help
    Replies: 1
    Last Post: 06-18-2008, 04:43 AM
  3. [SOLVED] Is zimbra really open source product ?
    By hernad in forum Developers
    Replies: 3
    Last Post: 08-18-2007, 10:30 PM
  4. Error message in Server status
    By Max Ma in forum Installation
    Replies: 20
    Last Post: 04-19-2007, 08:55 AM
  5. M3 problem with shares
    By titangears in forum Users
    Replies: 4
    Last Post: 01-12-2006, 12:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •