Results 1 to 6 of 6

Thread: Zimbra on FC5

  1. #1
    Join Date
    May 2006
    Posts
    2
    Rep Power
    9

    Thumbs up Zimbra on FC5

    Just thought I'd post the caveats I had installing on FC5. On a fresh FC5 box I was able to get the zcs-3.1.2_GA_445.FC4.tgz install to work by doing the following:

    1. In /opt/zimbra/openldap-2.3.21/etc/openldap/slapd.conf change the line:

    loglevel @@ldap_log_level@@

    to:

    loglevel 4 #or whatever level you want the logging to be at

    2. Secondly, in /opt/zimbra/conf/ca/ca.pem change the lines:

    -----BEGIN TRUSTED CERTIFICATE-----
    -----END TRUSTED CERTIFICATE-----

    to:

    -----BEGIN CERTIFICATE-----
    -----END CERTIFICATE-----


    After that, rerun the /opt/zimbra/libexec/zmsetup.pl script and you should be good to go.

  2. #2
    Join Date
    Jun 2006
    Posts
    4
    Rep Power
    9

    Default No dice..

    Tried what you said and still get this:



    Note

    The previous configuration appears to have failed to complete

    Attempt to complete configuration now? [yes]
    Save configuration data to a file? [Yes]
    Save config in file: [/opt/zimbra/config.9617]
    Saving config in /opt/zimbra/config.9617...Done
    The system will be modified - continue? [No] yes
    Operations logged to /tmp/zmsetup.log.9617
    Initializing ldap...FAILED (256)


    ERROR



    Configuration failed

    Please address the error and re-run /opt/zimbra/libexec/zmsetup.pl to
    complete the configuration[root@localhost zcs]#



    Something else in LDAP? Library issue? Don't really even know where to check...

  3. #3
    Join Date
    Jun 2006
    Posts
    4
    Rep Power
    9

    Default Solved my own prob..

    Reading some other threads, before you do what's mentioned above, make sure you do this:

    # yum install openssl097a
    # cd /lib
    # ln -s libssl.so.0.9.7a libssl.so.5
    # ln -s libcrypto.so.0.9.7a libssl.so.5

    That will get all the libraries in the right place for LDAP to work.

    -Eric

  4. #4
    Join Date
    May 2006
    Posts
    2
    Rep Power
    9

    Default

    heh, that's interesting I was just going to post that you have to install an older version of openssl as well. It's weird though, I was able to complete the installation successfully without doing it, and everything would seem to be running fine, a "zmcontrol status" would report everything as running, but I couldn't send or receive email. Postfix would keep giving messages like:

    Jun 1 03:45:12 zimbra postfix/smtpd[19939]: initializing the server-side TLS engine
    Jun 1 03:45:12 zimbra postfix/master[6056]: warning: process /opt/zimbra/postfix-2.2.9/libexec/smtpd pid 19939 killed by signal 11
    Jun 1 03:45:12 zimbra postfix/master[6056]: warning: /opt/zimbra/postfix-2.2.9/libexec/smtpd: bad command startup -- throttling


    I just figured out a couple hours ago to install the old version of openssl. Oh yeah, one other thing, if you haven't done so already, disable SELinux as well, that causes problems.

  5. #5
    Join Date
    Jun 2006
    Posts
    4
    Rep Power
    9

    Default arghh.

    I'm right where you were now. Getting the postfix message:

    SSL_accept:error in SSLv3 read client certificate

    What did you do after you installed the older version? Did you link some other files or change some pointer to make it see that version of Open SSL?

    -Eric

  6. #6
    Join Date
    Jun 2006
    Posts
    4
    Rep Power
    9

    Default link..

    My fault again...

    Everyone make sure you link to the 0.9.7 libs and not the 0.9.8. Makes all the difference.


    I reiterate to Zimbra something someone else said: try if you can to get these things to work on non-version specific libs. Will make porting much easier for you and everyone else.

    -Eric

Similar Threads

  1. Replies: 31
    Last Post: 12-15-2007, 09:05 PM
  2. Zimbra shutdowns every n hours.
    By Andrewb in forum Administrators
    Replies: 13
    Last Post: 08-14-2007, 09:55 AM
  3. Fedora Core 3, Clean Install - Not working!
    By pcjackson in forum Installation
    Replies: 17
    Last Post: 03-05-2006, 07:38 PM
  4. Monitoring : Data not yet avalaible
    By s3nz3x in forum Installation
    Replies: 7
    Last Post: 11-30-2005, 07:18 PM
  5. FC3 Install and no zimbra ?
    By aws in forum Installation
    Replies: 10
    Last Post: 10-09-2005, 05:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •