Results 1 to 4 of 4

Thread: [SOLVED] Server Status connection refused in admin console

  1. #1
    Join Date
    Aug 2009
    Rep Power

    Default [SOLVED] Server Status connection refused in admin console

    I know there has been a similar thread before that has been marked solved (here). The author of the thread solved his problem by complete re-installation of the ZCS which at this time is NOT an option to me.

    We're in the process of evaluating ZCS Network Edition and so far we like it. The problem I need help with is that accidentially I installed the zimbra-logger package on both mailstore and MTA server.

    I quote from the other thread (as I am having exactly the same problem!):

    When I click on the server status item in the left panel of the administration web page, I received the following error:

    Message: error while proxying request to target server Connection refused Error code: service.PROXY_ERROR Method: GetServiceStatusRequest Details:soap:Receiver
    In the mailbox.log file I see:

    2009-08-18 09:09:39,192 INFO [btpool0-34] [;mid=4;ip=192.168.100 .29;ua=ZimbraWebClient - FF3.0 (Win);] SoapEngine - handler exception
    com.zimbra.common.service.ServiceException: error while proxying request to target server Connection timed out
    Code:service.PROXY_ERROR Argurl, STR, "")

    Our sever setup is quite simple. We have a dedicated mailstore server in the trusted network, and the MTA is located in our DMZ.

    I disabled the logger on the MTA after realising my mistake. Still it seems that a request is sent to the MTA on port 7071 which times out eventually causing an exception (I left the stack trace out but can supply one anytime needed).

    Please help me to fix this problem. As I said before, re-installation is not feasible.

    Thanks in advance,
    Timo Kosig

  2. #2
    Join Date
    Aug 2009
    Rep Power


    I solved the problem by setting zimbraLogHostname to the right hostname. After installing the logger on the mta zimbraLogHostname was set to

    zmprov modifyConfig zimbraLogHostname
    Did solve the problem - without re-installing everything.

  3. #3
    Join Date
    Jan 2009
    Rep Power


    That solved my problem too. Thanks for the tip!

  4. #4
    Join Date
    Jun 2011
    Rep Power

    Thumbs up Thank You !

    Thanks tkosig ! Your posts helped me solved my problem.

    Basically I have accidentally setup a Zimbra server with localhost.localdomain set as its hostname. Very bad.

    Some other post suggested to delete it from the Global Server config. However, it failed with error message :

    > zmprov ds localhost.localdomain
    ERROR: service.TOO_MANY_HOPS (mountpoint or proxy loop detected)
    So I checked to see what services that it had registered :

    ### set variables
    su - zimbra
    source ~/bin/zmshutil
    ### start checking current setting
    ldapsearch -LLL -x -D $zimbra_ldap_userdn -w $zimbra_ldap_password -H $ldap_url -b "" | grep -i localdomain
    zmprov -l gaa -s localhost.localdomain
    zmlocalconfig | grep -i localdomain
    zmprov gacf | grep -i localdomain
    Looks like zimbraLogHostname is the most important one.

    So I found your post, and how to change it :

    > zmprov modifyConfig zimbraLogHostname my.zimbra.server
    Voila ! No more "PROXY_ERROR Method: GetServiceStatusRequest" error message whenever I tried to access the Global Config

    Thanks again !

Similar Threads

  1. [SOLVED] zmclamdctl is not running
    By SamTzu in forum Administrators
    Replies: 9
    Last Post: 06-06-2012, 06:42 PM
  2. [SOLVED] mailbox and apache not running
    By rtwick in forum Administrators
    Replies: 4
    Last Post: 11-15-2008, 07:21 AM
  3. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 12:42 AM
  4. Error loading on Mac OS X 10.4.10 server PPC
    By qprcanada in forum Installation
    Replies: 7
    Last Post: 10-26-2007, 06:25 AM
  5. fatal: Queue report unavailable - mail system is down
    By zzzzsg in forum Administrators
    Replies: 16
    Last Post: 08-24-2006, 02:31 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts