Page 3 of 3 FirstFirst 123
Results 21 to 25 of 25

Thread: [SOLVED] ZCS 6.0: Postfix does not start

  1. #21
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Did you try running zmfixperms with --extended ?

  2. #22
    Join Date
    Dec 2006
    Posts
    27
    Rep Power
    8

    Default

    Quote Originally Posted by uxbod View Post
    Did you try running zmfixperms with --extended ?
    yes. That does not fix it - at least it does not set the permissions to 755. Not sure if we really need the "5" at the end for "others".

  3. #23
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Please file a RFE as zmfixperms needs that adding around line 512.

  4. #24
    Join Date
    Jun 2009
    Posts
    5
    Rep Power
    6

    Default

    Hi I'm having the same problem,

    please, can you explain what you mean when you say "Changing db files to just files resolves the issue"?

    Thank you!

    Quote Originally Posted by brian View Post
    Your /etc/nsswitch.conf contained

    This was causing libnss.so to load libnss_db.so which is linked against libdb-4.3.so. This conflicts with the bdb version libdb-4.7.so that postfix is linked against. Postfix output wasn't really indicating that it was segfaulting but if you tried to run /opt/zimbra/postfix/libexec/master by hand it was noticeable.

    Changing db files to just files resolves the issue.

  5. #25
    Join Date
    Dec 2006
    Posts
    27
    Rep Power
    8

    Default

    Quote Originally Posted by infajb View Post
    Hi I'm having the same problem,

    please, can you explain what you mean when you say "Changing db files to just files resolves the issue"?

    Thank you!
    Here are the relevant lines from nsswitch.conf. In some lines, it used to say "db files" instead of just "files".
    Code:
    hosts:          files mdns4_minimal [NOTFOUND=return] dns mdns4
    networks:       files
    
    protocols:       files
    services:        files
    ethers:          files
    rpc:             files
    Hope this helps!

Similar Threads

  1. postdrop fail to create file after upgrade to 5.0.3
    By echoadisan in forum Installation
    Replies: 23
    Last Post: 07-15-2013, 03:02 PM
  2. Trouble Sending mail - All Messages deferred!
    By SiteDiscovery in forum Administrators
    Replies: 7
    Last Post: 09-03-2009, 04:52 AM
  3. Mail is being queued, not delivered!
    By icepick94 in forum Administrators
    Replies: 12
    Last Post: 01-22-2009, 06:03 AM
  4. Is it started or not
    By kwelipatton in forum Installation
    Replies: 10
    Last Post: 03-28-2006, 10:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •