Results 1 to 1 of 1

Thread: [SOLVED] ZCS 6.0 GoDaddy cert install issue

  1. #1
    Join Date
    Sep 2009
    Rep Power

    Default [SOLVED] ZCS 6.0 GoDaddy cert install issue


    I have the latest ZCS (6.0) on fresh install on Ubuntu 8.06 64bit. Everything ok until I have replaced the self signed certificate.
    I have generated an CSR, go at GoDaddy and generate an certificate. I downloaded the certificate for Tomcat web server and followed the installation steps in ZCS. Then zmcontrol stop/start, then... problems:
    Starting ldap...Done.
    Unable to determine enabled services from ldap.
    Enabled services read from cache. Service list may be inaccurate.
    Starting logger...Done.
    Starting mailbox...Done.
    Starting antispam...Done.
    Starting antivirus...Done.
    Starting snmp...Done.
    Starting spell...Done.
    Starting mta...Done.
    Starting stats...Done.

    in zimbra log:

    service.FAILURE (system failure: ZimbraLdapContext) (cause:

    And the CPU's stays in 80% usage and no webaccess.

    I have reissued an self signed certificate from CLI:
    1. Begin by generating a new Certificate Authority (CA).
    zmcertmgr createca -new
    2. Then generate a certificate signed by the CA that expires in 365 days.
    zmcertmgr createcrt -new -days 365
    3. Next deploy the certificate.
    zmcertmgr deploycrt self
    4. To finish, verify the certificate was deployed to all the services.
    zmcertmgr viewdeployedcrt

    Then I was able to log on back in the admin section. I have repeated again everything but stil the same issue.

    What should I do? I need to use that certificate from a known CA.

    Additional details:
    - the hostname of the machine is the default and only domain in ZCS
    - host file ok
    - hostname is and the csr/certificate is for * (can this be the issue?). The reason for that is I have an virtual host like and I need the wildcard type of certificate.



    1. Download the certificates issued by GoDaddy for Tomcat webserver.
    2. Create a new folder 'certs" in /opt/zimbra
    3. chown -R zimbra:zimbra /opt/zimbra/certs
    4. rename the certificate file to commercial.crt and gd_bundle.crt to commercial_ca.crt
    5. cd /opt/zimbra/bin
    6. run: ./zmcertmgr deploycrt comm /opt/zimbra/certs/commercial.crt /opt/zimbra/certs/commercial_ca.crt
    7. restart zimbra (zmcontrol stop/start)

    Got inspired from:
    Last edited by georgelazar; 09-04-2009 at 11:34 AM.

Similar Threads

  1. Replies: 2
    Last Post: 03-15-2010, 04:04 PM
  2. Yahoo! Zimbra Desktop for ZCS 6.0 Guns and Roses
    By aldennis in forum General Questions
    Replies: 8
    Last Post: 09-11-2009, 06:02 PM
  3. [SOLVED] ZCS 5.0.15 Renewing GoDaddy Cert Failure
    By jmatos in forum Installation
    Replies: 3
    Last Post: 09-08-2009, 11:52 AM
  4. Replies: 41
    Last Post: 10-29-2007, 02:36 PM
  5. Replies: 2
    Last Post: 09-28-2006, 08:30 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts