Page 4 of 4 FirstFirst ... 234
Results 31 to 40 of 40

Thread: Error Valid backup file not found upgrading from 5.0.18 to 6

  1. #31
    Join Date
    Jan 2007
    Location
    Germany
    Posts
    42
    Rep Power
    8

    Default

    Quick status report.

    dunno why, but i find an actual ldap.bak in /temp with 69 kybte. copied it to /opt/zimbra/data/ldap/ dir - and started zmsetup.pl - but same error. the script overwrites the ldap.bak with a 0 byte version. hmm...chmod 440 on ldap.bak and restart zmsetup.pl - now it goes above this error - and still updating at this time
    Last edited by Nextasy; 09-07-2009 at 05:54 AM.

  2. #32
    Join Date
    Jan 2007
    Location
    Germany
    Posts
    42
    Rep Power
    8

    Default

    thx for help - its now solved.

  3. #33
    Join Date
    Aug 2007
    Posts
    6
    Rep Power
    8

    Default How was this sovled

    Hello,

    I have the exact same issue how was this solved in the end?

    thanks

  4. #34
    Join Date
    Nov 2009
    Posts
    3
    Rep Power
    6

    Default Please post your solution

    Quote Originally Posted by Nextasy View Post
    thx for help - its now solved.
    Same for me. I have the exact same phenomenon when updating to 6.0 and desperately would like to know what action actually solved this problem. Thanx for reply

  5. #35
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Post #31 would appear to have the answer, does that not work for you?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  6. #36
    Join Date
    Aug 2007
    Posts
    6
    Rep Power
    8

    Default

    Post #31 did nto work for me. I could not find a ldap.bak in temp, I am running Fedora 7, so /tmp. I also tried to restoring from backup earlier and it failed.

  7. #37
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    Bug 43591 – ldap.bak issues on GNR upgrades

    Quanah also pointed out that depending on when you create this ldap.bak (if your not using one that was created earlier like ldap.bak.timestamp) have to be using the 5.0 slapcat/sleepycatlibs for BDB differences with 6.0 to get a valid backup.

  8. #38
    Join Date
    Jan 2009
    Posts
    9
    Rep Power
    6

    Default

    Just to add one more touch;

    I was able to find an ldap.bak in the still existing openldap-data directory, copy it over to data/ldap and chmod 440, rerun /opt/zimbra/libexec/zmsetup.pl and it worked like a charm.


    At first I thought I b0rked my install, by trying to go from 5.0.20 > 6.0.0; when it failed, I figured that was the cause of 6.0.3 breaking.

    I hope that helps someone out there

  9. #39
    Join Date
    Nov 2009
    Posts
    3
    Rep Power
    6

    Default my only solution: redo the whole upgrade again

    sorry guys, i wanted to post my experience in that topic but i have forgotten to post it yet.

    Since i had not found any ldap.bak file in the mentioned directories either, i saw my last change in redoing the whole upgrade process again from scratch. so after another restore of a blank machine, replaying the bakup and starting the upgrade sequence, i was at that point and the upgrade script did not stop at that time and the upgrade finished without any problems.

    So this was my experience with that incident in this case. From that day on i have a functional system running for about 4 weeks now.

  10. #40
    Join Date
    Jun 2009
    Posts
    10
    Rep Power
    6

    Default

    I ran into the same problem.. fortunately, in the folder (/opt/zimbra/data/ldap), there was a backup with the first timestamp that wasn't 0 size- *copied* it to ldap.bak and chmod to 440 and the install worked past that point.

Similar Threads

  1. bayes db..
    By osiris in forum Administrators
    Replies: 9
    Last Post: 06-15-2011, 12:14 PM
  2. Replies: 20
    Last Post: 03-18-2008, 06:37 AM
  3. i made a mess 4.5.6 -> 4.5.10 to a future 5.0 FOSS
    By innercy in forum Installation
    Replies: 7
    Last Post: 01-09-2008, 07:05 PM
  4. Zimbra Install Problem - getDirectContext
    By bsimzer in forum Installation
    Replies: 27
    Last Post: 07-19-2007, 11:12 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •