Results 1 to 2 of 2

Thread: [SOLVED] MailRelay (DynDNS) on Zimbra 6

  1. #1
    Join Date
    Mar 2008
    Posts
    55
    Rep Power
    7

    Default [SOLVED] MailRelay (DynDNS) on Zimbra 6

    I upgraded from Zimbra 5.0.18 to 6.0.0 (Ubuntu 8.04 32 Bit).

    The 5.0.18 Zimbra configuration was configured last November and worked fine. As I have a dynamic DNS, I use the DynDNS mailhop service. See Outgoing SMTP Authentication - Zimbra :: Wiki

    Since I upgraded to 6.0.0, sending e-mail is no more possible. /var/log/mail.info shows:

    to=aaa@bb.com,relay=outbound.mailhop.org[99.999.999.999]:2525, delay=1.1, delays=0.03/0.01/0.96/0.11, dsn=5.0.0, status=bounced (host outbound.mailhop.org[99.999.999.999] said: 550 You must authenticate to use MailHop Outbound (in reply to MAIL FROM command))
    The sender receives an error message with the same information. What has changed in 6.0.0?

    I noticed that the postmap command behaves differently:
    echo outbound.dyndns.org:2525 user@domain.com: password > /opt/zimbra/conf/relay_password
    postmap hash:/opt/zimbra/conf/relay_password
    postmap -q smtp.gmail.com /opt/zimbra/conf/relay_password
    postmap -q returns the username and password in 5.0.18 - in 6.0.0 it returns an empty string. This might be a hint why the mail relay as well does not get a username/password causing the 550 error message
    Last edited by mfehr; 09-07-2009 at 01:51 PM.

  2. #2
    Join Date
    Mar 2008
    Posts
    55
    Rep Power
    7

    Default Postfix configuration was reset during upgrade

    I found the issue. It seems that the postfix configuration was reset during the upgrade from 5.0.18 to 6.0.0

    I checked the configuration of postmap and I found differences between v5 and v6 (Luckily, I run my zimbra server in a VMware instance; I am back on 5.0.18 but am still able to experiment the 6.0.0 upgrade using a different IP address):

    postconf ¦ grep smtp_

    I had to change the following settings to get it working again:

    postconf -e smtp_sasl_security_options=noanonymous
    postconf -e smtp_cname_overrides_servername=no
    postconf -e smtp_sasl_auth_enable=yes
    postconf -e smtp_sasl_password_maps=hash:/opt/zimbra/conf/relay_password

    I checked the /var/log/mail.info to see that the message was successfully delivered.

    BTW: In my initial message, I mixed up the sample with gmail addresses and the dyndns hostnames. Therefore, I did not get a valid info from postmap. Entering the command with the proper information delivers the expected result... - Sorry for potential confusion.

Similar Threads

  1. Replies: 8
    Last Post: 01-12-2012, 01:20 AM
  2. admin consol blank after 5.0.3 upgarde
    By maumar in forum Administrators
    Replies: 6
    Last Post: 03-21-2008, 05:16 AM
  3. Replies: 12
    Last Post: 02-25-2008, 06:28 PM
  4. Zimbra shutdowns every n hours.
    By Andrewb in forum Administrators
    Replies: 13
    Last Post: 08-14-2007, 08:55 AM
  5. Fedora Core 3, Clean Install - Not working!
    By pcjackson in forum Installation
    Replies: 17
    Last Post: 03-05-2006, 06:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •