Results 1 to 8 of 8

Thread: problem about host lookup.failed

Hybrid View

  1. #1
    Join Date
    Jun 2006
    Posts
    5
    Rep Power
    9

    Default problem about host lookup.failed

    the problem when starting zimbra service
    in Fedora 4
    details:
    [root@mailhost ~]# service zimbra start
    java.net.UnknownHostException: mailhost.example.com: mailhost.example.com
    at java.net.InetAddress.getLocalHost(InetAddress.java :1308)
    at com.zimbra.cs.localconfig.LC.(LC.java:160)
    at com.zimbra.cs.localconfig.KnownKey.(KnownKey.java:39)
    at com.zimbra.cs.localconfig.LocalConfig.verify(Local Config.java:337)
    at com.zimbra.cs.localconfig.LocalConfig.(LocalConfig.java:185)
    at com.zimbra.cs.localconfig.LocalConfig.readConfig(L ocalConfig.java:360)
    at com.zimbra.cs.localconfig.LocalConfig.(LocalConfig.java:365)
    at com.zimbra.cs.localconfig.Main.main(Main.java:116)
    Host lookup.failed
    ------------------------------------
    I have changed the host name to mailhost.example.com and added FQDN
    before hostname, as described in the quick-start, but it doesn't work.
    Have any suggestion?

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Welcome to the forums.

    Does the host actually point to your internal IP address of the Zimbra server? Do you also have a local DNS server with MX records pointing to the Zimbra server? Were there any problems in the install logs?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Jun 2006
    Posts
    5
    Rep Power
    9

    Default

    I'm not sure about these issues. I didn't install the spell package, for this package was failed to be installed, and there is not other problem when installing.
    Quote Originally Posted by phoenix
    Welcome to the forums.

    Does the host actually point to your internal IP address of the Zimbra server? Do you also have a local DNS server with MX records pointing to the Zimbra server? Were there any problems in the install logs?

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by jipeng
    I'm not sure about these issues. I didn't install the spell package, for this package was failed to be installed, and there is not other problem when installing.
    What has the spell package got to do with a hostname problem? You need to look in the install logs and see if there were any problems. If you are still having problems with hostname resolution you either have a hosts file problem or your DNS set-up is incorrect (or DNS isn't installed).
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    Join Date
    Jun 2006
    Posts
    5
    Rep Power
    9

    Default

    Thanks for your reply. there is parts of the logs:
    -------------------------------------------------------
    COMMAND: zmlocalconfig -s | sed -e "s/ = \(.*\)/=\'\1\'/" > /opt/zimbra/.saveconfig/config.save
    java.net.UnknownHostException: fedora.xjtuse.edu.cn: fedora.xjtuse.edu.cn
    at java.net.InetAddress.getLocalHost(InetAddress.java :1308)
    at com.zimbra.cs.localconfig.LC.(LC.java:160)
    at com.zimbra.cs.localconfig.KnownKey.(KnownKey.java:39)
    at com.zimbra.cs.localconfig.LocalConfig.verify(Local Config.java:337)
    at com.zimbra.cs.localconfig.LocalConfig.(LocalConfig.java:185)
    at com.zimbra.cs.localconfig.LocalConfig.readConfig(L ocalConfig.java:360)
    at com.zimbra.cs.localconfig.LocalConfig.(LocalConfig.java:365)
    at com.zimbra.cs.localconfig.Main.main(Main.java:116)
    COMMAND: zmcontrol shutdown
    java.net.UnknownHostException: fedora.xjtuse.edu.cn: fedora.xjtuse.edu.cn
    at java.net.InetAddress.getLocalHost(InetAddress.java :1308)
    at com.zimbra.cs.localconfig.LC.(LC.java:160)
    at com.zimbra.cs.localconfig.KnownKey.(KnownKey.java:39)
    at com.zimbra.cs.localconfig.LocalConfig.verify(Local Config.java:337)
    at com.zimbra.cs.localconfig.LocalConfig.(LocalConfig.java:185)
    at com.zimbra.cs.localconfig.LocalConfig.readConfig(L ocalConfig.java:360)
    at com.zimbra.cs.localconfig.LocalConfig.(LocalConfig.java:365)
    at com.zimbra.cs.localconfig.Main.main(Main.java:116)
    Host lookup.failed
    Stopping antispam...Done
    Stopping antivirus...Done
    Stopping ldap...Done
    Stopping logger...Done
    Stopping mailbox...FAILED
    Error: no pid in /opt/zimbra/log/tomcat.pid
    Error: assertion '-r /opt/zimbra/conf/my.cnf' failed
    ------------------------------------------------------------

    Maybe the reason is that I changed the hostname and edited /etc/hosts after the installation. Reinstallation may solve the problem, but is there any other ways? I make use of the zmprov command, however, there is error:
    -------------------------------------
    $zmprov createServer fedora.xjtuse.edu.cn
    ERROR: service.FAILURE (system failure: getDirectContext) (cause:
    javax.naming.C ommunicationException localhost:389)
    ------------------------------------
    PS: sorry for the duplicate post
    Last edited by jipeng; 06-08-2006 at 09:33 PM.

  6. #6
    Join Date
    Jun 2006
    Posts
    5
    Rep Power
    9

    Default

    I have another try:
    [zimbra@mailhost tmp]$ zmlocalconfig -e zimbra_server_hostname=mailhost.example.com
    [root@mailhost /]# service zimbra restart
    Host mailhost.example.com
    Stopping antispam...Done
    Stopping antivirus...Done
    Stopping ldap...Done
    Stopping logger...Done
    Stopping mailbox...FAILED
    Error: no pid in /opt/zimbra/log/tomcat.pid
    Error: assertion '-r /opt/zimbra/conf/my.cnf' failed


    Stopping mta...Done
    Stopping snmp...Done
    Stopping spell...Done
    Host mailhost.example.com
    -------------------------------------------------
    However the service still can not work well:
    [root@mailhost /]# telnet mailhost.example.com 80
    Trying 127.0.0.1...
    telnet: connect to address 127.0.0.1: Connection refused
    telnet: Unable to connect to remote host: Connection refused
    [root@mailhost /]# telnet mailhost.example.com 7071
    Trying 127.0.0.1...
    telnet: connect to address 127.0.0.1: Connection refused
    telnet: Unable to connect to remote host: Connection refused

Similar Threads

  1. Filter problem with relay host
    By sdgeek in forum Installation
    Replies: 2
    Last Post: 03-19-2007, 07:07 PM
  2. Installation Cancelled - Zimbra-spell !
    By Ledg in forum Installation
    Replies: 4
    Last Post: 10-19-2006, 03:54 AM
  3. Problem about host looup.failed
    By jipeng in forum Administrators
    Replies: 1
    Last Post: 06-08-2006, 01:49 AM
  4. Is it started or not
    By kwelipatton in forum Installation
    Replies: 10
    Last Post: 03-28-2006, 11:11 PM
  5. Unknown Host ?
    By msentissi in forum Administrators
    Replies: 5
    Last Post: 03-18-2006, 03:57 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •