Results 1 to 3 of 3

Thread: Java problems with ZCS 6.0.1 GA (Mac OS X 10.5)

  1. #1
    Join Date
    Oct 2008
    Rep Power

    Default Java problems with ZCS 6.0.1 GA (Mac OS X 10.5)

    Yesterday we upgraded from ZCS 5.0.18 to ZCS 6.0.1 and among other problems that forced us to downgrade to version 5 (see this link) we have also experienced some java problems; all services started fine but the zmprov command failed with this error message:
    java.lang.InternalError: Could not start up the CDSA libraries.
    and also the admin console did not work. Rebooting the servers fixed the java problem the first time, then it randomly appeared again but it seems that zmcontrol stop && zmcontrol start fixed it.
    Below you can find an excerpt from the log files:
    2009-09-16 08:20:03,573 INFO  [btpool0-0] [ip=;] AuthProvider - Adding auth provider: zimbra com.zimbra.cs.service.ZimbraAuthProvider
    2009-09-16 08:20:03,577 INFO  [btpool0-0] [ip=;] soap - AuthRequest
    2009-09-16 08:20:03,741 WARN  [btpool0-0] [name=zimbra;ip=;] SoapEngine - handler exception
    java.lang.InternalError: Could not start up the CDSA libraries.
    	at java.lang.ClassLoader$NativeLibrary.load(Native Method)
    	at java.lang.ClassLoader.loadLibrary0(
    	at java.lang.ClassLoader.loadLibrary(
    	at java.lang.Runtime.loadLibrary0(
    	at java.lang.System.loadLibrary(
    	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
    	at sun.reflect.NativeConstructorAccessorImpl.newInstance(
    	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(
    	at java.lang.reflect.Constructor.newInstance(
    	at java.lang.Class.newInstance0(
    	at java.lang.Class.newInstance(
    	at javax.crypto.Mac.a(DashoA12275)
    	at javax.crypto.Mac.init(DashoA12275)
    	at com.zimbra.cs.account.ZimbraAuthToken.getHmac(
    	at com.zimbra.cs.account.ZimbraAuthToken.getEncoded(
    	at com.zimbra.cs.account.ZimbraAuthToken.getOrigAuthData(
    	at com.zimbra.cs.account.ZimbraAuthToken.encodeAuthResp(
    	at com.zimbra.cs.service.admin.Auth.doResponse(
    	at com.zimbra.cs.service.admin.Auth.handle(
    	at com.zimbra.soap.SoapEngine.dispatchRequest(
    	at com.zimbra.soap.SoapEngine.dispatch(
    	at com.zimbra.soap.SoapEngine.dispatch(
    	at com.zimbra.soap.SoapServlet.doWork(
    	at com.zimbra.soap.SoapServlet.doPost(
    	at javax.servlet.http.HttpServlet.service(
    	at com.zimbra.cs.servlet.ZimbraServlet.service(
    	at javax.servlet.http.HttpServlet.service(
    	at org.mortbay.jetty.servlet.ServletHolder.handle(
    	at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(
    	at org.mortbay.servlet.UserAgentFilter.doFilter(
    	at org.mortbay.servlet.GzipFilter.doFilter(
    	at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(
    	at org.mortbay.jetty.servlet.ServletHandler.handle(
    	at org.mortbay.jetty.servlet.SessionHandler.handle(
    	at org.mortbay.jetty.handler.ContextHandler.handle(
    	at org.mortbay.jetty.webapp.WebAppContext.handle(
    	at org.mortbay.jetty.handler.ContextHandlerCollection.handle(
    	at org.mortbay.jetty.handler.HandlerCollection.handle(
    	at org.mortbay.jetty.handler.HandlerWrapper.handle(
    	at org.mortbay.jetty.handler.rewrite.RewriteHandler.handle(
    	at org.mortbay.jetty.handler.HandlerWrapper.handle(
    	at org.mortbay.jetty.Server.handle(
    	at org.mortbay.jetty.HttpConnection.handleRequest(
    	at org.mortbay.jetty.HttpConnection$RequestHandler.content(
    	at org.mortbay.jetty.HttpParser.parseNext(
    	at org.mortbay.jetty.HttpParser.parseAvailable(
    	at org.mortbay.jetty.HttpConnection.handle(
    	at org.mortbay.thread.BoundedThreadPool$

  2. #2
    Join Date
    Jun 2008
    Rep Power


    I'm seeing the same error regarding CDSA libraries on OS X Server 10.5.8. zmcontrol stop and zmcontrol start fixed it for now.

    Release 6.0.1_GA_1816.MACOSXx86_10.5, Zimbra, Inc.
    MACOSXx86_10.5 NETWORK edition.

  3. #3
    Join Date
    Jan 2009
    Rep Power


    I thinks the reason is:
    -in version 6.x, it has some class that hasn't in version 5.x
    In your log, it said that it can't find some class

Similar Threads

  1. Zimbra on Mac OS X 10.5.7 - Problems after Java Update
    By andreas_auwaerter in forum Administrators
    Replies: 10
    Last Post: 08-25-2009, 03:03 PM
  2. Replies: 2
    Last Post: 05-06-2009, 10:27 AM
  3. Mail is being queued, not delivered!
    By icepick94 in forum Administrators
    Replies: 12
    Last Post: 01-22-2009, 06:03 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts