Results 1 to 2 of 2

Thread: [SOLVED] Error while testing after installation

  1. #1
    Join Date
    Jan 2009
    Rep Power

    Default [SOLVED] Error while testing after installation

    Hello All,

    I am getting the following error while sending a test email after my installation. Setup is domain registered--> hosting server at home using dyndns-->ISP verizon.

    I did the following:

    Enable SMTP authentication on outbound messages:


    $ postconf -e smtp_sasl_auth_enable=yes

    Create a file text file mapping which name/password should be used for
    which given outbound destination. This file can contain multiple


    $ echo userassword > /opt/zimbra/conf/relay_password

    Create a postfix lookup table from this text file:


    $ postmap /opt/zimbra/conf/relay_password

    Test that the map is okay and that the user: password pair is returned.


    $ postmap -q /opt/zimbra/conf/relay_password

    Make postfix use this:


    $ postconf -e smtp_sasl_password_maps=hash:/opt/zimbra/conf/relay_password
    $ postfix reload
    Error I am getting
    : host[]
    said: 550 5.7.1 Authentication Required (in reply to MAIL FROM command)
    Thanks in advance.

  2. #2
    Join Date
    Jan 2009
    Rep Power


    I am getting a new error after I ran the following command:

    postconf -e smtp_cname_overrides_servername=no
    new error

    After sending a test message, check the Log Files for the error:

    (Authentication failed: cannot SASL authenticate to server ...: no mechanism available)

    You can fix this problem by tweaking the auth mechanisms that postfix is willing to use. First check what auth mechanism postfix is configured to use - by default, you will see:

    postconf smtp_sasl_security_options
    smtp_sasl_security_options = noplaintext, noanonymous

    Since noplaintext is present, postfix will refuse to use a mechanism that sends passwords in the clear. If your upstream relay host only supports PLAIN or LOGIN mechanisms (both of which send password in the clear), you have to remove noplaintext from smtp_sasl_security_options:

    postconf -e smtp_sasl_security_options=noanonymous
    postfix reload
    Applying this to see if it fixed it if so you can close this post.
    Last edited by Infolookup; 09-27-2009 at 07:43 PM.

Similar Threads

  1. Installation Issues - SLES 10_Zimbra 5.0 Beta 3
    By rhartman in forum Installation
    Replies: 3
    Last Post: 01-14-2008, 06:18 AM
  2. 3 testing: LDAP: 389 Failed when restore zimbra
    By victorLeong in forum Administrators
    Replies: 15
    Last Post: 05-24-2007, 06:45 AM
  3. Installation Failed
    By freit5 in forum Installation
    Replies: 2
    Last Post: 08-17-2006, 11:38 PM
  4. Replies: 16
    Last Post: 01-05-2006, 08:55 AM
  5. Installation problem
    By sywong70 in forum Installation
    Replies: 5
    Last Post: 11-07-2005, 08:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts