Results 1 to 8 of 8

Thread: Enabling dspam, razor, pyzor etc

  1. #1
    Join Date
    Oct 2009
    Location
    UK
    Posts
    32
    Rep Power
    6

    Default Enabling dspam, razor, pyzor etc

    I'm having problems enabling dspam, razor and pyzor in Zimbra 6.0.1. It just doesn't seem to work.

    I've done all the stuff required for razor and pyzor, and they are enabled in the spamassassin v310.pre file.

    I've enabled dspam by editing the amavisd.conf.in like I did in v5.x of Zimbra but no incoming email is being marked with header info for either dspam, razor or pyzor.

    I edited local.cf to put scoring information for dspam. I also note this post when I searched:

    http://www.zimbra.com/forums/install...6-3-dspam.html

    but the additional config doesn't make any sense to me. Where does it go, and why the change in the first place? Why not keep it simple like it was in v5.x? There doesn't seem to be any documented information on enabling these features.

    Any ideas on how I can get dspam working again? As well as razor and pyzor.

  2. #2
    Join Date
    Oct 2009
    Location
    UK
    Posts
    32
    Rep Power
    6

    Default

    Nobody got any ideas?!?

  3. #3
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Do you have the spamassassin binary on your server ? If so you could do
    Code:
    su - zimbra
    spamassassin -C /opt/zimbra/conf -D --lint > /tmp/sadebug 2>&1
    to make sure no errors.

  4. #4
    Join Date
    Oct 2009
    Posts
    6
    Rep Power
    6

    Default Different way of doing things.

    Please see
    MTA Functionality

    That is only for dspam.

    Still trying to sort out razor & pyzor myself.

  5. #5
    Join Date
    Oct 2009
    Posts
    6
    Rep Power
    6

    Default Different way of doing things.

    there is a line in
    /opt/zimbra/conf/spamassassin/25_razor2.cf
    that says 'ifplugin Mail::SpamAssassin::Plugin::Razor2'
    so after following the instructions at
    Improving Anti-spam system - Zimbra :: Wiki
    and restarting the required services, it should hopefully work properly (without having to edit the
    /opt/zimbra/conf/spamassassin/local.cf
    file

  6. #6
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Indeed ... you could create you own .cf under /opt/zimbra/conf/spamassassin and that will get called via Amavisd. That means you can have you own configs without affecting the vanilla ZCS ones.

  7. #7
    Join Date
    Oct 2009
    Location
    UK
    Posts
    32
    Rep Power
    6

    Default

    I don't have any problems with amavisd, spamassassin. dspam is enabled as per the documentation, but it doesn't work.

    Email headers are not being scored, the amavisd config has not been edited other than enabling dspam. Prior to upgrade to 6.0.1 it worked.

  8. #8
    Join Date
    Oct 2009
    Location
    UK
    Posts
    32
    Rep Power
    6

    Default

    Never mind, after upgrade to 6.0.2 it's working again.

Similar Threads

  1. Enabling DSPAM
    By osiris in forum Administrators
    Replies: 80
    Last Post: 09-20-2012, 05:10 PM
  2. zimbra 6.0b1 not installing on Mac OS X 10.5.6
    By funkahdafi in forum Installation
    Replies: 5
    Last Post: 05-13-2009, 10:51 PM
  3. Installing Zimbra on Ubuntu 8.04 (Hardy)
    By tikitom in forum Installation
    Replies: 33
    Last Post: 03-03-2009, 12:23 PM
  4. [SOLVED] Install Problem in Ubuntu 6.06 Server
    By xtimox in forum Installation
    Replies: 16
    Last Post: 03-27-2008, 10:36 AM
  5. Enabling DSPAM
    By plan9 in forum Administrators
    Replies: 6
    Last Post: 07-18-2007, 11:55 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •