Hello everybody,

We are facing a problem with the Notebook (Documents) function. After installing Zimbra in our server, we realized that the Documents feature wasn't working. The page always showed an "system failure: wiki formatter failure" error. After searching this Forum, i discovered this normally means that the Documents feature wasn't enabled. Unfortunately i could only find this solution for Zimbra 4 Upgrade (and we use Zimbra 5.0.18 here):

Documents - Enabling for 4.0 Upgrade - Zimbra :: Wiki

Trying to adapt the solution to our version, i realized that the user "wiki@domain.com" wasn't created at all in the installation process. Neither another user with the description "Global Documents account". As i didn't perform the installation myself, i can't tell you if some error occured during the process, but the colleague that did it said the installation ran normally. So that lead us to my first question: what could have happened to avoid the creation of such user?

Going on, i then tried to create this user myself: in the Admin Console i created an user "wiki@domain.com", and using the following commands (ran as zimbra) i set it as the Notebook user:

zmprov mcf zimbraNotebookAccount wiki@domain.com
zmprov initNotebook

If i run the command as the help for Zimbra 4 says (zmprov initNotebook wiki@domain.com /opt/zimbra/wiki/Template Template) i got a syntax error in the command line. That's why i ran it in that different way.

After doing that and restarting Jetty, i discovered that the error was no longer showed in the Documents page, instead only a blank page was showed. A little research showed me the command "zmprov ut /opt/zimbra/wiki/Template", and after running it, i could see finally the Documents page. But with a difference from all other installations (where the wiki user were automatically created): now, when i create a document, and then click on its name to open it, the document is opened in the same iframe, and no password is asked. In all other servers i installed before to test, i always had to authenticate again (in a browser window, like .htaccess from Apache) before seeing a document, and also, the document was always opened in another tab/window. This is my second question: what did i do wrong to receive this strange behavior? And also, sometimes the Documents page (i mean, only the content of the internal iframe) loads without any css formatation, only pure html. Why?

Sorry about the long text, but i tried to explain exactly every step i took to get where i am now. Any help or tip will be greatly appreciated. And just in case that makes a difference, we ran Zimbra over an Ubuntu with kernel 2.6.24 over a AMD64 machine. If further details about the hardware or our configuration are needed, i'll be pleased to inform.

Thanks a lot,