Results 1 to 3 of 3

Thread: upgrading from 5 to 6, change OS...

  1. #1
    Join Date
    Jan 2008
    Posts
    70
    Rep Power
    7

    Default upgrading from 5 to 6, change OS...

    Hi,

    I have running debian etch with zcs-5.0.6_GA.

    I am building a new mail server, with debian lenny (etch is so old now) and want to use zcs-6.0.1_GA

    I have my server set up, but cannot install 5.06 on lenny - wrong OS error.

    When I try install 6.01 over the 5.06 folders I get (see below) How can I proceed with a pleasant experience from here?

    kind regards

    Brian

    Checking for prerequisites...
    FOUND: NPTL
    FOUND: sudo-1.6.9p17-2
    FOUND: libidn11-1.8+20080606-1
    FOUND: libpcre3-7.6-2.1
    FOUND: libgmp3c2-2:4.2.2+dfsg-3
    FOUND: libexpat1-2.0.1-4
    FOUND: libstdc++6-4.3.2-1.1
    FOUND: libstdc++5-1:3.3.6-18
    Checking for suggested prerequisites...
    FOUND: perl-5.10.0
    FOUND: sysstat
    Prerequisite check complete.
    Checking current number of databases...

    Checking for installable packages

    Found zimbra-core
    Found zimbra-ldap
    Found zimbra-logger
    Found zimbra-mta
    Found zimbra-snmp
    Found zimbra-store
    Found zimbra-apache
    Found zimbra-spell
    Found zimbra-memcached
    Found zimbra-proxy


    The Zimbra Collaboration Suite does not appear to be installed,
    yet there appears to be a ZCS directory structure in /opt/zimbra.

  2. #2
    Join Date
    Jan 2008
    Posts
    70
    Rep Power
    7

    Default I hacked the install scripts

    util/modules/packages.sh

    line 150 - 155 commented out.

    #if [ x$LOCALPROC != x$PROC ]; then
    # echo "Error: attempting to install $PROC packages on a $LOCALPROC OS."
    # echo "Exiting..."
    # echo ""
    # exit 1
    # fi

    and used the

    ./install.sh -platform-override

    command, it failed after installing the packages... but that should be enough :-) will advise any further grief.

  3. #3
    Join Date
    Jan 2008
    Posts
    70
    Rep Power
    7

    Default cant check message store integrity

    perl incompatabilities.. chose N for check message store.

Similar Threads

  1. Upgrading Zimbra and OS
    By AutootuA in forum Installation
    Replies: 1
    Last Post: 09-29-2009, 12:40 PM
  2. Upgrading to 5.0.16 OS with posix/samba extensions
    By trakkert in forum Installation
    Replies: 3
    Last Post: 06-11-2009, 08:47 AM
  3. upgrading from 5.0.4 to 5.0.5 opensource
    By smoke in forum Installation
    Replies: 4
    Last Post: 10-19-2008, 10:38 AM
  4. Replies: 2
    Last Post: 06-20-2008, 10:43 AM
  5. Question about upgrading to Zimbra 4 OS
    By Thomas.Curtis in forum Installation
    Replies: 4
    Last Post: 01-02-2007, 04:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •