Results 1 to 2 of 2

Thread: HELP! Upgraded to 3.1.3 and lost my domain and all users!

  1. #1
    Join Date
    Mar 2006
    Posts
    16
    Rep Power
    9

    Default HELP! Upgraded to 3.1.3 and lost my domain and all users!

    HELP!!!

    I upgraded from 3.0.1 to 3.1.3 last night thinking all users, domains, accounts, etc would be retained.

    The install went fine.

    Now I can't login as an of my users - admin or regular. I have two domains: mail.toplevel.info and toplevel.info. All users were created under toplevel.info. That doesn't exist now! (By using the zimbra command line commands...)

    I created a test admin user and can confirm in the admin UI that my toplevel.info domain is NOT there and NONE of my users are there.

    I'm panicked. Help. What can be done to retrofit the upgrade? Is this normal that users/domains are not retained? What can I do to see if my accounts/users are still there?

    Thanks

    cjhall

  2. #2
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    So I suppose you know my first question:
    Do you have a backup?

    If not, before you proceed ANY further, make a backup.

    Users and domains are stored in LDAP, and something must have gone wrong; however, (If I'm right) LDAP is now backed up automatically during the upgrade.

    I don't know where it's stored, but your best bet would be to restore to a backup.

    Try this
    >su zimbra
    >zmprov
    zmprov> gaa

    What pops up? I assume that nothing will appear, but it couldn't hurt. Also, so a search for LDAP Browser, and browse through your LDAP.

    I just searched bugzilla, but nothing appeared. We had a known issue a while ago, where if you ran the upgrade script more than twice, it would dump your LDAP. Did you run the upgrade script more than twice?

    What OS are you using? Also, it would be a good idea to post your install.log stored in /tmp/install.log.xxxx

    Thanks and good luck (DON'T FORGET TO MAKE THAT BACKUP)

    john

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •