Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: [SOLVED] Social Zimlet Zimbra 6.0.2. NE Twitter Issue

  1. #1
    Join Date
    Aug 2007
    Posts
    16
    Rep Power
    8

    Default [SOLVED] Social Zimlet Zimbra 6.0.2. NE Twitter Issue

    I just installed the Social Zimlet into 6.0.2NE. I got facebook working fine but when I click the "go to Twitter" button on the Twitter authentication dialog it opens up a popup with the following link:

    Code:
    https://twitter.com/oauth/authorize?oauth_token=
    Twitter responds with a token already used error. I assume that it is because the oauth variable is empty. Any suggestions as to where to look to try to fix this? Is anyone else seeing this with ZCS 6.0.2?
    Victor J Matherly
    Wave Communications, Inc
    http://www.wave-communications.com

  2. #2
    Join Date
    Sep 2005
    Posts
    187
    Rep Power
    10

    Default

    Quote Originally Posted by VJM View Post
    I just installed the Social Zimlet into 6.0.2NE. I got facebook working fine but when I click the "go to Twitter" button on the Twitter authentication dialog it opens up a popup with the following link:

    Code:
    https://twitter.com/oauth/authorize?oauth_token=
    Twitter responds with a token already used error. I assume that it is because the oauth variable is empty. Any suggestions as to where to look to try to fix this? Is anyone else seeing this with ZCS 6.0.2?
    If you have installed the one that came with 6.0.0 or 6.0.1, please uninstall it(as they had bugs) and install the one from Gallery.
    Code:
    http://gallery.zimbra.com/gallery.php?act=viewProd&productId=134
    Bugzilla - Wiki - Downloads - Before posting... Search!

  3. #3
    Join Date
    Aug 2007
    Posts
    16
    Rep Power
    8

    Default

    Quote Originally Posted by rrao View Post
    If you have installed the one that came with 6.0.0 or 6.0.1, please uninstall it(as they had bugs) and install the one from Gallery.
    Code:
    http://gallery.zimbra.com/gallery.php?act=viewProd&productId=134
    I uninstalled and reinstalled from the gallery but it still lacks a token when I get the twitter popup.
    Victor J Matherly
    Wave Communications, Inc
    http://www.wave-communications.com

  4. #4
    Join Date
    Aug 2007
    Posts
    16
    Rep Power
    8

    Default

    Does this Zimlet create a log file somewere that may give my some indication as to what is wrong?
    Victor J Matherly
    Wave Communications, Inc
    http://www.wave-communications.com

  5. #5
    Join Date
    Sep 2005
    Posts
    187
    Rep Power
    10

    Default

    Quote Originally Posted by VJM View Post
    Does this Zimlet create a log file somewere that may give my some indication as to what is wrong?
    What locale/language are you using? and what browser is it?
    Bugzilla - Wiki - Downloads - Before posting... Search!

  6. #6
    Join Date
    Aug 2007
    Posts
    16
    Rep Power
    8

    Default

    I am using US English. I have tested it with the following browsers:

    Firefox 3.5 64Bit & 32Bit (Ubuntu Linux)
    Google Chrome 64Bit and 32 Bit (Ubuntu Linux)
    Firefox 3 (WinXP)

    Its also worth noting that I get a token and can set up twiter on a friend of mines server running 6.0.1NE. I tested it with Firefox 3.5 64Bit (Ubuntu Linux). He is also using US English.

    I also didn't install the zimlet until after I installed 6.0.2 so I don't know if it worked prior to the update.
    Victor J Matherly
    Wave Communications, Inc
    http://www.wave-communications.com

  7. #7
    Join Date
    Sep 2005
    Posts
    187
    Rep Power
    10

    Default

    Lots of people are using Social zimlet without any issues. I think the version that was from 6.0.1 that you installed earlier might still be causing some issue.

    Please do a complete uninstall of the Zimlet (one more time), run the following flush-cache command and reinstall the one from Gallery..
    Code:
    zmprov fc zimlet
    Bugzilla - Wiki - Downloads - Before posting... Search!

  8. #8
    Join Date
    Aug 2007
    Posts
    16
    Rep Power
    8

    Default

    I have flushed the Cache and reinstalled a fresh copy from the gallery but it is still not giving me a token.

    twitter.jpg
    Victor J Matherly
    Wave Communications, Inc
    http://www.wave-communications.com

  9. #9
    Join Date
    Sep 2005
    Posts
    187
    Rep Power
    10

    Default

    I am attaching a slightly newer version of the Zimlet(that comes with 6.0.2), try that out and see if it solves the issue.
    Also, try creating a different account and see if you can add twitter to that account on your server
    Attached Files Attached Files
    Bugzilla - Wiki - Downloads - Before posting... Search!

  10. #10
    Join Date
    Aug 2007
    Posts
    16
    Rep Power
    8

    Default

    Still no difference. So we both are on the same page here is exactly what i did this time around:

    Undeployed Zimbra social
    Flushed the Cache via the command line
    Installed the new version you attached (when I restarted my browser I noted a different icon on the social tab so the new version must have been deployed properly)
    Tried and failed to add my twitter account under my main zimbra login
    created a new account
    Tried and failed to add my twitter account under that account
    Victor J Matherly
    Wave Communications, Inc
    http://www.wave-communications.com

Similar Threads

  1. [SOLVED] Important Mta Issue!!!!!!!!
    By borngunners in forum Migration
    Replies: 2
    Last Post: 01-05-2010, 05:44 AM
  2. [SOLVED] Install Problem in Ubuntu 6.06 Server
    By xtimox in forum Installation
    Replies: 16
    Last Post: 03-27-2008, 09:36 AM
  3. /tmp filling
    By Nutz in forum Administrators
    Replies: 8
    Last Post: 02-22-2008, 01:00 AM
  4. Replies: 8
    Last Post: 02-27-2007, 03:10 AM
  5. dspam logrotate errors
    By michaeln in forum Users
    Replies: 7
    Last Post: 02-19-2007, 11:45 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •