I have been trying to upgrade to 6.0.2 but every time it fails with the following:

Code:
Upgrading from 6.0.1_GA_1816 to 6.0.2_GA_1912
Stopping zimbra services...done.
Verifying /opt/zimbra/conf/my.cnf
Starting mysql...done.
ERROR 1033 (HY000) at line 1: Incorrect information in file: './zimbra/config.frm'
Sat Oct 24 17:46:53 2009: Error while running '/opt/zimbra/bin/mysql --user=zimbra --password=mypassword --database=zimbra --batch --skip-column-names'.
I have tried this many times, and each and every time it is the same. I have reverted back to 6.0.1 because I made a tar backup of the full /opt/zimbra directory, but I'd prefer to upgrade because of the minor problems that were present in 6.0.1.

What can I do to upgrade successfully?