Results 1 to 8 of 8

Thread: problems with receiving mail to name@sub.domain.com

  1. #1
    Join Date
    Jan 2009
    Posts
    5
    Rep Power
    6

    Default problems with receiving mail to name@sub.domain.com

    Hi - At work we migrated to and have been using Zimbra for about a year, we're very happy.

    To try out ZCS6 before planning my real-job upgrade, as well as considering it for a replacement to my old-school sendmail/IMAP server my personal domain runs on, I've installed a new instance of Zimbra.

    It is happy to receive messages sent to myname@mydomain.com (which is how I configured it on install) but I need to test a bunch of things before moving my few users and repointing my MX records - so I'm trying to get to to accept mail for myname@sub.mydomain.com.

    I've got the DNS for that subdomain set up properly and the MX host is my ZCS instance. Mail is directed there as it should be.

    Before making any changes to the Zimbra config, mail to a subdomain failed with the following error in /var/log/maillog:

    Nov 5 17:24:50 xxxxxx postfix/smtpd[1932]: NOQUEUE: reject: RCPT from xxxxxx.fios.verizon.net[my.home.ip.address]: 554 5.7.1 : Relay access denied; from= to= proto=ESMTP helo=


    Then I added the subdomain in the ZCS admin GUI, and added alias to my myname@mydomain.com account: myname@sub.mydomain.com, and expected that to do the trick. However, now sending the same message results in:

    Nov 6 09:38:31 xxxxxxxx postfix/smtpd[13308]: NOQUEUE: reject: RCPT from xxxxxxx.fios.verizon.net[my.home.ip.address]: 550 5.1.1 : Recipient address rejected: my.zcs.hostname; from= to= proto=ESMTP helo=


    What am I missing?


    thanks

    Kevin

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Did you add this as a new domain in the Admin UI? Can you actually login with the credentials myname@sub.mydomain.com and the password? The error message implies that the user isn't known. What does the following show (when run on your Zimbra server):

    Code:
    cat /etc/hosts
    cat /etc/resolv.conf
    dig sub.domain.com mx
    dig sub.somain.com any
    host `hostname` <-- use that exact command with bactticks not single quotes
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Jan 2009
    Posts
    5
    Rep Power
    6

    Default

    Quote Originally Posted by phoenix View Post
    Did you add this as a new domain in the Admin UI? Can you actually login with the credentials myname@sub.mydomain.com and the password?

    The error message implies that the user isn't known. What does the following show (when run on your Zimbra server):

    Code:
    cat /etc/hosts
    cat /etc/resolv.conf
    dig sub.domain.com mx
    dig sub.somain.com any
    host `hostname` <-- use that exact command with bactticks not single quotes
    Thanks for the reply!

    I did add it as a new domain in the Admin UI, and I added the alias (with the subdomain) in my user account.

    /etc/hosts

    127.0.0.1 localhost.localdomain localhost
    w.x.y.z host.mydomain.com host


    /etc/resolv.conf

    search mydomain.com
    server 127.0.0.1

    dig sub.domain.com mx

    returns an MX with the ZCS host's IP. (Returns the same on local and outside DNS)

    dig sub.domain.com any

    returns the good MX, and the NS and the A record for the host of the same name.

    [root@hostname pz]# host `hostname`
    host.mydomain.com has address (same IP as returned from DNS)
    sub.mydomain.com mail is handled by 10 host.mydomain.com.



    (just to confuse things, the hostname of the ZCS server is also the name of the subdomain - so host.mydomain.com is the same string as sub.mydomain.com)

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Can you actually post the output form those commands for verification.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    Join Date
    Jan 2009
    Posts
    5
    Rep Power
    6

    Default

    Quote Originally Posted by phoenix View Post
    Can you actually post the output form those commands for verification.
    [root@cloud1 pz]# dig cloud1.kretz.net mx

    ; <<>> DiG 9.5.0b1 <<>> cloud1.kretz.net mx
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 7600
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 1

    ;; QUESTION SECTION:
    ;cloud1.kretz.net. IN MX

    ;; ANSWER SECTION:
    cloud1.kretz.net. 86400 IN MX 10 cloud1.kretz.net.

    ;; AUTHORITY SECTION:
    cloud1.kretz.net. 86400 IN NS cloud1.kretz.net.

    ;; ADDITIONAL SECTION:
    cloud1.kretz.net. 86400 IN A 174.129.42.27

    ;; Query time: 0 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Fri Nov 6 11:04:21 2009
    ;; MSG SIZE rcvd: 80


    [root@cloud1 pz]# dig cloud1.kretz.net any

    ; <<>> DiG 9.5.0b1 <<>> cloud1.kretz.net any
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 59260
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 4, AUTHORITY: 0, ADDITIONAL: 1

    ;; QUESTION SECTION:
    ;cloud1.kretz.net. IN ANY

    ;; ANSWER SECTION:
    cloud1.kretz.net. 86400 IN SOA cloud1.kretz.net. dns-admin.kretz.net. 2009110506 3600 900 1209600 900
    cloud1.kretz.net. 86400 IN NS cloud1.kretz.net.
    cloud1.kretz.net. 86400 IN MX 10 cloud1.kretz.net.
    cloud1.kretz.net. 86400 IN A 174.129.42.27

    ;; ADDITIONAL SECTION:
    cloud1.kretz.net. 86400 IN A 174.129.42.27

    ;; Query time: 0 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Fri Nov 6 11:04:41 2009
    ;; MSG SIZE rcvd: 142


    [root@cloud1 pz]# host `hostname`
    cloud1.kretz.net has address 174.129.42.27
    cloud1.kretz.net mail is handled by 10 cloud1.kretz.net.

  6. #6
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    This server is on a public IP? Does it have a firewall on the server? Which operating system is on the server?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #7
    Join Date
    Jan 2009
    Posts
    5
    Rep Power
    6

    Default

    Quote Originally Posted by phoenix View Post
    This server is on a public IP? Does it have a firewall on the server? Which operating system is on the server?
    It's on a private IP behind a firewall (not a fw on the server). It's running Fedora Core 7.

  8. #8
    Join Date
    Jan 2009
    Posts
    5
    Rep Power
    6

    Default

    I deleted the account alias and domain entry, and re-created them, and it started working. Maybe there was a typo somewhere I didn't notice.


    Thanks for the assistance anyway - I'm as impressed with the free/community support as I am with the official commercial support I get at work.

Similar Threads

  1. Problems with port 25
    By yogiman in forum Installation
    Replies: 57
    Last Post: 06-13-2011, 02:55 PM
  2. Migration Assistance
    By dwill in forum Administrators
    Replies: 10
    Last Post: 12-02-2008, 08:20 AM
  3. [SOLVED] Zimbra don't work - zmmailboxd
    By dmalherbe in forum Administrators
    Replies: 10
    Last Post: 11-20-2008, 10:05 AM
  4. zmamavisdctl stopped and won't restart
    By alto in forum Installation
    Replies: 2
    Last Post: 04-18-2008, 01:41 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •