Results 1 to 2 of 2

Thread: [SOLVED] Bungled upgrade

  1. #1
    Join Date
    Nov 2009
    Rep Power

    Default [SOLVED] Bungled upgrade

    Hello all,

    A colleague of mine was tasked with performing an Zimbra upgrade for a client but didn't quite understand the upgrade process. The upgrade was supposed to be from zcs-5.0.2_GA_1975.RHEL5_64.20080130223104 to zcs-5.0.20_GA_3127.RHEL5_64.20091102122116

    It looks like he downloaded the tar.gz file, unpacked it, cd into the packages directory and went rpm -Uvh *.rpm.

    Now the server won't start, zmcontrol start reults in:
    Enabled services read from cache. Service list may be inaccurate.
    Starting ldap...Done.
    ldap_url and ldap_master_url cannot be the same on an ldap replica

    Running results in:

    "/opt/zimbra/mysql/bin/mysqlcheck: Got error: 1045: Access denied for user 'root'@'localhost' (using password: YES) when trying to connect"

    zmcontrol -v show:
    Release 5.0.20_GA_3127.RHEL5_64_20091102122116 RHEL5_64

    Is there an easy way to recover from this sore of issue?
    Any help would really be appreciated.

  2. #2
    Join Date
    Nov 2009
    Rep Power

    Default Resolved

    In case it helps others.

    We resolved this issue using the following procedure:
    Recovering from wrong platform upgrade - Zimbra :: Wiki

    As the rpm upgrade wrote over the localconfig.xml we had to recover this file from tape.

    Once this was done we were able to start the old version of Zimbra. We could then run and upgrade to the latest version.

Similar Threads

  1. Upgrade instructions in 5.0.10 too muddy to understand
    By johnshen in forum Installation
    Replies: 4
    Last Post: 12-06-2008, 05:19 AM
  2. Replies: 2
    Last Post: 10-04-2007, 03:20 PM
  3. M1 -> M2 Upgrade Scripts
    By KevinH in forum Announcements
    Replies: 57
    Last Post: 12-15-2005, 09:10 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts