Results 1 to 2 of 2

Thread: Install fails: IO::Socket::INET: connect: Connection refused at /opt/zimbra/libexec/z

  1. #1
    Join Date
    Nov 2009
    Posts
    5
    Rep Power
    5

    Default Install fails: IO::Socket::INET: connect: Connection refused at /opt/zimbra/libexec/z

    I have searched the forum / google looking for a possible solution to my issue. I have seen many people with the similar issue, but none seemed to have fixed this issue. I am running CentOS 5.4 and receive the following error during the install and by running /opt/zimbra/libexec/zmsetup.pl


    Note

    Fri Nov 6 13:00:13 2009 The previous configuration appears to have failed to complete

    Fri Nov 6 13:00:16 2009 Saving config in /opt/zimbra/config.16577...
    Fri Nov 6 13:00:16 2009 done.
    Fri Nov 6 13:00:18 2009 Operations logged to /tmp/zmsetup.11062009-125930.log
    Fri Nov 6 13:00:18 2009 checking isEnabled zimbra-ldap
    Fri Nov 6 13:00:18 2009 zimbra-ldap is enabled
    Fri Nov 6 13:00:18 2009 Initializing ldap...
    Fri Nov 6 13:00:18 2009 *** Running as zimbra user: /opt/zimbra/libexec/zmldapinit
    IO::Socket::INET: connect: Connection refused at /opt/zimbra/libexec/zmldapinit line 136.
    Fri Nov 6 13:00:25 2009 failed. (28416)
    Fri Nov 6 13:00:25 2009

    ERROR

    Fri Nov 6 13:00:25 2009

    Configuration failed

    Fri Nov 6 13:00:25 2009 Please address the error and re-run /opt/zimbra/libexec/zmsetup.pl to
    Fri Nov 6 13:00:25 2009 complete the configuration.
    Fri Nov 6 13:00:25 2009
    Errors have been logged to /tmp/zmsetup.11062009-125930.log


    here is the output for the following info:

    ############ cat /etc/hosts ############
    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    127.0.0.1 localhost.localdomain localhost
    ::1 localhost6.localdomain6 localhost6

    172.16.66.123 ghostrider.example.com ghostrider

    ############ cat /etc/resolv.conf ############
    search example.com
    nameserver 10.71.177.149

    ############ dig example.com any ############

    ; <<>> DiG 9.3.6-P1-RedHat-9.3.6-4.P1.el5 <<>> example.com any
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 38329
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 4, AUTHORITY: 0, ADDITIONAL: 4

    ;; QUESTION SECTION:
    ;example.com. IN ANY

    ;; ANSWER SECTION:
    example.com. 86400 IN SOA flash.example.com. admin.example.com. 2009110604 28800 7200 864000 86400
    example.com. 86400 IN NS superman.example.com.
    example.com. 86400 IN NS flash.example.com.
    example.com. 86400 IN MX 20 ghostrider.example.com.

    ;; ADDITIONAL SECTION:
    flash.example.com. 86400 IN A 10.71.177.149
    superman.example.com. 86400 IN A 10.71.177.146
    superman.example.com. 86400 IN A 172.16.66.115
    ghostrider.example.com. 86400 IN A 172.16.66.123

    ;; Query time: 1 msec
    ;; SERVER: 10.71.177.149#53(10.71.177.149)
    ;; WHEN: Mon Nov 9 10:25:45 2009
    ;; MSG SIZE rcvd: 215

    ############ dig example.com mx ############

    ; <<>> DiG 9.3.6-P1-RedHat-9.3.6-4.P1.el5 <<>> example.com mx
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 26389
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 4

    ;; QUESTION SECTION:
    ;example.com. IN MX

    ;; ANSWER SECTION:
    example.com. 86400 IN MX 20 ghostrider.example.com.

    ;; AUTHORITY SECTION:
    example.com. 86400 IN NS flash.example.com.
    example.com. 86400 IN NS superman.example.com.

    ;; ADDITIONAL SECTION:
    ghostrider.example.com. 86400 IN A 172.16.66.123
    flash.example.com. 86400 IN A 10.71.177.149
    superman.example.com. 86400 IN A 172.16.66.115
    superman.example.com. 86400 IN A 10.71.177.146

    ;; Query time: 1 msec
    ;; SERVER: 10.71.177.149#53(10.71.177.149)
    ;; WHEN: Mon Nov 9 10:25:45 2009
    ;; MSG SIZE rcvd: 173

    ############ host ghostrider ############
    ghostrider.example.com has address 172.16.66.123

    Any help would be much appreciated. I cant seem to find what is causing the issue.

    Thanks,

    Jeff

  2. #2
    Join Date
    Feb 2007
    Location
    Portland, OR
    Posts
    1,147
    Rep Power
    10

    Default

    Do you have SELinux enabled? What further information (if any) is available in the setup log?

Similar Threads

  1. Replies: 7
    Last Post: 02-03-2011, 06:01 AM
  2. fresh install (both OS and Zimbra) but zimbra-spell fails
    By xtremetoonz in forum Installation
    Replies: 14
    Last Post: 09-09-2007, 12:34 AM
  3. Replies: 26
    Last Post: 02-12-2007, 06:23 PM
  4. Cannot send mail - connection refused
    By ojkeyboard in forum Installation
    Replies: 14
    Last Post: 10-30-2006, 01:11 AM
  5. Is it started or not
    By kwelipatton in forum Installation
    Replies: 10
    Last Post: 03-28-2006, 10:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •