Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 26

Thread: Server Statistics not working on 6.0.2

  1. #11
    Join Date
    Jun 2007
    Posts
    68
    Rep Power
    8

    Default

    here is what you asked me, the olcAccess lines from the file you mentioned :

    Code:
    olcAccess: {0}to attrs=userPassword  by anonymous auth  by dn.children="cn=adm
     ins,cn=zimbra" write
    olcAccess: {1}to dn.subtree="cn=zimbra"  by dn.children="cn=admins,cn=zimbra"
     write
    olcAccess: {2}to attrs=zimbraZimletUserProperties,zimbraGalLdapBindPassword,zi
     mbraGalLdapBindDn,zimbraAuthTokenKey,zimbraPreAuthKey,zimbraPasswordHistory,z
     imbraIsAdminAccount,zimbraAuthLdapSearchBindPassword  by dn.children="cn=admi
     ns,cn=zimbra" write  by * none
    olcAccess: {3}to attrs=objectclass  by dn.children="cn=admins,cn=zimbra" write
       by dn.base="uid=zmpostfix,cn=appaccts,cn=zimbra" read  by dn.base="uid=zmam
     avis,cn=appaccts,cn=zimbra" read  by * read
    olcAccess: {4}to attrs=@amavisAccount  by dn.children="cn=admins,cn=zimbra" wr
     ite  by dn.base="uid=zmamavis,cn=appaccts,cn=zimbra" read  by * +0 break
    olcAccess: {5}to attrs=mail  by dn.children="cn=admins,cn=zimbra" write  by dn
     .base="uid=zmamavis,cn=appaccts,cn=zimbra" read  by * +0 break
    olcAccess: {6}to attrs=zimbraAllowFromAddress  by dn.children="cn=admins,cn=zi
     mbra" write  by dn.base="uid=zmpostfix,cn=appaccts,cn=zimbra" read  by * none
    olcAccess: {7}to filter="(!(zimbraHideInGal=TRUE))"  attrs=cn,co,company,dc,di
     splayName,givenName,gn,initials,l,mail,o,ou,physicalDeliveryOfficeName,postal
     Code,sn,st,street,streetAddress,telephoneNumber,title,uid  by dn.children="cn
     =admins,cn=zimbra" write  by dn.base="uid=zmpostfix,cn=appaccts,cn=zimbra" re
     ad  by * read
    olcAccess: {8}to attrs=zimbraId,zimbraMailAddress,zimbraMailAlias,zimbraMailCa
     nonicalAddress,zimbraMailCatchAllAddress,zimbraMailCatchAllCanonicalAddress,z
     imbraMailCatchAllForwardingAddress,zimbraMailDeliveryAddress,zimbraMailForwar
     dingAddress,zimbraPrefMailForwardingAddress,zimbraMailHost,zimbraMailStatus,z
     imbraMailTransport,zimbraDomainName,zimbraDomainType,zimbraPrefMailLocalDeliv
     eryDisabled  by dn.children="cn=admins,cn=zimbra" write  by dn.base="uid=zmpo
     stfix,cn=appaccts,cn=zimbra" read  by * read
    olcAccess: {9}to attrs=entry  by dn.children="cn=admins,cn=zimbra" write  by *
      read
    hope this helps ..
    Last edited by ArcaneMagus; 11-16-2009 at 12:44 AM. Reason: Changed to a [code] block

  2. #12
    Join Date
    Jun 2007
    Posts
    68
    Rep Power
    8

    Default

    ArcaneMagus,
    Sorry for the "code" typo thing..I was in a big hurry..
    is this information of any help for you? any suggestions for further actions on our side?
    is there any ETA for the 6.3 release..maybe an upgrade will fix our/this issue too..

  3. #13
    Join Date
    Feb 2007
    Location
    Portland, OR
    Posts
    1,147
    Rep Power
    10

    Default

    Unfortunately it's the exact same as my system, I was thinking maybe it had something to do with the LDAP access rights from the error you posted earlier.

    As for a 6.0.3 release Zimbra is currently waiting on a third party to release a fix. This release will mainly be a security release though. Most fixes were pushed back to 6.0.4. You can see what will be in 6.0.3 here: Zimbra Product Portal.

  4. #14
    Join Date
    Jan 2009
    Location
    Arad, Romania
    Posts
    26
    Rep Power
    6

    Default

    Yes, that is the strange part. Like I said we have several servers running zimbra here and I compared the settings between them and they are all the same on every server, the only difference is that this server statistics does not want to work.

    We also did a migration like this from openSUSE 9.1 to CentOS 5.2 one year ago, we did all the steps exactly as we did now on this migration (openSUSE 10.2 to CentOS 5.4) and on that server everything is working great.

    I will compare these 2 servers again tomorrow just to make sure they are 100% the same.

    Thanks again ArcaneMagus for trying to help.

  5. #15
    Join Date
    Jan 2009
    Location
    Arad, Romania
    Posts
    26
    Rep Power
    6

    Default

    Here is what I've noticed today. Maybe this would help solve our problem.

    [zimbra@server03 root]$ zmsoap -z GetLoggerStatsRequest stats/@name=zmmtastats | head -20
    ERROR: service.FAILURE (system failure: unable to get globalgrant)

    Anyone has any ideas about this error ?

    Thanks for all the answers
    Last edited by bsarandan; 11-18-2009 at 09:30 AM.

  6. #16
    Join Date
    Jan 2009
    Location
    Arad, Romania
    Posts
    26
    Rep Power
    6

    Default

    anybody can help us with that error ?

    thanks

  7. #17
    Join Date
    Nov 2009
    Posts
    2
    Rep Power
    5

    Default same problem

    I wish I could offer a fix - all I can offer is that we are having the same problem after upgrading from zimbra 5.0.20 to 6.0.2 on Debian 4.

  8. #18
    Join Date
    Jan 2009
    Location
    Arad, Romania
    Posts
    26
    Rep Power
    6

    Thumbs down

    Unfortunately, nobody wants to help us solving this problem.

  9. #19
    Join Date
    Jun 2007
    Posts
    68
    Rep Power
    8

    Default

    Quote Originally Posted by sergiumartin :
    hmm..this is probably related to our problem: i also noticed that since we upgraded (about a week ago) we have in mailbox.log files, lots of exceptions like this :

    2009-11-06 00:00:20,996 WARN [LmtpServer-7360
    [name=ipomian@myserver.com;mid=25;ip=192.168.29.8;] ParsedMessage - exception while analyzing message; message will be partially indexed
    java.lang.NullPointerException
    at com.zimbra.cs.mime.MimeHandlerManager.lookUpMimeTy peInfo(MimeHandlerManager.java:196)
    at com.zimbra.cs.mime.MimeHandlerManager.loadHandler( MimeHandlerManager.java:119)
    at com.zimbra.cs.mime.MimeHandlerManager.getMimeHandl er(MimeHandlerManager.java:82)
    at com.zimbra.cs.mime.ParsedMessage.analyzePart(Parse dMessage.java:1049)
    at com.zimbra.cs.mime.ParsedMessage.analyzeBodyParts( ParsedMessage.java:385)
    at com.zimbra.cs.mime.ParsedMessage.getFragment(Parse dMessage.java:635)
    at com.zimbra.cs.mailbox.Message.encodeMetadata(Messa ge.java:1008)
    at com.zimbra.cs.mailbox.Message.createInternal(Messa ge.java:426)
    at com.zimbra.cs.mailbox.Message.create(Message.java: 360)
    at com.zimbra.cs.mailbox.Mailbox.addMessageInternal(M ailbox.java:4446)
    at com.zimbra.cs.mailbox.Mailbox.addMessage(Mailbox.j ava:4293)
    at com.zimbra.cs.mailbox.Mailbox.addMessage(Mailbox.j ava:4226)
    at com.zimbra.cs.mailbox.Mailbox.addMessage(Mailbox.j ava:4186)
    at com.zimbra.cs.filter.FilterUtil.addMessage(FilterU til.java:280)
    at com.zimbra.cs.filter.IncomingMessageHandler.fileIn to(IncomingMessageHandler.java:86)
    at com.zimbra.cs.filter.ZimbraMailAdapter.fileInto(Zi mbraMailAdapter.java:324)
    at com.zimbra.cs.filter.ZimbraMailAdapter.executeActi ons(ZimbraMailAdapter.java:201)
    at org.apache.jsieve.SieveFactory.evaluate(SieveFacto ry.java:164)
    at com.zimbra.cs.filter.RuleManager.applyRulesToIncom ingMessage(RuleManager.java:348)
    at com.zimbra.cs.filter.RuleManager.applyRulesToIncom ingMessage(RuleManager.java:311)


    ArcaneMagus;161145]Actually serguimartin that index error is: Bug 42599 – Message causes NPE on ReIndex - indexing blocked
    You can see some more discussion on that in this thread: http://www.zimbra.com/forums/adminis...e-6-0-1-a.html
    ...
    I'm returning to this issue (a little off topic probably) because we also have users reporting searching problems (to be more specific, since the upgrade the latest emails are not included in the search results) ..

    ArcaneMagnus, you mentioned is related to bug 42599 but as you can see our error is different from the one stated in that bugzilla :
    indexadd - Caught exception while
    indexing message id 17813 - indexing blocked. Possibly corrupt index?
    java.lang.NullPointerException: value cannot be null
    ...

    You can see that the exception is different..the exceptions are probably related (?), but i wanted to point this out so Zimbra would also take this into consideration when fixing bug 42599..
    Any workarounds for this issue? Our boss and also other people from the company are having really lots of emails so the searching function not working properly is a big minus for us at this moment..
    Last edited by sergiumartin; 12-06-2009 at 02:26 AM.

  10. #20
    Join Date
    Jun 2007
    Posts
    68
    Rep Power
    8

    Default

    related to our statistics issue.. here is a thing i noticed when i run this on our server:

    Code:
     zmsoap -z GetLoggerStatsRequest stats/@name=zmmtastats | head -20
    ERROR: service.FAILURE (system failure: unable to get globalgrant)
    maybe this is helpful ?

Similar Threads

  1. Server Statistics longer than 365 days?
    By frankman in forum Administrators
    Replies: 0
    Last Post: 07-08-2009, 09:20 AM
  2. Change hostname and server statistics stopped
    By rajeshkodali in forum Administrators
    Replies: 10
    Last Post: 12-11-2008, 06:47 AM
  3. failed to install zimbra cos of zmmailboxd
    By aljoshab in forum Installation
    Replies: 4
    Last Post: 12-09-2008, 01:33 AM
  4. [SOLVED] Server statistics does not working
    By boblin in forum Administrators
    Replies: 46
    Last Post: 11-20-2008, 04:15 AM
  5. Server Statistics dont work after changing hostname
    By rnuno in forum Administrators
    Replies: 1
    Last Post: 06-08-2007, 07:54 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •