Page 1 of 3 123 LastLast
Results 1 to 10 of 26

Thread: Server Statistics not working on 6.0.2

Hybrid View

  1. #1
    Join Date
    Jan 2009
    Location
    Arad, Romania
    Posts
    26
    Rep Power
    6

    Default Server Statistics not working on 6.0.2

    Hi,

    We have recently made a migration process from openSUSE 10.3 with zcs 4.5.9 to CentOS 5.4 with zcs 6.0.2. The migration process went well, with small errors but they were fixed at the moment. We made a backup on the old server, copied it to the new one, fixed the permissions, installed the same version, after everything worked we then upgraded to 4.5.11 -> 5.0.2 -> 5.0.18 -> 6.0.2. Everything works on 6.0.2 but the Server Statistics doesn't.

    When I go to Admin Console -> Server Statistics -> Mailbox Quota I get the following exception.

    User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.0; WOW64; Trident/4.0; SLCC1; .NET CLR 2.0.50727; InfoPath.2; .NET CLR 3.5.30729; .NET CLR 3.0.30729; OfficeLiveConnector.1.4; OfficeLivePatch.1.3)
    Timestamp: Tue, 10 Nov 2009 16:21:14 UTC


    Message: Exception thrown and not caught
    Line: 4906
    Char: 2
    Code: 0
    URI: https://mail.myserver.com:7071/zimbr...v=091020192731


    Message: Exception thrown and not caught
    Line: 4906
    Char: 2
    Code: 0
    URI: https://mail.myserver.com:7071/zimbr...v=091020192731


    Message: Exception thrown and not caught
    Line: 4906
    Char: 2
    Code: 0
    URI: https://mail.myserver.com:7071/zimbr...v=091020192731


    Message: Exception thrown and not caught
    Line: 4906
    Char: 2
    Code: 0
    URI: https://mail.myserver.com:7071/zimbr...v=091020192731


    Server Statistics -> Anti-Spam/Anti-Virus Activity or Message Volume or Message Count. I get the following error:

    Message: system failure: unable to get globalgrant Error code:
    service:FAILURE Method: GetLoggerStatsRequested Details:soap:Receiver

    When I go to certificates and click on the certificate that is there, I get:
    Message: system failure: unable to get globalgrant Error code: service.FAILURE Method: GetCertRequest Details:soap:Receiver


    I have tried everything I could get. I followed the steps from over here:
    http://www.zimbra.com/forums/install...-problems.html and here Mail Queue Monitoring - Zimbra :: Wiki , even recreated all the certificates, and still nothing.

    It would be very appreciated if you could tell me what the problem is.

    Thanks in advanced.

  2. #2
    Join Date
    Jan 2009
    Location
    Arad, Romania
    Posts
    26
    Rep Power
    6

    Default

    any ideas ? I've tried everything and nothing seems to work...

    thanks

  3. #3
    Join Date
    Jun 2007
    Posts
    68
    Rep Power
    8

    Unhappy Anybody there?

    Guys,

    We switched from openSuse to CentOS, because you recommended it's the best way to go for the OS version.. also upgraded to the latest version because we considered it's safe, and now we have all these "bugs"?
    Beside bsarandan mentioned, we also had problems with the filters - see bug Bug 42149 – Mail filters with "does not" options are not saved correctly, which caused us some real pain here..
    I don't want to point fingers here, but won't these bugs supposed to be eliminated in the beta versions? Nevertheless, I'm also a software engineer (software developer) and I understand that this is not always possible, but the least I'd expect is to help us out in fixing/solving the situations bsarandan mentioned..this server is already in production so we're working on the clock here..
    any advice from you would be a step ahead at this point..
    Last edited by sergiumartin; 11-12-2009 at 09:07 AM.

  4. #4
    Join Date
    Jun 2007
    Posts
    68
    Rep Power
    8

    Thumbs down disappointed

    the least i expect seems to be a little to much here..i bet (in fact i know) that if this problem had occurred on the other mail server where we have the Network edition, things would have been different..but because zimbra version 6 seems to be "buggy" and no one here is willing to help..we will probably upgrade the NE only to version 5.0.18..

  5. #5
    Join Date
    Feb 2007
    Location
    Portland, OR
    Posts
    1,147
    Rep Power
    10

    Default

    Well the only other posts on the forum with a similar error is this thread http://www.zimbra.com/forums/migrati...platforms.html where the person had tried to skip a few steps in the upgrade process. They were also migrating from openSUSE to CentOS. The last thing they posted was saying they were going to try upgrading the openSUSE install to a current version and then moving the servers, so I can only assume that fixed their problem for them.

    Instead of migrating to CentOS and then upgrading, have you tried upgrading on openSUSE and then migrating? It shouldn't make any difference, but it's the only thing I can think of that might help.

    You might want to submit a bug on Bugzilla Main Page - Zimbra.

  6. #6
    Join Date
    Jan 2009
    Location
    Arad, Romania
    Posts
    26
    Rep Power
    6

    Unhappy

    Actually this is our second migration so we have followed every step in the process, we already migrate once from openSUSE to centOS and everything was ok.

    Yes, we have upgraded to the last version supported for openSUSE and that is 5.0.18 and after that we did the migration. Since this is a very important part in our company I`ve doubled checked everything on the old server to be sure that everything is working at 100%. After the migration I also checked everything to see if it's working on the new server and just after that I upgraded to the last version of zimbra. Everything is working well. Like I said, I`ve tried every instruction from every post I`ve read and nothing seems to work for us.

    Any help will be much appreciated.

  7. #7
    Join Date
    Feb 2007
    Location
    Portland, OR
    Posts
    1,147
    Rep Power
    10

    Default

    Could you try reproducing the error in firefox and in the error console clicking on the like to the source code? It should link you to the line in the source code.

    Does it look like this?
    Code:
    if(!resp && !this._currentRequest.cancelled) {
    That is line 4906 of the Admin_all.js script, the line right after that throws an excepting which might relate to the error you got of an exception being thrown but not caught.

    Also is there any further information in /var/log/zimbra.log or /opt/zimbra/log/mailbox.log?

  8. #8
    Join Date
    Jun 2007
    Posts
    68
    Rep Power
    8

    Default

    Quote Originally Posted by ArcaneMagus View Post
    Could you try reproducing the error in firefox and in the error console clicking on the like to the source code? It should link you to the line in the source code.

    Does it look like this?
    Code:
    if(!resp && !this._currentRequest.cancelled) {
    That is line 4906 of the Admin_all.js script, the line right after that throws an excepting which might relate to the error you got of an exception being thrown but not caught.

    Also is there any further information in /var/log/zimbra.log or /opt/zimbra/log/mailbox.log?
    First of all, thanks ArcaneMagus for trying to help us .

    If we try to reproduce it from Firefox we get a different message..see the attached image file.


    Here is what i found in mailbox.log, related to the above error :

    2009-11-14 08:22:39,775 INFO [btpool0-5://mail.myserver.com:7071/service/admin/soap/GetLoggerStatsRequest] [name=admin@myserver.com;mid=2;ip=82.77.36.19;ua=Zi mbraWebClient - FF3.0 (Win);] SoapEng\
    ine - handler exception
    com.zimbra.common.service.ServiceException: system failure: unable to get globalgrant
    ExceptionId:btpool0-5://mail.myserver.com:7071/service/admin/soap/GetLoggerStatsRequest:1258208559775:c118b7b7a6566d 9f
    Code:service.FAILURE
    at com.zimbra.common.service.ServiceException.FAILURE (ServiceException.java:247)
    at com.zimbra.cs.account.ldap.LdapProvisioning.getGlo balGrant(LdapProvisioning.java:451)
    at com.zimbra.cs.service.admin.AdminAccessControl$ACL AccessControl.checkRight(AdminAccessControl.java:5 34)
    at com.zimbra.cs.service.admin.AdminDocumentHandler.c heckRight(AdminDocumentHandler.java:373)
    at com.zimbra.cs.service.admin.AdminDocumentHandler.c heckRight(AdminDocumentHandler.java:342)
    at com.zimbra.cs.service.admin.GetLoggerStats.handle( GetLoggerStats.java:108)
    at com.zimbra.soap.SoapEngine.dispatchRequest(SoapEng ine.java:418)
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:272)
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:156)
    at com.zimbra.soap.SoapServlet.doWork(SoapServlet.jav a:291)
    at com.zimbra.soap.SoapServlet.doPost(SoapServlet.jav a:212)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:727)
    at com.zimbra.cs.servlet.ZimbraServlet.service(Zimbra Servlet.java:181)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:820)
    at org.mortbay.jetty.servlet.ServletHolder.handle(Ser vletHolder.java:502)
    at org.mortbay.jetty.servlet.ServletHandler$CachedCha in.doFilter(ServletHandler.java:1157)
    at org.mortbay.servlet.UserAgentFilter.doFilter(UserA gentFilter.java:81)
    at org.mortbay.servlet.GzipFilter.doFilter(GzipFilter .java:132)
    at org.mortbay.jetty.servlet.ServletHandler$CachedCha in.doFilter(ServletHandler.java:1148)
    at org.mortbay.jetty.servlet.ServletHandler.handle(Se rvletHandler.java:379)
    at org.mortbay.jetty.security.SecurityHandler.handle( SecurityHandler.java:216)
    at org.mortbay.jetty.servlet.SessionHandler.handle(Se ssionHandler.java:181)
    at org.mortbay.jetty.handler.ContextHandler.handle(Co ntextHandler.java:765)
    at org.mortbay.jetty.webapp.WebAppContext.handle(WebA ppContext.java:418)
    at org.mortbay.jetty.handler.ContextHandlerCollection .handle(ContextHandlerCollection.java:230)
    at org.mortbay.jetty.handler.HandlerCollection.handle (HandlerCollection.java:114)
    at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha ndlerWrapper.java:152)
    at org.mortbay.jetty.handler.rewrite.RewriteHandler.h andle(RewriteHandler.java:230)
    at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha ndlerWrapper.java:152)
    at org.mortbay.jetty.handler.DebugHandler.handle(Debu gHandler.java:77)
    at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha ndlerWrapper.java:152)
    at org.mortbay.jetty.Server.handle(Server.java:324)
    at org.mortbay.jetty.HttpConnection.handleRequest(Htt pConnection.java:525)
    at org.mortbay.jetty.HttpConnection$RequestHandler.co ntent(HttpConnection.java:882)
    at org.mortbay.jetty.HttpParser.parseNext(HttpParser. java:747)
    at org.mortbay.jetty.HttpParser.parseAvailable(HttpPa rser.java:218)
    at org.mortbay.jetty.HttpConnection.handle(HttpConnec tion.java:387)
    at org.mortbay.io.nio.SelectChannelEndPoint.run(Selec tChannelEndPoint.java:409)
    at org.mortbay.thread.BoundedThreadPool$PoolThread.ru n(BoundedThreadPool.java:451)
    Caused by: javax.naming.NameNotFoundException: [LDAP: error code 32 - No Such Object]; remaining name 'cn=globalgrant,cn=zimbra'
    at com.sun.jndi.ldap.LdapCtx.mapErrorCode(LdapCtx.jav a:3066)
    at com.sun.jndi.ldap.LdapCtx.processReturnCode(LdapCt x.java:2987)
    at com.sun.jndi.ldap.LdapCtx.processReturnCode(LdapCt x.java:2794)
    at com.sun.jndi.ldap.LdapCtx.c_getAttributes(LdapCtx. java:1309)
    at com.sun.jndi.toolkit.ctx.ComponentDirContext.p_get Attributes(ComponentDirContext.java:213)
    at com.sun.jndi.toolkit.ctx.PartialCompositeDirContex t.getAttributes(PartialCompositeDirContext.java:12 1)
    at javax.naming.directory.InitialDirContext.getAttrib utes(InitialDirContext.java:133)
    at javax.naming.directory.InitialDirContext.getAttrib utes(InitialDirContext.java:128)
    at com.zimbra.cs.account.ldap.ZimbraLdapContext.getAt tributes(ZimbraLdapContext.java:618)
    at com.zimbra.cs.account.ldap.LdapProvisioning.getGlo balGrant(LdapProvisioning.java:448)
    ... 37 more
    Attached Images Attached Images

  9. #9
    Join Date
    Jun 2007
    Posts
    68
    Rep Power
    8

    Default

    hmm..this is probably related to our problem: i also noticed that since we upgraded (about a week ago) we have in mailbox.log files, lots of exceptions like this :

    2009-11-06 00:00:20,996 WARN [LmtpServer-7360] [name=ipomian@myserver.com;mid=25;ip=192.168.29.8;] ParsedMessage - exception while analyzing message; message will be partially indexed
    java.lang.NullPointerException
    at com.zimbra.cs.mime.MimeHandlerManager.lookUpMimeTy peInfo(MimeHandlerManager.java:196)
    at com.zimbra.cs.mime.MimeHandlerManager.loadHandler( MimeHandlerManager.java:119)
    at com.zimbra.cs.mime.MimeHandlerManager.getMimeHandl er(MimeHandlerManager.java:82)
    at com.zimbra.cs.mime.ParsedMessage.analyzePart(Parse dMessage.java:1049)
    at com.zimbra.cs.mime.ParsedMessage.analyzeBodyParts( ParsedMessage.java:385)
    at com.zimbra.cs.mime.ParsedMessage.getFragment(Parse dMessage.java:635)
    at com.zimbra.cs.mailbox.Message.encodeMetadata(Messa ge.java:1008)
    at com.zimbra.cs.mailbox.Message.createInternal(Messa ge.java:426)
    at com.zimbra.cs.mailbox.Message.create(Message.java: 360)
    at com.zimbra.cs.mailbox.Mailbox.addMessageInternal(M ailbox.java:4446)
    at com.zimbra.cs.mailbox.Mailbox.addMessage(Mailbox.j ava:4293)
    at com.zimbra.cs.mailbox.Mailbox.addMessage(Mailbox.j ava:4226)
    at com.zimbra.cs.mailbox.Mailbox.addMessage(Mailbox.j ava:4186)
    at com.zimbra.cs.filter.FilterUtil.addMessage(FilterU til.java:280)
    at com.zimbra.cs.filter.IncomingMessageHandler.fileIn to(IncomingMessageHandler.java:86)
    at com.zimbra.cs.filter.ZimbraMailAdapter.fileInto(Zi mbraMailAdapter.java:324)
    at com.zimbra.cs.filter.ZimbraMailAdapter.executeActi ons(ZimbraMailAdapter.java:201)
    at org.apache.jsieve.SieveFactory.evaluate(SieveFacto ry.java:164)
    at com.zimbra.cs.filter.RuleManager.applyRulesToIncom ingMessage(RuleManager.java:348)
    at com.zimbra.cs.filter.RuleManager.applyRulesToIncom ingMessage(RuleManager.java:311)
    at com.zimbra.cs.lmtpserver.ZimbraLmtpBackend.deliver MessageToLocalMailboxes(ZimbraLmtpBackend.java:425 )
    at com.zimbra.cs.lmtpserver.ZimbraLmtpBackend.deliver MessageToLocalMailboxes(ZimbraLmtpBackend.java:257 )
    at com.zimbra.cs.lmtpserver.ZimbraLmtpBackend.deliver (ZimbraLmtpBackend.java:162)
    at com.zimbra.cs.lmtpserver.LmtpHandler.processMessag eData(LmtpHandler.java:365)
    at com.zimbra.cs.lmtpserver.TcpLmtpHandler.continueDA TA(TcpLmtpHandler.java:72)
    at com.zimbra.cs.lmtpserver.LmtpHandler.doDATA(LmtpHa ndler.java:350)
    at com.zimbra.cs.lmtpserver.LmtpHandler.processComman d(LmtpHandler.java:170)
    at com.zimbra.cs.lmtpserver.TcpLmtpHandler.processCom mand(TcpLmtpHandler.java:66)
    at com.zimbra.cs.tcpserver.ProtocolHandler.processCon nection(ProtocolHandler.java:175)
    at com.zimbra.cs.tcpserver.ProtocolHandler.run(Protoc olHandler.java:132)
    at EDU.oswego.cs.dl.util.concurrent.PooledExecutor$Wo rker.run(Unknown Source)
    at java.lang.Thread.run(Thread.java:619)

    maybe we should try to reindex users mailboxes..? we will search more related to these new exceptions i found and hope this will help us.
    Last edited by sergiumartin; 11-14-2009 at 07:53 AM.

  10. #10
    Join Date
    Feb 2007
    Location
    Portland, OR
    Posts
    1,147
    Rep Power
    10

    Default

    Actually serguimartin that index error is: Bug 42599 – Message causes NPE on ReIndex - indexing blocked
    You can see some more discussion on that in this thread: http://www.zimbra.com/forums/adminis...e-6-0-1-a.html

    As for the problem described in this thread... here is a wild guess but what do the olcAccess lines in
    Code:
    /opt/zimbra/data/ldap/config/cn\=config/olcDatabase\=\{2\}hdb.ldif
    look like?

Similar Threads

  1. Server Statistics longer than 365 days?
    By frankman in forum Administrators
    Replies: 0
    Last Post: 07-08-2009, 10:20 AM
  2. Change hostname and server statistics stopped
    By rajeshkodali in forum Administrators
    Replies: 10
    Last Post: 12-11-2008, 07:47 AM
  3. failed to install zimbra cos of zmmailboxd
    By aljoshab in forum Installation
    Replies: 4
    Last Post: 12-09-2008, 02:33 AM
  4. [SOLVED] Server statistics does not working
    By boblin in forum Administrators
    Replies: 46
    Last Post: 11-20-2008, 05:15 AM
  5. Server Statistics dont work after changing hostname
    By rnuno in forum Administrators
    Replies: 1
    Last Post: 06-08-2007, 08:54 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •