Results 1 to 4 of 4

Thread: [SOLVED] Move from FC7 to FC11 not supported ?

  1. #1
    Join Date
    Mar 2006
    Location
    Stockholm, Sweden
    Posts
    18
    Rep Power
    9

    Default [SOLVED] Move from FC7 to FC11 not supported ?

    Hi,

    I need to move a Zimbra OSS installation running on FC7 to another server. The new server must run a more recent OS level, so I was trying FC11 since Zimbra supports this.

    I have installed zcs-6.0.2_GA_1912.F11.20091020155433 on the new server and verified that everything works fine. I then removed the newly created /opt/zimbra directory, and replaced it with the old production /opt/zimbra from the FC7 box.
    I then ran ./install.sh and was hoping that it would upgrade Zimbra to FC11, but I constantly get the error below. I also tried to move to CentOS and different x64-variants, but always the same error. Does anyone recognize this error? Is the problem in the old FC7 environment? Zimbra has been upgraded on FC7 several times without any errors..!

    Thanks

    -------------------

    [root@mail1 zcs-6.0.2_GA_1912.F11.20091020155433]# ./install.sh

    Operations logged to /tmp/install.log.6649
    Checking for existing installation...
    zimbra-ldap...FOUND zimbra-ldap-6.0.2_GA_1912
    zimbra-logger...FOUND zimbra-logger-6.0.2_GA_1912
    zimbra-mta...FOUND zimbra-mta-6.0.2_GA_1912
    zimbra-snmp...FOUND zimbra-snmp-6.0.2_GA_1912
    zimbra-store...FOUND zimbra-store-6.0.2_GA_1912
    zimbra-apache...FOUND zimbra-apache-6.0.2_GA_1912
    zimbra-spell...FOUND zimbra-spell-6.0.2_GA_1912
    zimbra-convertd...NOT FOUND
    zimbra-memcached...NOT FOUND
    zimbra-proxy...NOT FOUND
    zimbra-archiving...NOT FOUND
    zimbra-cluster...NOT FOUND
    zimbra-core...FOUND zimbra-core-6.0.2_GA_1912
    ZCS upgrade from 6.0.2 to 6.0.2 will be performed.

    Saving existing configuration file to /opt/zimbra/.saveconfig


    PLEASE READ THIS AGREEMENT CAREFULLY BEFORE USING THE SOFTWARE.
    ZIMBRA, INC. ("ZIMBRA") WILL ONLY LICENSE THIS SOFTWARE TO YOU IF YOU
    FIRST ACCEPT THE TERMS OF THIS AGREEMENT. BY DOWNLOADING OR INSTALLING
    THE SOFTWARE, OR USING THE PRODUCT, YOU ARE CONSENTING TO BE BOUND BY
    THIS AGREEMENT. IF YOU DO NOT AGREE TO ALL OF THE TERMS OF THIS
    AGREEMENT, THEN DO NOT DOWNLOAD, INSTALL OR USE THE PRODUCT.

    License Terms for the Zimbra Collaboration Suite:
    Zimbra - Zimbra Public End-User License Agreement, Version 2.1


    Press Return to continue

    Checking for prerequisites...
    FOUND: NPTL
    FOUND: sudo-1.7.1-4
    FOUND: libidn-1.9-4
    FOUND: gmp-4.2.4-6
    FOUND: bind-libs-9.6.1-6
    FOUND: cronie-1.3-3
    FOUND: /usr/lib/libstdc++.so.6
    Checking for suggested prerequisites...
    Prerequisite check complete.
    Checking current number of databases...
    df: no file systems processed

    Do you want to verify message store database integrity? [Y]
    Verifying integrity of message store databases. This may take a while.
    Starting mysqld...done.
    mysqld is alive
    perl: symbol lookup error: /opt/zimbra/zimbramon/lib/i386-linux-thread-multi/auto/Data/UUID/UUID.so: undefined symbol: Perl_Tstack_sp_ptr
    mysqld is alive
    Stopping mysqld... done.
    [root@mail1 zcs-6.0.2_GA_1912.F11.20091020155433]#

    --------------------------------

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by rickard View Post
    Hi,

    I need to move a Zimbra OSS installation running on FC7 to another server. The new server must run a more recent OS level, so I was trying FC11 since Zimbra supports this.
    Are you actually running the same version of Zimbra on this server as you have on the new server? If not, then read this: Moving ZCS to New Server - Zimbra :: Wiki

    There are also a couple of threads in the forums with the error you posted, please search for this: Perl_Tstack_sp_ptr
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Mar 2006
    Location
    Stockholm, Sweden
    Posts
    18
    Rep Power
    9

    Default

    Yupp - It's the same i386 release;

    On the production box running FC7:
    $ zmcontrol -v
    Release 6.0.2_GA_1912.F7_20091020145320 F7 FOSS edition.

    $ perl -v
    This is perl, v5.8.8 built for i386-linux-thread-multi


    On the new FC11 box:

    Made a fresh installation using FC11 and zcs-6.0.2_GA_1912.F11.20091020155433
    Replaced /opt/zimbra with the one from the FC7 box above

    $ perl -v
    This is perl, v5.10.0 built for i386-linux-thread-multi

    $ zmcontrol -v
    /usr/bin/perl: symbol lookup error: /opt/zimbra/zimbramon/lib/i386-linux-thread-multi/auto/Data/UUID/UUID.so: undefined symbol: Perl_Tstack_sp_ptr

  4. #4
    Join Date
    Mar 2006
    Location
    Stockholm, Sweden
    Posts
    18
    Rep Power
    9

    Default

    OK, so it seems like the uuid shipped with Zimbra FC7 isn't compliant with the perl environment in other distributions. Since this is an upgrade, the install script tries to run zmcontrol in the old /opt/zimbra before starting the upgrade, and this will then obviously fail.
    The solution is to install the native uuid in FC11;
    yum install uuid-perl
    And then replace the FC7-version of this and other perl objects in /opt/zimbra with with the FC11 version;

    For 32-bit:
    rsync -av /usr/lib/perl5/vendor_perl/5.10.0/i386-linux-thread-multi /opt/zimbra/zimbramon/lib
    rsync -av /usr/lib/perl5/5.10.0/i386-linux-thread-multi /opt/zimbra/zimbramon/lib
    rm -rf /opt/zimbra/zimbramon/lib/perl5

    For 64-bit:
    rsync -av /usr/lib64/perl5/vendor_perl/5.10.0/x86_64-linux-thread-multi/ /opt/zimbra/zimbramon/lib
    rsync -av /usr/lib64/perl5/5.10.0/x86_64-linux-thread-multi/ /opt/zimbra/zimbramon/lib
    rm -rf /opt/zimbra/zimbramon/lib/perl5


    The install.sh now works just fine.
    Last edited by rickard; 08-20-2010 at 12:55 PM.

Similar Threads

  1. Replies: 25
    Last Post: 11-20-2009, 12:19 AM
  2. Is 4.5.10 supported on FC7
    By tonyawbrey in forum Installation
    Replies: 4
    Last Post: 01-09-2008, 09:14 PM
  3. iCal To dos / task syncing to be supported in 5?
    By steviestar in forum CalDAV / CardDAV / iSync
    Replies: 7
    Last Post: 12-05-2007, 05:20 AM
  4. Replies: 4
    Last Post: 07-25-2007, 08:31 PM
  5. Move user between Zimbra servers
    By lightman in forum Migration
    Replies: 7
    Last Post: 02-27-2007, 10:35 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •