Results 1 to 4 of 4

Thread: [SOLVED] TLS/SSL required since update to 6.0.4 (need to enable insecure login)

  1. #1
    Join Date
    Nov 2008
    Posts
    10
    Rep Power
    6

    Default [SOLVED] TLS/SSL required since update to 6.0.4 (need to enable insecure login)

    Hi,

    since I updated to ZCS 6.0.4 a few days ago I cannot receive mails via IMAP or POP3 without secure connection. (No problem at all after enabling SSL or TLS but some clients still have the insecure setting and I don't want to force them to change the settings.)

    No settings have been changed, the setup is very simple and default. I also tried to change some settings after the update like described here (Setting Up a Single Node)
    Zimbra IMAP/POP Proxy
    but unfortunately nothing seems to help

    Any advice appreciated - thanks

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by elcorazon View Post
    since I updated to ZCS 6.0.4 a few days ago I cannot receive mails via IMAP or POP3 without secure connection. (No problem at all after enabling SSL or TLS but some clients still have the insecure setting and I don't want to force them to change the settings.)
    You really should not let clients connect via an insecure connection, their passwords will be visible to anyone sniffing your system. Do you mean via Port 25 for submitting mail or via IMAP(S)/POP3(S)? What port(s) are they trying to connect to?

    Quote Originally Posted by elcorazon View Post
    No settings have been changed, the setup is very simple and default. I also tried to change some settings after the update like described here (Setting Up a Single Node)
    Zimbra IMAP/POP Proxy
    but unfortunately nothing seems to help
    You haven't enabled the proxy have you? What settings did you change?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Dec 2009
    Location
    Singapore and India
    Posts
    42
    Rep Power
    5

    Default

    Quote Originally Posted by elcorazon View Post
    Hi,

    since I updated to ZCS 6.0.4 a few days ago I cannot receive mails via IMAP or POP3 without secure connection. (No problem at all after enabling SSL or TLS but some clients still have the insecure setting and I don't want to force them to change the settings.)

    No settings have been changed, the setup is very simple and default. I also tried to change some settings after the update like described here (Setting Up a Single Node)
    Zimbra IMAP/POP Proxy
    but unfortunately nothing seems to help

    Any advice appreciated - thanks
    As phoenix suggested, its very insecure to do this. But anyways, you can try enabling "Clear Text" option in IMAP/POP3 tab of Global Settings when in the Administration Panel. You may also need to remove "TLS Auth only" from the MTA tab.

    If still only TLS is coming up (it should not), check what the values are as following :
    zmprov gs `zmhostname` | grep zimbraReverseProxyPop3StartTlsMode
    zmprov gs `zmhostname` | grep zimbraReverseProxyImapStartTlsMode

    If set to 'Only', change by :
    zmprov ms `zmhostname` zimbraReverseProxyPop3StartTlsMode on
    zmprov ms `zmhostname` zimbraReverseProxyImapStartTlsMode on

    zmcontrol stop/start may be required.
    VBNCloud & VBNMail - Administrator
    Zimbra OSS with Full Cloud Files/Gallery Services [Under Dev]

  4. #4
    Join Date
    Nov 2008
    Posts
    10
    Rep Power
    6

    Default

    Quote Originally Posted by vbn View Post
    As phoenix suggested, its very insecure to do this. But anyways, you can try enabling "Clear Text" option in IMAP/POP3 tab of Global Settings when in the Administration Panel. You may also need to remove "TLS Auth only" from the MTA tab.
    I know its insecure (thats why I wrote it in the title) - and I think I will disable it in a few weeks after warning the clients. But since some clients have been unable to receive mails with their current setting I needed to reset it to the state it was before the update.

    Quote Originally Posted by vbn View Post
    If still only TLS is coming up (it should not), check what the values are as following :
    zmprov gs `zmhostname` | grep zimbraReverseProxyPop3StartTlsMode
    zmprov gs `zmhostname` | grep zimbraReverseProxyImapStartTlsMode

    If set to 'Only', change by :
    zmprov ms `zmhostname` zimbraReverseProxyPop3StartTlsMode on
    zmprov ms `zmhostname` zimbraReverseProxyImapStartTlsMode on

    zmcontrol stop/start may be required.
    That helped, thanks!

    Setting the suggested values in the Admin panel didn't help (I tried that before posting, hope I didn't miss something).

Similar Threads

  1. Is an update required??
    By Jbrabander in forum Zimbra Connector for Outlook
    Replies: 6
    Last Post: 08-04-2008, 01:29 PM
  2. Update Received Date in Folder-Listing
    By Oswald-Kolle in forum Installation
    Replies: 25
    Last Post: 08-21-2007, 04:21 PM
  3. pop3s only works when enable clear text login is checked
    By freeformz in forum Administrators
    Replies: 1
    Last Post: 01-29-2007, 06:48 PM
  4. Enable clear text login - Server error encountered
    By czaveri in forum Installation
    Replies: 14
    Last Post: 03-06-2006, 04:16 PM
  5. M3 -> full release - any update scripts required
    By bin2hex in forum Installation
    Replies: 4
    Last Post: 02-20-2006, 12:53 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •