Results 1 to 6 of 6

Thread: Any way to truly confirm the Zimbra version running?

Hybrid View

  1. #1
    Join Date
    Feb 2007
    Posts
    147
    Rep Power
    8

    Default Any way to truly confirm the Zimbra version running?

    A few days ago I tried to upgrade from FOSS 5.0.14 to FOSS 6.0.4 on my Ubuntu 6.10 server. Before I get replies to the obvious, yes I know this is not an officially supported version of Ubuntu. However, I've been running the 6.06LTS builds since the last few 4.x versions and all of the 5.x versions without problems.

    Anyway, after the 6.0.4 upgrade (which appeared to go smoothly), the e-mail system was unreachable. Lacking time to truly investigate and resolve the issue, I simply restored a backup (which I've done with a few failed installs in the past) and everything was back to normal... or maybe it wasn't.

    Today I intended to upgrade to 5.0.21 just to get the latest updates/fixes and the install reports I am running 6.0.4. zmcontrol -v reports:
    Release 6.0.4_GA_2038.UBUNTU6 UBUNTU6 FOSS edition

    I don't see how this is possible since I literally deleted everything in the /opt/zimbra directory ("rm -r -f *" from within /opt/zimbra) then restored the files from a tar made prior to the upgrade. Also, I notice no differences in the e-mail GUI or functions though I've never seen the 6.x GUI.

    How can I determine what's going on? Any help will be appreciated.

  2. #2
    Join Date
    Mar 2006
    Location
    Beaucaire, France
    Posts
    2,322
    Rep Power
    13

    Default

    The packages installed (the .deb files, OS side) are 6.0.4 ones...

  3. #3
    Join Date
    Feb 2007
    Posts
    147
    Rep Power
    8

    Default

    Are you saying there are Zimbra components installed outside the /opt/zimbra directory tree? I've had failed installs before (including previous attempts to upgrade to 6.0.0 and 6.0.2) where I followed the same delete/restore process and everything was fine - including the ability to attempt an upgrade again.

    Now, it's telling me I can't downgrade 6.0.4 to 5.0.21 even though I believe I'm really running 5.0.14. So my questions are thus:

    1) Is there something definitive I can look at in the /opt/zimbra directories that would tell me what version I'm on? If so, can you give me an example? I've purused the forums and the wiki docs without coming up with how I would accomplish this.

    2) Is the current running Zimbra version set anywhere outside the /opt/zimbra directories? (I.e., is it possible it's grabbing this from somewhere that wouldn't have been changed back when I did the delete/restore of /opt/zimbra)

    Thank you for your assistance.

  4. #4
    Join Date
    Feb 2007
    Posts
    147
    Rep Power
    8

    Default

    I'm far from a Linux expert and understanding/following the syntax in the install files takes me huge amounts of time. However, I have managed to track down that the install process is using the following line to determine the version of each package:
    Code:
    dpkg -s {zimbra-package}
    Taking a look at the packages, the following line:
    Code:
    dpkg -s zimbra-ldap
    produces the output:
    Code:
    Package: zimbra-ldap
    Status: install ok installed
    Priority: optional
    Section: Mail
    Maintainer: build@zimbra.com
    Architecture: i386
    Version: 6.0.4_GA_2038.UBUNTU6
    Depends: zimbra-core
    Description: Best email money can buy
    Does this process actually reflect whats in the /opt/zimbra directories or simply the last version to go through the dpkg install process?

  5. #5
    Join Date
    Mar 2006
    Location
    Beaucaire, France
    Posts
    2,322
    Rep Power
    13

    Default

    Quote Originally Posted by rajahd View Post
    Does this process actually reflect whats in the /opt/zimbra directories or simply the last version to go through the dpkg install process?
    The dpkg install process.

    The command you used asks the OS databases what are the packages installed. You'll get the same answer even if you fully delete /opt/zimbra.

  6. #6
    Join Date
    Feb 2007
    Posts
    147
    Rep Power
    8

    Default

    Ok so I think that's my root problem. The failed 6.0.4 install left the OS databases showing 6.0.4 packages were installed and they aren't. I guess I'll try telling the Zimbra install to ignore the current installed version and install anyway. My fear is that it won't correctly identify the current version for where to start the upgrade process from - guess I'll find out.

    Thanks for the info.

Similar Threads

  1. Replies: 21
    Last Post: 02-04-2010, 09:06 AM
  2. /tmp filling
    By Nutz in forum Administrators
    Replies: 8
    Last Post: 02-22-2008, 01:00 AM
  3. Major Issue - 5.0RC2 NE to 5.0GA NE failed
    By DougWare in forum Installation
    Replies: 7
    Last Post: 01-06-2008, 08:56 PM
  4. Replies: 22
    Last Post: 12-02-2007, 04:05 PM
  5. Zimbra Install Problem - getDirectContext
    By bsimzer in forum Installation
    Replies: 27
    Last Post: 07-19-2007, 10:12 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •