Results 1 to 7 of 7

Thread: Installations fails on LDAP Initialisation

  1. #1
    Join Date
    Sep 2005
    Location
    Johannesburg, South Africa
    Posts
    19
    Rep Power
    10

    Default Installations fails on LDAP Initialisation

    I am trying a new install on FC4 and the installation fails with the following ERROR.
    Code:
    Initializing ldap...FAILED (256)
    Further checks show that LDAP has started and is running, but the /tmp//tmp/zmsetup.log.7840 file says LDAP server cannot be contacted as shown below:
    Code:
    .............
    Started slapd: pid 9002
    ldap_bind: Can't contact LDAP server (-1)
    It also appears that the host name is correctly resolved, see the code below:
    Code:
    [zimbra@mail zcs]$ host `hostname`
    mail.domain.net has address 192.168.0.3
    mail.domain.net is an alias for domain.net.
    mail.domainnet is an alias for domain.net.
    [zimbra@mail zcs]$
    Any help?
    Thanks in advance.

  2. #2
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    Would you mind posting the whole log? Bind isn't binding correctly to the interface.

    If you wish you can pvt me your log.

    John

  3. #3
    Join Date
    Sep 2005
    Location
    Johannesburg, South Africa
    Posts
    19
    Rep Power
    10

    Default

    Here is my /tmp//tmp/zmsetup.log.7840 log file with true domain name replaed with 'domain.net'.
    Code:
    ** Creating CA private key
    
    Generating a 1024 bit RSA private key
    ......++++++
    ..................++++++
    unable to write 'random state'
    writing new private key to '/opt/zimbra/ssl/ssl/ca/ca.key'
    -----
    ** Creating CA cert
    
    Signature ok
    subject=/C=US/ST=N/A/L=N/A/O=Zimbra Collaboration Suite/CN=mail.domain.net
    Getting Private key
    unable to write 'random state'
    ** Importing CA
    
    Certificate was added to keystore
    ** Creating keystore
    
    ** Creating server cert request
    
    Generating a 1024 bit RSA private key
    ..++++++
    .......++++++
    unable to write 'random state'
    writing new private key to '/opt/zimbra/ssl/ssl/server/server.key'
    -----
    ** Signing cert request
    
    Using configuration from /opt/zimbra/ssl/ssl/zmssl.cnf
    Check that the request matches the signature
    Signature ok
    Certificate Details:
            Serial Number: 2 (0x2)
            Validity
                Not Before: Jul  6 18:33:30 2006 GMT
                Not After : Jul  6 18:33:30 2007 GMT
            Subject:
                countryName               = US
                stateOrProvinceName       = N/A
                organizationName          = Zimbra Collaboration Suite
                commonName                = mail.domain.net
            X509v3 extensions:
                X509v3 Basic Constraints: 
                    CA:FALSE
                Netscape Comment: 
                    OpenSSL Generated Certificate
                X509v3 Subject Key Identifier: 
                    50:9C:0A:78:56:D2:DB:96:A1:E6:55:0F:50:82:CA:01:25:90:F4:FB
                X509v3 Authority Key Identifier: 
                    DirName:/C=US/ST=N/A/L=N/A/O=Zimbra Collaboration Suite/CN=mail.domain.net
                    serial:91:98:BB:E1:54:B7:6F:78
    
    Certificate is to be certified until Jul  6 18:33:30 2007 GMT (365 days)
    
    Write out database with 1 new entries
    Data Base Updated
    unable to write 'random state'
    Signature ok
    subject=/C=US/ST=NA/L=NA/O=Zimbra/OU=Zimbra/CN=mail.domain.net
    Getting CA Private Key
    unable to write 'random state'
    Started slapd: pid 9002
    ldap_bind: Can't contact LDAP server (-1)

  4. #4
    Join Date
    Nov 2005
    Posts
    518
    Rep Power
    11

    Default

    what happens if you "telnet mail.domain.net 389"? is selinux enabled (grep -v '^#' /etc/selinux/config)?

  5. #5
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    Yeah, I agree with Bobby, try that.


    I would, more particularly, try to telnet >ip of external interface< 389

  6. #6
    Join Date
    Sep 2005
    Location
    Johannesburg, South Africa
    Posts
    19
    Rep Power
    10

    Default

    These are my telnet results:
    Code:
    [luke@mail ~]$ telnet mail.domain.net 389
    Trying 192.168.0.3...
    telnet: connect to address 192.168.0.3: Connection refused
    telnet: Unable to connect to remote host: Connection refused
    [luke@mail ~]$
    With external ip optained from IPCop gateway/firewal
    Code:
    [luke@mail ~]$ telnet 165.146.46.87 389
    Trying 165.146.46.87...
    telnet: connect to address 165.146.46.87: Connection refused
    telnet: Unable to connect to remote host: Connection refused
    [luke@mail ~]$
    LDAP demon seems to be running:
    Code:
    [root@mail luke]# ps auxww | grep slapd
    zimbra    9002  0.0  1.0  20316  8080 ?        Ssl  Jul06   0:00 /opt/zimbra/open ldap-2.3.21/libexec/slapd -l LOCAL0 -4 -u zimbra -h ldap://:389/ -f /opt/zimbra/c onf/slapd.conf
    root     23561  0.0  0.0   3752   692 pts/1    R+   20:30   0:00 grep slapd
    [root@mail luke]#
    Last edited by Linsys; 07-07-2006 at 12:34 PM.

  7. #7
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    Do you have SELinux running?

    >grep -v '^#' /etc/selinux/config


    Quote Originally Posted by Linsys
    These are my telnet results:
    Code:
    [luke@mail ~]$ telnet mail.domain.net 389
    Trying 192.168.0.3...
    telnet: connect to address 192.168.0.3: Connection refused
    telnet: Unable to connect to remote host: Connection refused
    [luke@mail ~]$
    With external ip optained from IPCop gateway/firewal
    Code:
    [luke@mail ~]$ telnet 165.146.46.87 389
    Trying 165.146.46.87...
    telnet: connect to address 165.146.46.87: Connection refused
    telnet: Unable to connect to remote host: Connection refused
    [luke@mail ~]$
    LDAP demon seems to be running:
    Code:
    [root@mail luke]# ps auxww | grep slapd
    zimbra 9002 0.0 1.0 20316 8080 ? Ssl Jul06 0:00 /opt/zimbra/open ldap-2.3.21/libexec/slapd -l LOCAL0 -4 -u zimbra -h ldap://:389/ -f /opt/zimbra/c onf/slapd.conf
    root 23561 0.0 0.0 3752 692 pts/1 R+ 20:30 0:00 grep slapd
    [root@mail luke]#

Similar Threads

  1. Zimbra Install Problem - getDirectContext
    By bsimzer in forum Installation
    Replies: 27
    Last Post: 07-19-2007, 11:12 AM
  2. 3 testing: LDAP: 389 Failed when restore zimbra
    By victorLeong in forum Administrators
    Replies: 15
    Last Post: 05-24-2007, 07:45 AM
  3. Mac OSX install: Java errors & LDAP CA error
    By jefbear in forum Installation
    Replies: 9
    Last Post: 12-16-2006, 03:39 PM
  4. Replies: 4
    Last Post: 11-15-2006, 12:16 PM
  5. Replies: 2
    Last Post: 05-24-2006, 11:01 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •