hello everybody!
back again,for a question...here we go....
i installed zcs 6.0.4 on an ubuntu 8.04 server,everything is fine,i can send and receive,but...
i have a main domain name registered (for example maindomain.com) and some other domain names for web pages also registered..
the problem is that even i can use my server,i can not hit mail.mydomain.com from my browser...and also every other mail.domainname.com

it gives me an 503 service unavailable error.....
what is wrong?can't understand! i need to give mail access to my clients like this
"mail.clientdomain.com" (an example is mail.palfh.gr)
i must inform you that about 1 month ago,i set up another installation of zimbra (6.0.3) and it worked fine....and also that i use two virtual machines (one for zimbra-one for web server)
and that i use bind in my web and another in zimbra as this how to says...
Ubuntu 8.04 LTS Server (Hardy Heron) Install Guide - Zimbra :: Wiki

i post my config files if you need it...

my /etc/bind/db.deltacomputers.com

; BIND data file for deltacomputers.com
$TTL 604800
@ IN SOA mail.deltacomputers.com. admin.deltacomputers.com. (
070725 ; Serial
604800 ; Refresh
86400 ; Retry
2419200 ; Expire
604800 ) ; Negative Cache TTL
@ IN NS mail
IN MX 10 mail
mail IN A

my /etc/hosts localhost deltacomputers.com zeus

my /etc/named.conf.local
// Do any local configuration here

// Consider adding the 1918 zones here, if they are not used in your
// organization
//include "/etc/bind/zones.rfc1918";

zone "deltacomputers.com" {
type master;
file "/etc/bind/db.deltacomputers.com";

my named.conf.options
// query-source address * port 53;

// If your ISP provided one or more IP addresses for stable
// nameservers, you probably want to use them as forwarders.
// Uncomment the following block, and insert the addresses replacing
// the all-0's placeholder.

forwarders {;

auth-nxdomain no; # conform to RFC1035
listen-on-v6 { any; };

my resolv.conf
search deltacomputers.com

(some stuff MODIFIED ....and some unneeded lines removed)

hope this helps....thank you and sorry for this long post....