Results 1 to 2 of 2

Thread: [SOLVED] MySQL Error/Corruption

  1. #1
    Join Date
    Jan 2010
    Rep Power

    Default [SOLVED] MySQL Error/Corruption


    We've been trying to install Zimbra network edition to trial it on one of our servers here. The installation seemed to go through without any issues, but we're constantly getting the below message when trying to establish whether everything is running with "zmcontrol status"

    mailbox Stopped
    zmmtaconfig is running.
    mysql.server is not running
    mailboxd is running.

    We have tried several of the steps on these forums, including trying a reinstall, fixing permissions with zmfixperms, mysql_install_db, etc. Zimbra was getting installed to a clean box, fully updated RHEL5 64 bit edition with no other services or servers running on it. Below are the contents of mysql_error.log and the result of zmdbintegrityreport. I'm unsure if the two issues are related, but included here anyway.

    Any help would be appreciated, since we're keen to get Zimbra up and running so we can start testing it!

    Zmdbintegrity report output -

     /opt/zimbra/mysql/bin/mysqlcheck: Got error: 2002: Can't connect to local MySQL server through socket '/opt/zimbra/db/mysql.sock' (2) when trying to connect
    command failed

    Mysql_error.log output -

    100114 16:48:34  mysqld started
    InnoDB: The log sequence number in ibdata files does not match
    InnoDB: the log sequence number in the ib_logfiles!
    100114 16:48:34  InnoDB: Database was not shut down normally!
    InnoDB: Starting crash recovery.
    InnoDB: Reading tablespace information from the .ibd files...
    InnoDB: Restoring possible half-written data pages from the doublewrite
    InnoDB: buffer...
    InnoDB: Creating foreign key constraint system tables
    InnoDB: Starting in background the rollback of uncommitted transactions
    100114 16:48:35  InnoDB: Rollback of non-prepared transactions completed
    InnoDB: Foreign key constraint system tables created
    100114 16:48:35  InnoDB: Started; log sequence number 0 36808
    100114 16:48:35 [ERROR] Fatal error: Can't open and lock privilege tables: Table '' doesn't exist
    100114 16:48:35  mysqld ended

    Result of mysql.server start and mysql.server status which generates the mysql_error.log entries

     [zimbra@zimbra libexec]$ mysql.server start
    Starting mysqld...done.
    [zimbra@zimbra libexec]$ mysql.server status
    mysql is not running
    [zimbra@zimbra libexec]$

  2. #2
    Join Date
    Jan 2010
    Rep Power


    Issue has been solved... a *third* reinstall of zimbra appeared to fix the issue.

Similar Threads

  1. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 12:42 AM
  2. [SOLVED] Install Problem in Ubuntu 6.06 Server
    By xtimox in forum Installation
    Replies: 16
    Last Post: 03-27-2008, 09:36 AM
  3. DNS Questions and Trouble Installing
    By smurraysb in forum Installation
    Replies: 22
    Last Post: 03-14-2008, 03:27 PM
  4. Replies: 18
    Last Post: 03-20-2006, 01:22 PM
  5. Can't start MySQL to init db - Gentoo
    By fak3r in forum Installation
    Replies: 3
    Last Post: 10-10-2005, 06:59 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts