Results 1 to 6 of 6

Thread: upgrade to 6.0.4 failed

  1. #1
    Join Date
    Oct 2008
    Posts
    4
    Rep Power
    7

    Default upgrade to 6.0.4 failed

    I have a major issue, I just tried to upgrade from 6.0.1 to 6.0.4 on centOS4, but the file that was downloaded was for centOS5. I trusted the backup and it was not there....

    now I get the following errors when I try to update with the correct files.

    Should I try to go back to 6.0.1? Or just upgrade the server to CentOS5........

    zimbra-core...FOUND zimbra-core-6.0.4_GA_2038
    ZCS upgrade from 6.0.4 to 6.0.4 will be performed.

    Saving existing configuration file to /opt/zimbra/.saveconfig


    PLEASE READ THIS AGREEMENT CAREFULLY BEFORE USING THE SOFTWARE.
    ZIMBRA, INC. ("ZIMBRA") WILL ONLY LICENSE THIS SOFTWARE TO YOU IF YOU
    FIRST ACCEPT THE TERMS OF THIS AGREEMENT. BY DOWNLOADING OR INSTALLING
    THE SOFTWARE, OR USING THE PRODUCT, YOU ARE CONSENTING TO BE BOUND BY
    THIS AGREEMENT. IF YOU DO NOT AGREE TO ALL OF THE TERMS OF THIS
    AGREEMENT, THEN DO NOT DOWNLOAD, INSTALL OR USE THE PRODUCT.

    License Terms for the Zimbra Collaboration Suite:
    Zimbra - Zimbra Public End-User License Agreement, Version 2.1


    Press Return to continue

    Checking for prerequisites...
    FOUND: NPTL
    FOUND: sudo-1.6.7p5-30.1.3
    FOUND: libidn-0.5.6-1
    FOUND: gmp-4.1.4-3
    FOUND: compat-libstdc++-33-3.2.3-47.3
    FOUND: /usr/lib/libstdc++.so.5
    FOUND: /usr/lib/libstdc++.so.6
    Checking for suggested prerequisites...
    FOUND: perl-5.8.5
    FOUND: sysstat
    Prerequisite check complete.
    Checking current number of databases...

    Do you want to verify message store database integrity? [Y]
    Verifying integrity of message store databases. This may take a while.
    Can't load '/opt/zimbra/zimbramon/lib/i386-linux-thread-multi/auto/Data/UUID/UUID.so' for module Data::UUID: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /opt/zimbra/zimbramon/lib/i386-linux-thread-multi/auto/Data/UUID/UUID.so) at /usr/lib/perl5/5.8.5/i386-linux-thread-multi/DynaLoader.pm line 230.
    at /opt/zimbra/zimbramon/lib/Zimbra/Mon/Logger.pm line 22
    Compilation failed in require at /opt/zimbra/zimbramon/lib/Zimbra/Mon/Logger.pm line 22.
    BEGIN failed--compilation aborted at /opt/zimbra/zimbramon/lib/Zimbra/Mon/Logger.pm line 22.
    Compilation failed in require at bin/zmdbintegrityreport line 19.
    BEGIN failed--compilation aborted at bin/zmdbintegrityreport line 19.
    [root@email zcs-6.0.4_GA_2038.RHEL4.20091214172138]# cd /opt/zimbra
    Last edited by Kize; 01-20-2010 at 02:54 AM.

  2. #2
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Welcome to the forums

    First of all make a backup of /opt/zimbra just in case! Then download the correct RHEL version for your platform and perform the upgrade again. It has not gone through the major part of the install script so you may get away with it.

  3. #3
    Join Date
    Oct 2008
    Posts
    4
    Rep Power
    7

    Default

    I tried that already, it had already gotten to the point that ldap would not start, the "floating integer" error......

    I am in the process now of upgrading the server itself to CentOS5 and trying to do the upgrade again. I am going to chown the zimbra directory, then run the zmfixperms, then the db_recover before I try the upgrade again......

  4. #4
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    I hope you have secured a backup of /opt/zimbra before upgrading the OS.

  5. #5
    Join Date
    Oct 2008
    Posts
    4
    Rep Power
    7

    Default

    Yes sir, I did that about 2:30 this morning.....

  6. #6
    Join Date
    Oct 2008
    Posts
    4
    Rep Power
    7

    Default

    That worked, but now the zimbra user has disappeared. I am searching now to see how to recreate it........

Similar Threads

  1. [SOLVED] Upgrade to 6.0.4 Failed
    By miguel in forum Installation
    Replies: 6
    Last Post: 02-02-2010, 04:30 AM
  2. Help!!! Moving ZCS does not work!
    By ASebestian in forum Migration
    Replies: 7
    Last Post: 02-12-2009, 06:06 PM
  3. My Zimbra server down ... please help :)
    By frankb in forum Administrators
    Replies: 2
    Last Post: 12-12-2007, 11:29 AM
  4. Upgrade: 4.5.5 -> 4.5.6 failed, LDAP/slapd issues
    By Daimyo in forum Installation
    Replies: 7
    Last Post: 08-04-2007, 10:23 PM
  5. failed upgrade, failed restore, big trouble
    By feralcoder in forum Installation
    Replies: 2
    Last Post: 03-19-2007, 06:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •