Results 1 to 10 of 10

Thread: ZCS 6.04 - domain name

  1. #1
    Join Date
    Jan 2010
    Location
    Austria
    Posts
    30
    Rep Power
    5

    Default ZCS 6.04 - domain name

    hi all!
    i have installed Zimbra 6.04 on Centos 5.4 on a vmware. i have some problems with understanding all things. first i want to know about the /etc/hosts. i put in there 192.168.1.2 - zimbra.mydomain.com. But my MX-Record is set to smtp.mydomain.com. so what is the right for /etc/hosts? is the zimbra.mydomain.com for the external login? where i set the mx recorded domain? i dont can't send any email, not intern or extern, every mail is in the queue, connection time out on zimbra.mydomain.com. what for settings i must make for my MX-Domain smtp.mydomain.com?

    greetz

    pc-dok

  2. #2
    Join Date
    Oct 2009
    Location
    Omaha, NE
    Posts
    28
    Rep Power
    6

  3. #3
    Join Date
    Jan 2010
    Location
    Austria
    Posts
    30
    Rep Power
    5

    Default

    thx adone for answering

    i have read this howto, the only thing is, i test zimbra not behind a firewall, so i dont need to configure bind, is that true? for the domains, i will take the "smtp.mydomain.com" and after install i create the domain "mydomain.com" for the emailadresses, is that correct? ports on my router i must forward is the port 80,443,7071,25,143, thats correct? when these things are correct, email should be able to send and recieve emails??

    greetz

    pc-dok

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by pc-dok View Post
    i have read this howto, the only thing is, i test zimbra not behind a firewall, so i dont need to configure bind, is that true?
    No, that not correct. If you are behind a firewall or a NAT router you need to set-up a Split DNS. As your Zimbra server has an IP address of 192.168.x.x then I guess you're behind a NAT device so you will need the Split DNS set-up.

    Quote Originally Posted by pc-dok View Post
    for the domains, i will take the "smtp.mydomain.com" and after install i create the domain "mydomain.com" for the emailadresses, is that correct?
    No, that's not correct. When you install Zimbra (after setting the correct DNS A & MX records and valid hosts file) you will be asked if you want to change the Domain Name, at that point you answer 'yes' and change the domain name to "mydomain.com" and your mail will be sent with that domain name.

    Quote Originally Posted by pc-dok View Post
    "mydomain.com"ports on my router i must forward is the port 80,443,7071,25,143, thats correct? when these things are correct, email should be able to send and recieve emails??
    The answer to that would depend on what services your Zimbra server is going to offer to clients outside of your LAN, you should not allow any unsecured connections to your server via either the Web UI or clients (such as Thunderbird, Outlook etc.) they should all be secure. The only port you need to forward 'as-is' is Port 25 for SMTP connections.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    Join Date
    Dec 2009
    Location
    Singapore and India
    Posts
    42
    Rep Power
    6

    Default

    Quote Originally Posted by pc-dok View Post
    thx adone for answering

    i have read this howto, the only thing is, i test zimbra not behind a firewall, so i dont need to configure bind, is that true? for the domains, i will take the "smtp.mydomain.com" and after install i create the domain "mydomain.com" for the emailadresses, is that correct? ports on my router i must forward is the port 80,443,7071,25,143, thats correct? when these things are correct, email should be able to send and recieve emails??

    greetz

    pc-dok
    May I suggest you do an install on a test system (hoping you are not pushing this directly on production ), since you will find most of the answers during the whole install and post-install procedures. Read the docs and wiki, perform the same practically on a test box.
    VBNCloud & VBNMail - Administrator
    Zimbra OSS with Full Cloud Files/Gallery Services [Under Dev]

  6. #6
    Join Date
    Jan 2010
    Location
    Austria
    Posts
    30
    Rep Power
    5

    Default

    hello phoenix, thx for speedy answer, ok than i make configuration with bind and splitdns. i will test it on evening, hope that it will be ok , and hope i can ask again when i have problems!

    greetz

    pc-dok

  7. #7
    Join Date
    Jan 2010
    Location
    Austria
    Posts
    30
    Rep Power
    5

    Default

    hi vbn, yes i testing it since weekend, i give microsoft exchange the format c: and now i will install it on a vmware, centos 5.4 machine, the root machine (physical machine with vmare-server) is also centos 5.4 with bind and squid proxy hope it will work fine, and yes i read all the manual

    greetz

    pc-dok

  8. #8
    Join Date
    Jan 2010
    Location
    Austria
    Posts
    30
    Rep Power
    5

    Default

    hi all

    after i reinstall my zimbra exact the same as in the howto for zimbra oss6 on centos 5.4, i have now one problem. my mysql from zimbra will not start, because he missing his mysql.sock. great. whats happend on the install, how can i generate a mysql.sock data?

    greetz

    pc-dok

  9. #9
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by pc-dok View Post
    after i reinstall my zimbra exact the same as in the howto for zimbra oss6 on centos 5.4, i have now one problem. my mysql from zimbra will not start, because he missing his mysql.sock. great. whats happend on the install, how can i generate a mysql.sock data
    You're not giving much information here. What happens when you start Zimbra, do all the services start? Whay does the output of 'zmcontrol status' show? What errors do you see in the log files ?

    You should also search the forums for similar erros, this problem has more than likely been asked and answered before.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  10. #10
    Join Date
    Jan 2010
    Location
    Austria
    Posts
    30
    Rep Power
    5

    Default

    sorry for short answer, it was very late in the night , zmcontrol status give me return, that "mail" (mysql-failure) and "stats" is not online, all other services are online. log files i can look after work. i can not login remote also i can not login to the admin webinterface of zimbra, is that because mail-service is not running? on evenig i will study the logs.

    greetz

Similar Threads

  1. Trouble Sending mail - All Messages deferred!
    By SiteDiscovery in forum Administrators
    Replies: 7
    Last Post: 09-03-2009, 05:52 AM
  2. Changed Domain name for ZCS account
    By John Marsden, FH Ba in forum General Questions
    Replies: 0
    Last Post: 05-09-2009, 12:53 AM
  3. Mail is being queued, not delivered!
    By icepick94 in forum Administrators
    Replies: 12
    Last Post: 01-22-2009, 07:03 AM
  4. ZCS 3.2 Beta Available
    By KevinH in forum Announcements
    Replies: 31
    Last Post: 07-07-2006, 04:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •