Results 1 to 5 of 5

Thread: [SOLVED] Problems with nginx

  1. #1
    Join Date
    Jan 2010
    Posts
    7
    Rep Power
    5

    Default [SOLVED] Problems with nginx

    Hi all,

    I have installed Zimbra with Samba (as PDC) on my debian lenny Server following the great UNIX_and_Windows_Accounts_in_Zimbra_LDAP_and_Zimbr a_Admin_UI_6.0 tutorial. Thanks for the good work!

    Everything went fine accept zimbra wasn'tīt able to find my MX Record. However finishing my installation all services came up and worked as expected. So I just ignored it...

    Then I recognized that my server is running most of the time around 90% CPU and getting slower and slower. Looking at top an syslog my nginx seems to have real problems. Its taking most of the CPU and writing all the time following error into my syslog:

    Code:
    Jan 27 06:27:06 serv kernel: [27906.054524] __ratelimit: 1452 messages suppressed
    Jan 27 06:27:06 serv kernel: [27906.054541] nginx[14382]: segfault at 8 ip 4142d9 sp 7fffeaf59ed0 error 4 in nginx[400000+82000]
    Jan 27 06:27:11 serv kernel: [27911.070569] __ratelimit: 1455 messages suppressed
    Jan 27 06:27:11 serv kernel: [27911.070569] nginx[15871]: segfault at 8 ip 4142d9 sp 7fffeaf59ed0 error 4 in nginx[400000+82000]
    Jan 27 06:27:16 serv kernel: [27916.082126] __ratelimit: 1262 messages suppressed
    Jan 27 06:27:16 serv kernel: [27916.082126] nginx[17283]: segfault at 8 ip 4142d9 sp 7fffeaf59ed0 error 4 in nginx[400000+82000]
    Jan 27 06:27:21 serv kernel: [27921.093174] __ratelimit: 1395 messages suppressed
    Jan 27 06:27:21 serv kernel: [27921.093184] nginx[18681]: segfault at 8 ip 4142d9 sp 7fffeaf59ed0 error 4 in nginx[400000+82000]
    Jan 27 06:27:26 serv kernel: [27926.116204] __ratelimit: 1172 messages suppressed
    Jan 27 06:27:26 serv kernel: [27926.116204] nginx[19858]: segfault at 8 ip 4142d9 sp 7fffeaf59ed0 error 4 in nginx[400000+82000]
    Trying a clean new installation or shutting down every other not needed service like samba, dhcpd etc my server still produces the same error. At the moment I am really stuck with this problem not even having an idea what to do... Someone out there knowing this error???

    Just in case the MX record might be part of the problem here my config:

    bind9
    Code:
    127.0.0.1       localhost
    127.0.0.1       serv.vsch.de<>serv
    127.0.1.1       serv.vsch.de<>serv
    192.168.100.10  serv.vsch.de  serv
    
    # The following lines are desirable for IPv6 capable hosts
    ::1     localhost ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts
    dig serv.vsch.de
    ; <<>> DiG 9.5.1-P3 <<>> serv.vsch.de
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 25639
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;serv.vsch.de. IN A

    ;; ANSWER SECTION:
    serv.vsch.de. 38400 IN A 192.168.100.10

    ;; AUTHORITY SECTION:
    vsch.de. 38400 IN NS serv.vsch.de.

    ;; Query time: 45 msec
    ;; SERVER: 192.168.100.10#53(192.168.100.10)
    ;; WHEN: Thu Jan 28 23:53:54 2010
    ;; MSG SIZE rcvd: 70
    dig serv.vsch.de MX

    ; <<>> DiG 9.5.1-P3 <<>> serv.vsch.de MX
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 41289
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;serv.vsch.de. IN MX

    ;; AUTHORITY SECTION:
    vsch.de. 38400 IN SOA serv.vsch.de. root.serv.vsch.de. 1147256750 10800 3600 604800 38400

    ;; Query time: 38 msec
    ;; SERVER: 192.168.100.10#53(192.168.100.10)
    ;; WHEN: Thu Jan 28 23:55:56 2010
    ;; MSG SIZE rcvd: 81

  2. #2
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Welcome to the forums

    You hosts file is wrong and it should look like
    Code:
    127.0.0.1       localhost.localdomain localhost
    192.168.100.10  serv.vsch.de  serv
    It would appear you are behind a firewall/router and would be best to setup a Split DNS - Zimbra :: Wiki architecture.

  3. #3
    Join Date
    Jan 2010
    Posts
    7
    Rep Power
    5

    Default

    You got it, and me on the right way...! Thanx!!!

    Just adding

    Code:
    127.0.0.1       localhost.localdomain localhost
    was the solution. Now its working pritty fine.

    I tried Wiki:Split_dns too but it seems that bind9 from lenny is a little different to older versions so it didn't work for me. However running Debian Lenny it is no good idea to add anything to namend.conf because this file may be replaced by system at upgrade etc. The first part with the options should be done in named.conf.options but is not really needed. Just uncomment the default values and write in there external dns server:

    named.conf.options
    Code:
    options {
         directory "/var/cache/bind";
    
         // If there is a firewall between you and nameservers you want
         // to talk to, you may need to fix the firewall to allow multiple
         // ports to talk.  See http://www.kb.cert.org/vuls/id/800113
    
         // If your ISP provided one or more IP addresses for stable.
         // nameservers, you probably want to use them as forwarders...
         // Uncomment the following block, and insert the addresses replacing.
         // the all-0's placeholder.
    
         forwarders {
              ;
              ;
         };
    
         auth-nxdomain no;    # conform to RFC1035
         listen-on-v6 { any; };
    };
    The zone configuration should be done or included in named.conf.local:

    Code:
    //
    // Do any local configuration here
    //
    zone "vsch.de" {
        type master;
        file "/etc/bind/vschdom.local.hosts";
        };
    And with the db.server.example.com zone file my bind seems to have a problem interpreting lines not having any first parameter. Loading this file it wasn't possible to get a nslookup or access my server by the domain from another PC. So id did little changes on this file to make it run again. Here my working vschdom.local.hosts:

    Code:
    @	IN	SOA	serv.vsch.de. root.serv.vsch.de. (
    	1147256750
    	10800
    	3600
    	604800
    	38400 )
    @	IN	NS	serv.vsch.de.
    @	IN	MX	10	serv.vsch.de.
    serv.vsch.de.	IN	A	192.168.100.10
    serv.vsch.de.	IN	HINFO	i586 GNU/Linux
    serv.vsch.de.	IN	TXT	"Welcome to Raserv."
    mail.vsch.	IN	CNAME	serv.vsch.de.
    192.168.100.10.vsch.de.>IN	PTR	serv
    Thanx a lot!! And a nice weekend!

  4. #4
    Join Date
    Jan 2010
    Posts
    7
    Rep Power
    5

    Default

    Hmm why can´t I read my previosly posts?

  5. #5
    Join Date
    Feb 2007
    Location
    Portland, OR
    Posts
    1,147
    Rep Power
    10

    Default

    They were stuck in the moderator queue, I approved your first post about 20 min ago. If your second was also "hidden", somebody else got it already

Similar Threads

  1. imapsync and nginx
    By Rambo in forum Migration
    Replies: 3
    Last Post: 06-04-2008, 08:54 AM
  2. Restarting and german 'umlaut' problems
    By Oswald-Kolle in forum Installation
    Replies: 3
    Last Post: 05-29-2007, 03:09 AM
  3. iSync Connector / Apple Address Book Problems
    By jrosen in forum CalDAV / CardDAV / iSync
    Replies: 11
    Last Post: 04-16-2007, 04:40 PM
  4. Replies: 3
    Last Post: 12-06-2006, 11:31 AM
  5. Problems with public Subversion repository
    By dwhite in forum Developers
    Replies: 0
    Last Post: 11-18-2006, 12:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •