Results 1 to 7 of 7

Thread: Connection refused

  1. #1
    Join Date
    Jul 2006
    Posts
    7
    Rep Power
    9

    Question Connection refused

    Connection refused by host.

    I have installed zimbra on FC3. It was working. After executing vsftpd, placing some files to /var/ftp/pub/ and removing it, I killed vsftpd process . After all this extions, I have execute zimbra by '/opt/zimbra/libexec/zimbra start'. Now, if I navigate to "http://localhost.localdomain" FireFox said what connection was refused by 'localhost.localdomain' . I re-installed zimbra, disable firewall. It is not work.

    'zmcontrol status' said what postfix & tomcat are not running.

    Tomcat (startup.sh in "tomcat"/bin/ ) said what JRE_HOME and JAVA_HOME are not defined.
    I have typed:
    'export JAVA_HOME=/opt/zimbra/java'
    'export JRE_HOME=/opt/zimbra/java'
    and execute sturtup.sh.
    'zmcontrol status' stil said what postfix & tomcat are not running.

    Please, help me.
    Last edited by gmihey; 07-18-2006 at 07:49 AM.

  2. #2
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    Hi gmihey,
    Zimbra comes with it's own everything. MYSQL, postfix, dspam, tomcat, ldap.
    Make sure that none of the above are installed/running on your machine.

    Then try
    >su zimbra
    >tomcat start
    Quote Originally Posted by gmihey
    Connection refused by host.

    I have installed zimbra on FC3. It was working. After executing vsftpd, placing some files to /var/ftp/pub/ and removing it, I killed vsftpd process . After all this extions, I have execute zimbra by '/opt/zimbra/libexec/zimbra start'. Now, if I navigate to "http://localhost.localdomain" FireFox said what connection was refused by 'localhost.localdomain' . I re-installed zimbra, disable firewall. It is not work.

    'zmcontrol status' said what postfix & tomcat are not running.

    Tomcat (startup.sh in "tomcat"/bin/ ) said what JRE_HOME and JAVA_HOME are not defined

    Please, help me.

  3. #3
    Join Date
    Jul 2006
    Posts
    7
    Rep Power
    9

    Default

    How can I uninstall zimbra and make situation before installing it? I want to try install it again

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Just run './install.sh -u' that will remove all of zimbra and the directories. You could also check that there are no zimbra processes running before doing the install, if there are then kille them.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    Join Date
    Jul 2006
    Posts
    7
    Rep Power
    9

    Default

    I have re-installed zimbra. I have not got external ip & host name, so i am using localhost.localdomain. Zimbra was working before with this configuration. Zmsetup.pl ask me for hostname, case DNS error resolving localhost.localdomain.

    When I am typing ¨zmcontrol start¨ this apears and nothing more:
    HOST localhost.localdomain

    zmcontrol status:
    Cannot determine service - exiting


  6. #6
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    Make sure your hosts file is configured properly.

    Do a search on how.

  7. #7
    Join Date
    Jul 2006
    Posts
    7
    Rep Power
    9

    Default

    I fix a problem:
    1. ./install.sh /u
    2. Remove all from /opt/zimbra/
    3. install packages by rpm -i
    4. /opt/zimbra/libexec/zmsetup.pm
    5. install by ./install.sh
    6. all is worked

    I don't know why it became work after this steps, nor after others (install /u , install), but it is worked now. Thanks to all.

Similar Threads

  1. zmprov mc default zimbraFeatureNotebookEnabled TRUE
    By nbhanji in forum Installation
    Replies: 11
    Last Post: 04-29-2008, 11:39 AM
  2. Can not reach https://example.com:7017/zimbraAdmin
    By Max Ma in forum Installation
    Replies: 14
    Last Post: 03-31-2007, 10:14 AM
  3. Replies: 26
    Last Post: 02-12-2007, 07:23 PM
  4. Problems: Fresh Zimbra on Fresh Debian
    By bronto in forum Installation
    Replies: 5
    Last Post: 09-11-2006, 07:14 PM
  5. Is it started or not
    By kwelipatton in forum Installation
    Replies: 10
    Last Post: 03-28-2006, 11:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •