I am using Zimbra Collaboration Suite 6.0 on Centos 5.4 x86_64 has worked perfectly as a replacement for our Exchange Server. I am trying to use Request Tracker on the same server as my Zimbra install and almost have everything running.

I referenced this wiki doc

Configuring Postfix to work with piped scripts - Zimbra :: Wiki

My zimbra setup uses @mydomain.com for general email request tracker I use @rt.mydomain.com. If send a message using user@mydomain.com to rt@rt.mydomain.com works fine.

If I use another domain like user@mac.com I get Relay access denied which makes sense. So I tried adding the domain rt.domain.com to the Zimbra admin and i get "Recipient address rejected: User unknown in virtual mailbox table" in response to emails. This all makes sence but even if I add the rt user I get the same message. My thoughts are the piped scripts work before the virtual mailbox.

So my question is how can I manually set this up so that rt.domain.com is correctly added to the config allowing incoming messages to be processed by the pipes.