Hi,

When starting the installation I get the message that tells me to fix the hosts file.

Code:
ERROR: Installation can not proceeed.  Please fix your /etc/hosts file
  to contain:

    

  Where  is the ip address of the host, 
   is the FULLY QUALIFIED host name, and
   is the (optional) hostname-only portion
I have gone through the documentation, I have followed the wiki on installing Zimbra in Ubuntu 8.04, but still getting same error. Any help would be GREATLY appreciatted since I am at a dead end.

There go my details:

- Zimbra 6.0
- Ubuntu 8.04 server 64 bits
- I'm installing this on Amazon EC2

Since it is Amazon EC2 I figured I should follow the split DNS route. So I followed the steps in the Main Page - Zimbra :: Wiki. I have all those files as the wiki says EXCEPT for /etc/resolv.conf that keeps getting back to default state after I reboot the server.

Also as forwarders in the /etc/bind/named.conf.options file I put the DNS servers I have from 1and1 where I bought my domain. I don't know their IPs so I wrote the name for them (ns64.1and1.es).

Anyway I don't think the error I get is related to those details, though.

There goes some more info:

CAT /ETC/HOSTS
Code:
127.0.0.1 localhost.localdomain localhost
#79.125.20.35 mail.cristianosuniversitarios.org mail  
#
# The following lines are desirable for IPv6 capable hosts
#::1 ip6-localhost ip6-loopback
#fe00::0 ip6-localnet
#ff00::0 ip6-mcastprefix
#ff02::1 ip6-allnodes
#ff02::2 ip6-allrouters
#ff02::3 ip6-allhosts
CAT /ETC/RESOLV.CONF
Code:
search eu-west-1.compute.internal
nameserver 172.16.0.23
After following the wiki,the above file was:
Code:
nameserver 10.227.127.144
But it changes back everytime I reboot the machine.

10.227.127.144 is my internal ip in the amazon ec2 internal network.
My public ip is different.

DIG CRISTIANOSUNIVERSITARIOS.ORG MX
Code:
; <<>> DiG 9.4.2-P2.1 <<>> cristianosuniversitarios.org mx
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 10927
;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;cristianosuniversitarios.org.	IN	MX

;; ANSWER SECTION:
cristianosuniversitarios.org. 815 IN	MX	10 mx00.1and1.es.
cristianosuniversitarios.org. 815 IN	MX	10 mx01.1and1.es.

;; Query time: 0 msec
;; SERVER: 172.16.0.23#53(172.16.0.23)
;; WHEN: Thu Feb 11 16:17:52 2010
;; MSG SIZE  rcvd: 96
I have not changed the MX fields in my domain provider, because I had no idea where to point them to. And I thought I had to install zimbra first and then point my domain MX to my zimbra server.

DIG CRISTIANOSUNIVERSITARIOS.ORG ANY
Code:
; <<>> DiG 9.4.2-P2.1 <<>> cristianosuniversitarios.org any
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 53926
;; flags: qr rd ra; QUERY: 1, ANSWER: 3, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;cristianosuniversitarios.org.	IN	ANY

;; ANSWER SECTION:
cristianosuniversitarios.org. 85281 IN	A	79.125.20.35
cristianosuniversitarios.org. 616 IN	MX	10 mx01.1and1.es.
cristianosuniversitarios.org. 616 IN	MX	10 mx00.1and1.es.

;; Query time: 0 msec
;; SERVER: 172.16.0.23#53(172.16.0.23)
;; WHEN: Thu Feb 11 16:21:10 2010
;; MSG SIZE  rcvd: 112
HOST `HOSTNAME`
Code:
ip-10-227-127-144.eu-west-1.compute.internal has address 10.227.127.144
Hope someone can help me out, thanks in advance!

Nacho