Results 1 to 8 of 8

Thread: smtp_sasl_password_maps

  1. #1
    Join Date
    Feb 2010
    Posts
    35
    Rep Power
    5

    Default smtp_sasl_password_maps

    Hi,

    I have the following problem
    I can't receive e-mail. When I send e-mail it just looks like everything is oke and the e-mail is delivered. But no one is receiving e-mail.
    This is what I see in my logfiles.


    zimbra postfix/smtp[12128]: fatal: specify a password table via the `smtp_sasl_password_maps' configuration parameter
    zimbra postfix/master[7924]: warning: process /opt/zimbra/postfix/libexec/smtp pid 12128 exit status 1
    zimbra postfix/master[7924]: warning: /opt/zimbra/postfix/libexec/smtp: bad command startup -- throttling




    Mar 19 15:27:45 zimbra postfix/postfix-script[8771]: warning: not owned by root: /opt/zimbra/data/postfix/spool
    Mar 19 15:27:45 zimbra postfix/postfix-script[8778]: warning: not owned by root: /opt/zimbra/postfix-2.6.5.2z/conf/main.cf
    Mar 19 15:27:45 zimbra postfix/postfix-script[8779]: warning: not owned by root: /opt/zimbra/postfix-2.6.5.2z/conf/master.cf
    Mar 19 15:27:45 zimbra postfix/postfix-script[8780]: warning: not owned by root: /opt/zimbra/postfix-2.6.5.2z/conf/master.cf.in
    Mar 19 15:27:45 zimbra postfix/postfix-script[8783]: warning: not owned by postfix: /opt/zimbra/data/postfix/./spool/pid/unix.retry
    Mar 19 15:27:45 zimbra postfix/postfix-script[8785]: warning: not owned by postfix: /opt/zimbra/data/postfix/./spool/pid/unix.showq
    Mar 19 15:27:45 zimbra postfix/postfix-script[8787]: warning: not owned by postfix: /opt/zimbra/data/postfix/./spool/pid/inet.smtp
    Mar 19 15:27:45 zimbra postfix/postfix-script[8796]: warning: not owned by postfix: /opt/zimbra/data/postfix/./spool/pid/inet.127.0.0.1:10025
    Mar 19 15:27:45 zimbra postfix/postfix-script[8798]: warning: not owned by postfix: /opt/zimbra/data/postfix/./spool/pid/inet.465
    Mar 19 15:27:45 zimbra postfix/postfix-script[8800]: warning: not owned by postfix: /opt/zimbra/data/postfix/./spool/pid/unix.lmtp
    Mar 19 15:27:45 zimbra postfix/postfix-script[8803]: warning: not owned by postfix: /opt/zimbra/data/postfix/./spool/pid/master.pid
    Mar 19 15:27:45 zimbra postfix/postfix-script[8804]: warning: not owned by postfix: /opt/zimbra/data/postfix/./spool/pid/unix.smtp
    Mar 19 15:27:45 zimbra postfix/postfix-script[8805]: warning: not owned by postfix: /opt/zimbra/data/postfix/./spool/pid/unix.defer
    Mar 19 15:27:45 zimbra postfix/postfix-script[8808]: warning: not owned by postfix: /opt/zimbra/data/postfix/./spool/pid/unix.bounce
    Mar 19 15:27:45 zimbra postfix/postfix-script[8810]: warning: not owned by postfix: /opt/zimbra/data/postfix/./spool/pid/unix.cleanup
    Mar 19 15:27:45 zimbra postfix/postfix-script[8811]: warning: not owned by postfix: /opt/zimbra/data/postfix/./spool/pid/unix.smtp-amavis


    Could anyone help me

  2. #2
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Has somebody not set up outgoing SMTP authentication correctly ? Have a read through Outgoing SMTP Authentication - Zimbra :: Wiki.

  3. #3
    Join Date
    Feb 2010
    Posts
    35
    Rep Power
    5

    Default

    Quote Originally Posted by uxbod View Post
    Has somebody not set up outgoing SMTP authentication correctly ? Have a read through Outgoing SMTP Authentication - Zimbra :: Wiki.
    I followed the steps till create a postfix lookup table. This is what i get returned.

    postmap: fatal: open /opt/zimbra/conf/relay_password: No such file or directory

    What should I do ?

  4. #4
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Did you create that file ? and once created run a postmap against it
    Code:
    su - zimbra
    postmap /opt/zimbra/conf/relay_password

  5. #5
    Join Date
    Feb 2010
    Posts
    35
    Rep Power
    5

    Default

    Yes I created that textfile as root and as zimbra, but it has nog effect still i get:

    postmap: fatal: open /opt/zimbra/conf/relay_password: No such file or directory

  6. #6
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    After running the postmap command did you restart Postfix ?

  7. #7
    Join Date
    Feb 2010
    Posts
    35
    Rep Power
    5

    Default

    zmcontrol stop
    zmcontrol start

    and this is what i get returned:

    postmap: fatal: open opt/zimbra/conf/relay_password: Permission denied

    permission denied? how come?

  8. #8
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Looks like you have a typo on /opt.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •